Subscribe

fcp_latency and iscsi_latency not showing any data in DFM

I'm running Netapp Oncommand 5.0.

I've created a custom view in DFM that shows the various latency types on a controller. for some reason cifs_latency shows data but iscis_latency and fcp_latency do not show any data. In the same custom view I have another graph that shows throughput per protocal and it shows data for every protocal. So their should be a latency associated with these protocals as well.

Any Ideas? I'm sure if this is a bug or what I'm missing something.

Re: fcp_latency and iscsi_latency not showing any data in DFM

What is the version of ONTAP against which these custom view is running ? Is the controller licensed for FCP and iSCSI ? Can you get the output of the following cli to verify the same.

dfm report view storage-systems-protocols

Regards

adai

Re: fcp_latency and iscsi_latency not showing any data in DFM

Yep, We are licensed for both. We are running 8.0.2P6 in 7-mode and 8.0.2P2 and 7.3.6P2. All have the same problem.

Thank you for your help

-Ian

Re: fcp_latency and iscsi_latency not showing any data in DFM

Hi Ian,

Are your LUNs >= 2TB?  If yes, you might be hitting Bug ID 444125 whereby some IOs are not captured correctly in the latency statistics.  You could do a test by creating a smaller LUN (< 2TB), start some load, and while it is active check the latency counter from the controller CLI using "stats show fcp" (or "stats show iscsi").  If it starts working then you have a good idea you are hitting this Bug.  I have also asked engineering to update the public report (it is blank at this moment) so you could also click the "WATCH THIS BUG" to get the updates when they are made.

Hope that helps,

Chris Madden

Storage Architect, NetApp EMEA

Re: fcp_latency and iscsi_latency not showing any data in DFM

Thanks Madden. But, no I don't have LUNs larger than 2TB. "stats show fcp" actaully shows data. (I didn't know about that command so that's nice to use.) It's only in Operations Manager where I don't see a graph for it.

Re: fcp_latency and iscsi_latency not showing any data in DFM

Hi Ian,

     Can you paste a screen shot of the custom views that you described in your initial post ?

Regards
Adai

Re: fcp_latency and iscsi_latency not showing any data in DFM

The line that you see is for CIFS latency

I also have throughput on the same view for some sort of corelation. The Line you see here is FCP throughput activity.