Subscribe

harvest graph

Recently installed the harvest, however Grafhana graph is not ight, netapp-harvest.conf is configured two filer.  one 7-mde and another is AFF CDOT.

I could find the graph but it does not show which sytem is belongs too. example in the group I could not drop down the menu, attaches the screen shot.

Not sure something wrong with netapp-harvest.conf file.

 

cat /opt/netapp-harvest/netapp-harvest.conf
##
## Configuration file for NetApp Harvest
##
## This file is organized into multiple sections, each with a [] header
##
## There are two reserved section names:
##  [global]  - Global key/value pairs for installation
##  [default] - Any key/value pairs specified here will be the default
##              value for a poller should it not be listed in a poller section.
##
## Any other section names are for your own pollers:
##  [cluster-name]     - cDOT cluster (match name from cluster CLI prompt)
##  [7-mode-node-name] - 7-mode node name (match name from 7-mode CLI prompt)
##  [OCUM-hostname]    - OCUM server hostname (match hostname set to system)

## Quick Start Instructions:
## 1. Edit the [global] and [default] sections and replace values in all
##    capital letters to match your installation details
## 2. For each system to monitor add a section header and  populate with
##    key/value parameters for it.
## 3. Start all pollers that are not running: /opt/netapp-harvest/netapp-manager start
##
## Note: Full instructions and list of all available key/value pairs is found in the
##       NetApp Harvest Administration Guide

##
#### Global section for installation wide settings
##
[global]
#grafana_api_key   = INSERT_LONG_KEY_HERE
#grafana_url       = INSERT_URL_OF_GRAFANA_WEB_INTERFACE_HERE
grafana_api_key = eyJrIjoiQUYzSlpYOVM0c2hwb21GZ1NucERtanlabngwT2pOelgiLCJuIjoibmV0YXBwLWhhcnZlc3QiLCJpZCI6MX0=
grafana_url = http://172.134.45.14:3000

##
#### Default section to set defaults for any user created poller section
##
[default]
#graphite_server   = INSERT_IP_OR_HOSTNAME_OF_GRAPHITE_SERVER_HERE
graphite_server   = 170.134.45.14
username          = netapp-harvest
password          = PAXXXXX

## If using ssl_cert (and not password auth)
## uncomment and populate next three lines
# auth_type         = ssl_cert
# ssl_cert          = INSERT_PEM_FILE_NAME_HERE
# ssl_key           = INSERT_KEY_FILE_NAME_HERE

##
#### Poller sections; Add one section for each cDOT cluster, 7-mode node, or OCUM server
#### If any keys are different from those in default duplicate them in the poller section to override.
##

[KRDFG]
hostname       = 172.134.45.10
group          = KM

[KRDFG2]
hostname       = 172.134.35.20
group          = KM2

# [INSERT_OCUM_SERVER_NAME_HERE]
# hostname          = INSERT_IP_ADDRESS_OR_HOSTNAME_OF_OCUM_SERVER
# group             = INSERT_GROUP_IDENTIFIER_HERE
# host_type         = OCUM
# data_update_freq  = 900
# normalized_xfer   = gb_per_sec

 

I could not find something wrong the logs.

 

------------------------------------------------

attaching polling log file for refernces

2017-01-27 14:52:38] [NORMAL ] [main] Poller will use [password] authentication                          with username [netapp-harvest] and password [**********]
[2017-01-27 14:52:38] [NORMAL ] [main] Collection of system info from [172.134.4                     .10] running [NetApp Release 8.2.4P5 7-Mode] successful.
[2017-01-27 14:52:38] [NORMAL ] [main] Found best-fit monitoring template (same                          generation and major release, minor same or less): [7dot-8.2.0.conf]
[2017-01-27 14:52:38] [NORMAL ] [main] Added and/or merged monitoring template [                         /opt/netapp-harvest/template/default/7dot-8.2.0.conf]
[2017-01-27 14:52:38] [NORMAL ] [main] Metrics will be submitted with graphite_r                         oot [netapp.perf7.KRDCG]
[2017-01-27 14:52:38] [NORMAL ] [main] Using graphite_meta_metrics_root [netapp.                         poller.perf7.KM.KRDCG]
[2017-01-27 14:52:38] [NORMAL ] [main] Startup complete.  Polling for new data e                         very [60] seconds.

-----------------------------------------------------

 

2017-01-27 14:52:38] [NORMAL ] [main] Poller will use [password] authentication with username [netapp-ha         rvest] and password [**********]
[2017-01-27 14:52:39] [NORMAL ] [main] Collection of system info from [172.134.35.20.] running [NetApp Rel         ease 8.3.2] successful.
[2017-01-27 14:52:39] [NORMAL ] [main] Found best-fit monitoring template (same generation and major rele         ase, minor same or less): [cdot-8.3.2.conf]
[2017-01-27 14:52:39] [NORMAL ] [main] Added and/or merged monitoring template [/opt/netapp-harvest/templ         ate/default/cdot-8.3.2.conf]
[2017-01-27 14:52:39] [NORMAL ] [main] Metrics will be submitted with graphite_root [netapp.perf.KRDFG2]
[2017-01-27 14:52:39] [NORMAL ] [main] Using graphite_meta_metrics_root [netapp.poller.perf.KRDFG2]
[2017-01-27 14:52:39] [NORMAL ] [main] Startup complete.  Polling for new data every [60] seconds.

 

-------------------------

attahced the screen shot, group I could not pull down the menu.

Re: harvest graph

Hi @babukish11

 

The config file and logs look ok to me.  

 

I did a search for the error and found https://github.com/grafana/grafana/issues/2180.  In that case he had no default datasource which caused this error.  The Harvest integration also requires your Graphite datasource to be set to default.  Can you go to your graphite data source and make sure the default checkbox is checked and then try to access again?

 

Cheers,
Chris Madden

Solution Architect - 3rd Platform - Systems Engineering NetApp EMEA (and author of Harvest)

Blog: It all begins with data

 

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO or both!