Subscribe
Accepted Solution

how to configure HA for WFA applicatio

Anyone can tell me the procedure of configuring HA for WFA application.

 

We have wfa server and many workflows running on it. If it fails we need to continue the service from cluster server.

 

 

Re: how to configure HA for WFA applicatio

 

MSCS - Microsoft Cluster Services.

 

Configuration is covered in the WFA Installation Guide:

https://library.netapp.com/ecm/ecm_download_file/ECMLP2597422

 


I hope this response has been helpful to you.

 

At your service,

 

Eugene E. Kashpureff, Sr.
Independent NetApp Consultant http://www.linkedin.com/in/eugenekashpureff
Senior NetApp Instructor, FastLane US http://www.fastlaneus.com/
(P.S. I appreciate 'kudos' on any helpful posts.)

Re: how to configure HA for WFA applicatio

Thanks for the information.

 Currently we have installed WFA in ESX VM on a Virtual disk.

To configure HA, do we need shared LUN?

If so , is it mandatory to add same Virtual disk where WFA installed on Server-A  to new VM we are building?

Shall we install WFA on different virtual disks on server-A & server-B and configure MSCS cluster for WFA High availability?

 

Re: how to configure HA for WFA applicatio

 

Yes, yes, and no - it's a shared LUN.

 

From the install doc:

 

Configuring MSCS to install Workflow Automation

Before you install Workflow Automation (WFA) in Microsoft Cluster Server (MSCS), you must configure your MSCS environment.

Before you begin
  • MSCS must be installed from the server manager.
  • Optional: SnapDrive for Windows must be installed.

    The minimum supported versions are Windows 2008 and 2012.

  • The same version of WFA must be installed using the same path on both the cluster nodes.
  • Both the cluster nodes must be added to the same domain.
About this task

You must complete this task by using Cluster Manager in the MSCS interface.

Steps
  1. Log in to Cluster Manager as a domain admin.
  2. Verify that the LUNs are accessible to both the nodes using one of the following options:
    • Managing the LUNs natively.
    • By using SnapDrive for Windows:
      1. Install and configure SnapDrive for Windows on both the nodes.
      2. Create a LUN using SnapDrive for Windows and configure the LUN for both the nodes.
  3. From Failover Cluster Manager, add the disk to the cluster.

 

Again, see 'Managing High Availability' in the 'Installation and Setup Guide for Windows' WFA documentation:

https://library.netapp.com/ecmdocs/ECMLP2597422/html/frameset.html

 


I hope this response has been helpful to you.

 

At your service,

 

Eugene E. Kashpureff, Sr.
Independent NetApp Consultant http://www.linkedin.com/in/eugenekashpureff
Senior NetApp Instructor, FastLane US http://www.fastlaneus.com/
(P.S. I appreciate 'kudos' on any helpful posts.)

 

 

 

 

 

 

 

 

Re: how to configure HA for WFA applicatio

I have a server running WFA which is installed on virtual disk (DSmiley Very Happyrive in server)

 

Option:A

Should i need to map the same virtual disk to my secondary node?

Will i be able to install WFA on secondary node using that shared drive?

 

Else,

 

Option:B

Should i get a seperate virtual disk to secondary node to install WFA application?

&

 a new virtual disk which is shared between both the primary & secondary node to configure High availability?