Subscribe

netapp.manage.NaAPIFailedException: Version 1.14 was requested, but only 1.13 is supported. (err

Hello , 

 

I am trying to invoke the "system-get-info" command and I get the error 

Caused by: netapp.manage.NaAPIFailedException: Version 1.14 was requested, but only 1.13 is supported. (errno=13010)

 

The nSeries involved is a type 6060 running Data ONTAP Release 8.0.1P3 7-Mode.

 

Can anyone help me?

 

Thanks in advance . 

Re: netapp.manage.NaAPIFailedException: Version 1.14 was requested, but only 1.13 is supported. (err

[ Edited ]

Hi @dragosh

 

Because you are running an older version of Data ONTAP it also only supports an older version of the API.  You can specify the version of API to use when you crate the NaServer object

 

From the SDK java docs:

 

NaServer
public NaServer(java.lang.String serverName,
                int majorVersion,
                int minorVersion)
         throws java.net.UnknownHostException
Create a server API object with server type SERVER_TYPE_FILER
 
Parameters: 
serverName - The name of the API server.
majorVersion - The major API version number required, for example "1" if version 1.0 is required.
minorVersion - The minor API version number required, for example "0" if version 1.0 is required.
For DataFabric Manager APIs, pass 1.0 as the major and minor version numbers. Throws: java.net.UnknownHostException - if the hostname is not known.

 

 

 

So simply update the major, minor to be 1, 13 and you should be able to connect to this older system.

 

 

Cheers,
Chris Madden

Storage Architect, NetApp EMEA (and author of Harvest)

Blog: It all begins with data

 

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO or both!

Re: netapp.manage.NaAPIFailedException: Version 1.14 was requested, but only 1.13 is supported. (err

Thanks , I will try that .