Subscribe

qtree capacity report not working

Hi Guys,

Just ran into a bit of an issue on my DFM server... I'm trying to generate a qtree growth report but, each time i select the qtree, the graph appears blank with no data, regardless of the time-frame i select.  I'm seeing this is only happening on random qtrees... and i will mention that the graphs for the containing volume are still working. This only appears to be on the random qtrees. 

has anyone ever run into this?

thanks,
Scott

Re: qtree capacity report not working

Hi Scott,

     Qtree growth reports and capacity reports work only if those qtrees have quotas set. Does the qtrees for which you dont see graph have quota set on filer ?

Regards

adai

Re: qtree capacity report not working

Hey Adai,

I do have quotas on for the qtree's in question... i will also mention that this is happening across multiple vfilers located on the same physical storage system.

thanks,
Scott

Re: qtree capacity report not working

Scott - which version of DFM?  Do the monitoring sample dates/times look good.  Had an issue similar to this when running an older version of DFM when we modified our sample rates to run too often.

Re: qtree capacity report not working

Hey Josh,

I'm running 5.0.2 (64-bit / rhel 5.6).  the samples are set to the default out of the box.. i've not made any changes to the polling intervals.

I do notice that with 'dfm host diag <vfiler>' that 'qtreeTimestamp' is blank and not showing 'last updated' and 'status' is blank....can that be kicked off manually?

thanks,
Scott

Re: qtree capacity report not working

Hi Scott,

     The DFM never talks to vfiler to collect data, instead it always does it via the physical filer. What is the version of Ontap is that system running ? Do you see any errors in your dfmmonitor.log with respect to the qtree in question ?

Regards

adai

Re: qtree capacity report not working

  Hey Adai,

 

Just had a peek at the dfmmonitor.log and noticed a bunch of error on the specific vfiler I’m having issue with..... below are the2 msg's that repeat.

Oct 20 20:54:28 [dfmmonitor:ERROR]: [10733:0x42709940]: Unable to execute vfiler run <vfiler> quota report -stx for host <filer>:ssh_exchange_identification: Connection closed by remote host

 

Oct 20 21:15:27 [dfmmonitor: INFO]: [10733:0x42002940]: uqmon_vfiler_job_lookup: <vfiler>:/vol There is a vfiler userquotamon job running for the host <filer>.

One thing I will mention is that I hit a Burt on the hosting viler where my ssh sessions are maxed out and can no longer run ssh cmd's against the filer (burt#514876)... looking at the errors, it would appear that this is a contributing factor...

 

I thought I’d be sneaky and flip from ssh to rsh but, when i now run 'dfm host diag' i'm seeing an error on rsh 'exec: No such file or directory'.... i also notice that 'qtreeTimestamp' still has a blank 'last updated' and 'status'.

any thoughts?

Thanks,
Scott