Subscribe
Accepted Solution

timeout https setting up ad account

Getting Connection to vbrpofil001 on port 443 for protocol HTTPS timed out in WFA when setting up an AD account. The AD account is created but the workflow says failed and doesn't proceed to the next step.

Re: timeout https setting up ad account

You need to provide enough access permission to the WFA service account for certain folders, else it can't work.

what's the verion of ontap and WFA?

 

thanks

 

Jeff

Cannot find the answer you need?  No need to open a support case - just CHAT and we’ll handle it for you.

Re: timeout https setting up ad account

what permissions do you mean? The account used for creating AD accounts is the same that i use when doing this manaully. The timeout it get is a timeout to the filer and not to the AD. I've also opend an support case for this issue.

Re: timeout https setting up ad account

The problem could be reproduced using standard powershell. When setting the timeout connecteion in powershell to 5 minutes the problem was solved. So i've edited the command in WFA and added the timeout parameter to the following line


Connect-WfaCluster -Node $Cluster -Vserver $StorageVirtualMachineName -timeout 300000

Re: timeout https setting up ad account

@Sebastiaan

 

So i've edited the command in WFA and added the timeout parameter to the following line


Connect-WfaCluster -Node $Cluster -Vserver $StorageVirtualMachineName -timeout 300000

 

-----------------

 

Fine if this worked for you, but I would say you don't need to edit a command to provide a non-default timeout. Besides editing the command code means connection to all clusters will use this increased timeout value while your problem I assume is with this very cluster only.

 

 

You can modify the connection timeout values in WFA-Credentials for this cluster.

 

See below, I've modified the timout to 600 sec for this cluster.

 

 

NOTE: This is only available in WFA4.0 and above

 

Credentials_override.png

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: timeout https setting up ad account

@sinhaa

 

The command I've modified is an copy of the original, so I selected this only when using this specific command. The timeout isn't specific for the cluster it's the domain where the svm resides that's the problem. Other domains for this cluster have no issue. If the problem was with the cluster your option is better.