Accepted Solution

wfa_ocsetup failed with bad interpreter :-o

successfully downloaded the file from WFA path (Windows 2008) with wget

tried to execute this and it failed with

[root@dfm opt]# chmod +x

[root@dfm opt]# ./ /opt/NTAPdfm/java/

-bash: ./ /bin/sh^M: bad interpreter: Datei oder Verzeichnis nicht gefunden

so if i try to convert the LF to unix, i ran into the next problem

[root@dfm opt]# dos2unix

dos2unix: converting file to UNIX format ...

[root@dfm opt]# ./ /opt/NTAPdfm/java/

Verifying  archive integrity...Error in MD5 checksums:  e2525ac8b2295dec74d9694748c5f341 is different from  e7e365e7e9a05cc12f3b0180bda85667

any idea how to fix this ??

Re: wfa_ocsetup failed with bad interpreter :-o

-bash: ./ /bin/sh^M: bad interpreter: 

Shows that you have dos line ending files format. dos2unix cmd is a way, but since it didn't work for you, Can you try the following:

1. Open the in vi editor and in the vi Command mode (ESC ) type the following:

:set fileformat=unix

And Save the file using x! or wq!

or Save As with :w

2. If (1) didn't work try this:

cat | tr -d '\r' >

Now re-run the cmd ./ /opt/NTAPdfm/java/

I hope this works

Abhishek Sinha


Re: wfa_ocsetup failed with bad interpreter :-o

Ignore the above solution, it doesn't work. Good thing is I managed to reproduce your problem and but bad thing is in the process screwed my working system too and I haven't figured out how to fix it now. Working on it.

I think its some environment variable with bash which always sets dos EOL. dos2unix changes the md5sum of the file and hence the execution fails.

Re: wfa_ocsetup failed with bad interpreter :-o


    There is apparently something wrong with the the file attached to the WFA 2.1 server. Its using a dos EOL.

Download the file attached here and try, I think should work fine. This is from WFA 2.0.1 version.

I'll file a bug to get it fixed. We regret your inconvenience.

warm regards,



NetApp Inc.

Re: wfa_ocsetup failed with bad interpreter :-o

hi sinhaa, many thanks for this helpful answer and the fully functioning i think this should be corrected by netapp itself :-o