Accepted Solution

All SSD based vsim

I run most of my vsims on my macbook pro with an internal SSD.  I wondered if I could run a VSIM (single node cluster) with all SSD's.  So, I imported the OVA, interrupted the boot process to get into the bootloader and proceeded to modify the vsim drives using vdevinit=35:14:0,35:14:1 and when it boots it loses its mind and says that this type of machine isn't allowed to use shared disks.  Anyone know the secret sauce to make this work?  I tried setting the setnev var root-uses-shared-disks? to true and that doesn't work either.  I know this isn't intended with the vsim but man it sure would be nice to have.



Re: All SSD based vsim

The simulated disks don't support being partitioned, so they can't be shared either ADP style or as an SSD storage pool.  But you should still be able to bring up the sim with just SSD disk types.  You may want to populate all 56 slots though because 500mb/disk doesn't yield very much capacity, and you'll need to add several to the root aggregate to keep it from filling up and falling over.


However it will not behave like an AFF because vsims will not currently boot in flash optimized mode, so AFF specific features wil still not be available.



If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: All SSD based vsim

I did 4 shelves of all flash and still doesn't work.  Unable to connect to Management Gateway Server.  Ultimately asks if I want to login as the diag user.  I'm thinking there is a vloader env that I must need to make this work. 

Re: All SSD based vsim

Which version of ontap are you trying it in?

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: All SSD based vsim


Re: All SSD based vsim

I was able to bring one up, but it took a little intervention.


When I first tried to create the cluster I got


.Jan 17 12:13:24 [demossd-01:boot.varfs.backup.issue:EMERGENCY]: Backup of the /var file system failed (cp: /mroot/etc/tmpvarfs.tgz: No space left on device
varfs_backup_restore: Failed to backup /var to mroot
Trying to create cluster again as previous attempt failed. .Error: The node root volume is not available. Contact support personnel for the repair procedure. 

My root aggr was only 427MB



demossd-01::> aggr status
Warning: Only local entries can be displayed at this time. 

Aggregate     Size Available Used% State   #Vols  Nodes            RAID Status
--------- -------- --------- ----- ------- ------ ---------------- ------------
aggr0      427.5MB   21.05MB   95% online       1 demossd-01       raid_dp,

And that didn't leave much space on vol0



demossd-01::> run local df -h
Filesystem               total       used      avail capacity  Mounted on
/vol/vol0/               382MB      151MB      231MB      40%  /vol/vol0/
/vol/vol0/.snapshot       20MB      296KB       19MB       1%  /vol/vol0/.snapshot

So I added some disks



demossd-01::> run local
Type 'exit' or 'Ctrl-D' to return to the CLI
demossd-01> disk assign all
demossd-01> aggr add aggr0 3@500MB

And expanded vol0 a bit

demossd-01> vol size vol0 1560m
vol size: Flexible volume 'vol0' size set to 1560m.


demossd-01> reboot
reboot not found. Type '?' for a list of commands.
demossd-01> exit

demossd-01::> reboot
  (system node reboot)

Warning: Are you sure you want to reboot node "demossd-01"? {y|n}: y

And cluster setup completely successfully on the next try

ssdemo::> cluster show
Node                  Health  Eligibility
--------------------- ------- ------------
ssdemo-01             true    true
If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: All SSD based vsim

I tried again today on a brand new vsim and I was able to get it to work.  I had been doing a 4a each time (just habbit from the old days) and this seemed to have been the issue.  This time I just did a 4 at the boot menu and it came up with all SSD's.  It still complained about not being able to do ADP but it worked.  I have 56 500GB SSD in my vsim.  I will definately add more drives to root aggr and increase my vol0 like you suggested here.  But it really seems that my old school habbit of typing 4a for a wipe instead of just plain 4 was the culprit.



Re: All SSD based vsim

That is funny. I was noting the other day that I can detect old-school'ers ... they are the folks who when telling a story about what they did say: "I 4a'ed the the system" :-) 


I guess it sounds like the menu still accepts 4a as a valid input ... ??? ... but may not be a good thing to do.