Community

Subscribe
Highlighted
Accepted Solution

OnTap Simulator 8.1.1 no longer running on ESXi 5.1 free

[ Edited ]

I'm the only one with this issue? After upgrade of my ESXi host to 5.1 the OnTap Simulator 8.1.1 no longer work. I only get the follwoing error:

 

Cannot open the disk '/vmfs/volumes/<id>/vsim-DOT811-7m/DataONTAP-sim.vmdk' or one of the snapshot disks it depends on.

The system cannot find the file specified

VMware ESX cannot find the virtual disk "/vmfs/volumes/<id>/vsim-DOT811-7m/DataONTAP-sim.vmdk". Verify the path is valid and try again.

 

Before the Update everything worked without any issue. The vmdk Files are there, it also not works if i manually assign those disk files. I have also never made any snapshots, this cannot be the problem.

A re-download of the Simulator files and add to the Host, get the same issue.

Re: OnTap Simulator 8.1.1 no longer running on ESXi 5.1 free

Same problem here. I also tried upgrading VM hardware but no success.

Re: OnTap Simulator 8.1.1 no longer running on ESXi 5.1 free

Ok, then let's hope NetApp is working on this issue.

Re: OnTap Simulator 8.1.1 no longer running on ESXi 5.1 free

Hi Roland,

           I got it working! The trick is in the name of the disk itself. Here's how I got it working. I think step 4, 5 and 6 is more relevant. Thanks.

1. Install vmware-workstation on my desktop (version 9)

2. add netapp 8.1.1 ESX version (vsim-DOT811-7m-esx) as VM to my vmware-workstation

3. right click manage and change hardware compatibility to workstation 9,,,

4. right click settings -> select harddisk 4 -> click utitlies -> compact

5. export as OVF template

6. import this OVF template to ESX5.1 (from web client) giving it a new name ie. test1

7. power on!

Regards,

Chakrit

Re: OnTap Simulator 8.1.1 no longer running on ESXi 5.1 free

Hi Chakrit

Can you perhaps place the vmx file here, especially the Disk Part? And how are the Disk named now?

Re: OnTap Simulator 8.1.1 no longer running on ESXi 5.1 free

Hi Roland,

         Sure thing,, but sadly to say it boots up and let me do the config but then kernel panic out. I'm out of ideas, sorry.

-rw-------1 root root 1677721600 Oct  2 10:14 test1-73bb8b70.vswp
-rw-------1 root root 5370806272 Oct  2 10:37 test1-flat.vmdk
-rw-------1 root root      8684 Oct  2 10:38 test1.nvram
-rw-------1 root root       487 Oct  2 10:16 test1.vmdk
-rw-r--r--1 root root         0 Oct  2 10:10 test1.vmsd
-rwxr-xr-x1 root root      1751 Oct  2 10:14 test1.vmx
-rw-------1 root root         0 Oct  2 10:14 test1.vmx.lck
-rw-r--r--1 root root       260 Oct  2 10:10 test1.vmxf
-rwxr-xr-x1 root root      1728 Oct  2 10:14 test1.vmx~
-rw-------1 root root 268435456000 Oct  2 10:38 test1_1-flat.vmdk
-rw-------1 root root       490 Oct  2 10:15 test1_1.vmdk
-rw-------1 root root 1108344832 Oct  2 10:38 test1_2-flat.vmdk
-rw-------1 root root       487 Oct  2 10:15 test1_2.vmdk
-rw-------1 root root 1616904192 Oct  2 10:38 test1_3-flat.vmdk
-rw-------1 root root       487 Oct  2 10:16 test1_3.vmdk
-rw-r--r--1 root root    193589 Oct  2 10:38 vmware.log
-rw-------1 root root  96468992 Oct  2 10:14 vmx-test1-1941670768-1.vswp

Regards,

Chakrit

Re: OnTap Simulator 8.1.1 no longer running on ESXi 5.1 free

Ok, thanks for the Info. So we have to see how we can fix this issue.

Re: OnTap Simulator 8.1.1 no longer running on ESXi 5.1 free

I can confirm this behaviour. I just put esx 5.1 on my server at home and tried to get the 8.1.1 simulator working. It came back with exactly the error you are reporting.

Looks like a 5.1 compatible release is needed.

Steve

Re: OnTap Simulator 8.1.1 no longer running on ESXi 5.1 free

Everyone I have the fix. It's a VMWare issue. By default ESXi 5.1 does not load the the vmkernel multiextent module. See the KB Below.

http://kb.vmware.com/selfservice/search.do?cmd=displayKC&docType=kc&externalId=2036572&sliceId=1&docTypeID=DT_KB_1_1&dialogID=448358018&stateId=1%200%...

The Fix: all you have to do is ssh into your host and  run this command from the cli: 

# vmkload_mod multiextent

The other stuff in this article didn't apply to me. All I had to do was run this command and my ONTAP Sims booted like usual, no issues. Unfortunately after a ESXi host reboot the multiextent module unloads and you have to perform this again to get your Sims to boot. If anyone can find a way to make this persistent with a switch or write a script that makes it load upon host reboot. I'm sure everyone would be very thankful.

Re: OnTap Simulator 8.1.1 no longer running on ESXi 5.1 free

This has certainly resolved the issue for me. Thank you.