Subscribe

panic - no hostbridge(s) detected in SK process main-_proc on release 8.2 (C)

 

 

I'm using Virtualbox 5.0.10r -

 

and the 8.2 simulator, and I can't seem to get all the way to the boot menu.

 

I have 2 processors, and 4764 MB ram allocated to the VM.

 

I get other errors  - no debug ports present.

 

 step 1.png

 

step2.png

 

step3.png

 

 

 

I have adjusted the boot loader vis these arguments: 

 

setenv bootarg.init.low_mem 512
setenv bootarg.vnvram.size 64
setenv nvram_discard true

 

Not sure what else to try. 

Re: panic - no hostbridge(s) detected in SK process main-_proc on release 8.2 (C)

You shouldn't need those bootargs on 8.2.  low_mem is already set at 512 in the download, and the nvram is in fake mode so the other two do not apply.  Also 8.2 shouldn't need that much ram. The vmx in the download has it set to 1600MB. Thats a little skimpy but 3gb is probably sufficient

 

Aside from that its probably something wrong in the vm definition.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: panic - no hostbridge(s) detected in SK process main-_proc on release 8.2 (C)

Okay, deleting it and starting over.

Re: panic - no hostbridge(s) detected in SK process main-_proc on release 8.2 (C)

For VirtualBox VM, I have the following network settings for my NICs. Do not use 'Bridged Adapter'. Do use 'Host-only Adapter' so you can set specific IP addresses. Make sure to use Adapter Type 'Intel PRO/1000 MT Server (8245EM)'.

 

NIC 1: MAC: 080027DC058B, Attachment: Host-only Interface 'VirtualBox Host-Only Ethernet Adapter', Cable connected: on, Trace: off (file: none), Type: 82545EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none
NIC 2: MAC: 0800274003B8, Attachment: Host-only Interface 'VirtualBox Host-Only Ethernet Adapter', Cable connected: on, Trace: off (file: none), Type: 82545EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none
NIC 3: MAC: 08002748C6D4, Attachment: Host-only Interface 'VirtualBox Host-Only Ethernet Adapter', Cable connected: on, Trace: off (file: none), Type: 82545EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none
NIC 4: MAC: 0800276532D6, Attachment: Host-only Interface 'VirtualBox Host-Only Ethernet Adapter', Cable connected: on, Trace: off (file: none), Type: 82545EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none
NIC 5: MAC: 080027EEF9D8, Attachment: Host-only Interface 'VirtualBox Host-Only Ethernet Adapter', Cable connected: on, Trace: off (file: none), Type: 82545EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none
NIC 6: MAC: 08002762C4D5, Attachment: Host-only Interface 'VirtualBox Host-Only Ethernet Adapter', Cable connected: on, Trace: off (file: none), Type: 82545EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none

 

This is what NICs look like after successful install of NetApp Sim 8.2.2 on VirtualBox:

 

c1::> net int show

(network interface show)
            Logical    Status     Network            Current       Current Is
Vserver     Interface  Admin/Oper Address/Mask       Node          Port    Home
----------- ---------- ---------- ------------------ ------------- ------- ----
c1
            cluster_mgmt up/up    10.10.1.80/24      c1-01         e0c     true
c1-01
            clus1        up/up    169.254.17.11/16   c1-01         e0a     true
            clus2        up/up    169.254.210.87/16  c1-01         e0b     true
            mgmt1        up/up    10.10.1.81/24      c1-01         e0f     true
vs1
            c1-01_iscsi_lif_1
                         up/up    10.10.1.85/24      c1-01         e0c     true
            c1-01_iscsi_lif_2
                         up/up    10.10.1.86/24      c1-01         e0d     true
            vs1_admin_lif1
                         up/up    10.10.1.84/24      c1-01         e0e     true
7 entries were displayed.

c1::> net port show
(network port show)
                                      Auto-Negot  Duplex     Speed (Mbps)
Node   Port   Role         Link MTU   Admin/Oper  Admin/Oper Admin/Oper
------ ------ ------------ ---- ----- ----------- ---------- ------------
c1-01
       e0a    cluster      up   1500  true/true   full/full  auto/1000
       e0b    cluster      up   1500  true/true   full/full  auto/1000
       e0c    data         up   1500  true/true   full/full  auto/1000
       e0d    data         up   1500  true/true   full/full  auto/1000
       e0e    data         up   1500  true/true   full/full  auto/1000
       e0f    node-mgmt    up   1500  true/true   full/full  auto/1000
6 entries were displayed.

 

Hope you follow link: http://community.netapp.com/t5/Simulator-Discussions/Simulate-ONTAP-8-1-1-withVirtualBox/m-p/2227 for insight to setup NetApp Sim on VirtualBox.