Subscribe
Highlighted
Accepted Solution

simulator license problem

Hello,

I hope, someone can help.

I have installed a two node cdot cluster in ESX.

On the system manager on the "license" GUI  I get following error:

 

"Data ONTAP API Failed :Loop detected in next() for table compliance_status. Next on "NFS 1-81-0000000000000004082368511" returned "NFS 1-81-0000000000000004082368511". (Error: 13001) "

 

no licenses are listed at all. 

 

I have the same problem with ontap 8.3.2  and ontap 9.0.

On the Clustershell  I wanted to create a  flex clone.  first I added the simulator flexclone license. But creation of a flexclone does not work because the system dont find any license.

 

Another info: In the Moment when i created a cluster with the first node,  I  found out, that the "License" Gui on the systemmanager is ok . no Errors.But as soon I joined the second node in the cluster, than I get the error.

"Data ONTAP API Failed :Loop detected in next() for table compliance_status. Next on "NFS 1-81-0000000000000004082368511" returned "NFS 1-81-0000000000000004082368511". (Error: 13001) "

 

Can you help?

Thank you.

Re: simulator license problem

 

Did you change the serial # of the second node at the LOADER firmware prompt before you  joined it into the cluster ?

 


I hope this response has been helpful to you.

 

At your service,

 

Eugene E. Kashpureff, Sr.
Independent NetApp Consultant http://www.linkedin.com/in/eugenekashpureff
Senior NetApp Instructor, FastLane US http://www.fastlaneus.com/
(P.S. I appreciate 'kudos' on any helpful posts.)

Re: simulator license problem

Licenses are node locked to the serial number of the controller.  It looks like you are using the license key for serial number 4082368511, so check that it matches the serial number of your node.

demo::> node show -fields serialnumber 
node  serialnumber 
----- ------------ 
demo9 4082368-51-1 

 

The cluster base license key has to be installed first, so check that as well.

 

demo::> license show
  (system license show)

Serial Number: 1-80-000008
Owner: demo
Package           Type     Description           Expiration
----------------- -------- --------------------- -------------------
Base              license  Cluster Base License  -

If both of those check out, you should be able to add feature keys from either the GUI or the CLI,.

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: simulator license problem

Thank you much.  With your Hints  I found the solution.

Re: simulator license problem

 

 
 

Re: simulator license problem

Start by running these commands and posting the output:

node show -fields serialnumber

system license show -instance

system license status show

The first will tell us the serial number(s) of your node(s)

 

The second will tell us which licenses have been installed.

 

The third will tell us which features were successfully licensed..

 

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: simulator license problem

Hi,

I had the problem , because i forgot to configure the point  "configuring serial number and system ID for the second node"  of the pdf "Simulate_ONTAP_9.0_Installation_and_Setup_Guide.pdf

Each Simulate ONTAP node in a cluster must have a unique System ID....

By.

Atilio.

Re: simulator license problem

Hi, follow the detail:

 

show -fields serialnumber:

 

node show -fields serialnumber -node CL-TEST-01
node serialnumber
---------- ------------
CL-TEST-01 4082368-51-1

 

CL-TEST::> node show -fields serialnumber -node CL-TEST-02
node serialnumber
---------- ------------
CL-TEST-02 4082368-51-1

 

 

CL-TEST::>
CL-TEST::> system license show -instance

Serial Number: 1-80-000008
Package: Base
Owner: CL-TEST
Expiration Date: -
Description: Cluster Base License
Type: license
Legacy: no
Customer ID: none

Serial Number: 1-81-0000000000000004082368511
Package: NFS
Owner: CL-TEST-02
Expiration Date: -
Description: NFS License
Type: license
Legacy: no
Customer ID: none

Serial Number: 1-81-0000000000000004082368511
Package: CIFS
Owner: CL-TEST-02
Expiration Date: -
Description: CIFS License
Type: license
Legacy: no
Customer ID: none

Serial Number: 1-81-0000000000000004082368511
Package: iSCSI
Owner: CL-TEST-02
Expiration Date: -
Description: iSCSI License
Type: license
Legacy: no
Customer ID: none
4 entries were displayed.

 

 

CL-TEST::> system license status show
Package Licensed Method Expiration
----------------- --------------- --------------------
Base license -
NFS license -
CIFS license -
iSCSI license -
FCP none -
SnapRestore none -
SnapMirror none -
FlexClone none -
SnapVault none -
SnapLock none -
SnapManagerSuite none -
SnapProtectApps none -
V_StorageAttach none -
SnapLock_Enterprise
none -
Insight_Balance none -
OCShift none -
16 entries were displayed.

 

thanks

Antonio

 

 

 

Re: simulator license problem

It would appear that both of your nodes have the same serial number. Try building a new pair, but make sure the second node uses a different serial number and system id than the first.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.