Community

Subscribe
Highlighted

Error: vmw-00139 VIBE plug-in module not supported with this version of ONTAP

Hi.

When trying to create a backup with SnapCreator of a volume which is used for VMware I get the following message in the log

vmw-00139 VIBE plug-in module not supported with this version of ONTAP

The Netapp Filer is FAS2020 which is on the 7.3.x release (not 8.x for 2020).

Is it really true that 7.3.x is not supported by VIBE? Since when? I had VIBE in use earlier at customers with 7.x releases.

Any ideas?

Regards,

Marc

Re: Error: vmw-00139 VIBE plug-in module not supported with this version of ONTAP

I have reached out to Snap Creator QA team on this.

I shall update this thread soon.

Re: Error: vmw-00139 VIBE plug-in module not supported with this version of ONTAP

The version of ONTAP in your case is a minor-version of 9, which is 7.3.1 (or earlier).  We support 7.3.3 or greater (it has to at least be an API minor-version of 11).  The net-ifconfig-get API call wasn't supported with earlier API calls which meant we couldn't figure out where the VMware Datastores were being mounted from based on the network configuration (for NFS).  As a result we required at least an API version of 11 so the API call we needed was available.

You can test this on your controllers by using the command:

priv set -q advanced ; ontapi execute "<net-ifconfig-get></net-ifconfig-get>"

This would tell you if you can run VIBE based on your existing 7.3 version level.  If the API call isn't listed (you see the message "Unable to find API"), it isn't supported.

--Matt