Community

Subscribe
Highlighted

Global config file ignored in GUI operations in SC 4.0P1

Hello,

we're attempting to start using version 4.0P1 of Snapcreator, Linux architecture. There, however, we experience strange behaviour of root global config file not being applied in some GUI operations - like deleting snapshots, clones. Those GUI operations end up with errors like "Controller X.X.X.X has no username defined in config file, Exiting". That's not true, however, and the same operation completes successfully when done via Snapcreator CLI.

As the vfiler credentials are set and enabled only in root global file and we only have small subset of application-specific parameters defined in the profile global and application config file, it makes me feel that the global file parsing is not working as it was in 3.6. There we've been using the configuration file hieararchy of "root global << profile global << config file".

We have set the parameter USE_GLOBAL_CONFIG=Y in all global and non-global configuration files.

Is this global config processing working to anybody in GUI operations on 4.0P1?

Greetings,

--

Lukas Kubin

Re: Global config file ignored in GUI operations in SC 4.0P1

Hello Lucas,

Let me test this behavior in the lab and get back to you.

Thanks,
Siva Ramanathan

Re: Global config file ignored in GUI operations in SC 4.0P1

Thanks Siva, that would be great if someone skilled could confirm whether that's a bug or just our misconfiguration.

Not to vaste your time, please be aware that we've also opened a support request 2004630525 before some weeks, without real progress so far. Maybe if you could join forces with the support team, it would help us to proceed.

Thanks for your interest and best greetings,

Lukas Kubin

Re: Global config file ignored in GUI operations in SC 4.0P1

Sure. I shall take a look at the support case and work on this.