Community

Subscribe
Highlighted

SnapCreator Plugin "Cache" SoapFault

Sometimes we get the following error... after we restared the agent service everything work fine for a few days until it happens again.

Snap Creator Framework 4.0p1

### Snap Creator Framework 4.0p1

NetApp Release 8.1.2P4

########## Application Quiesce ##########

[2013-08-30 13:00:02,107] ERROR: SCF-00037: Application quiesce for plugin [CACHE] failed with error [org.apache.cxf.binding.soap.SoapFault: Can't call method "references" on an undefined value at /<C:\Program Files\NetApp\Snap_Creator_Framework\scAgent4.0p1\snapcreator.exe>SOAP/Lite.pm line 2799.

] and exit code [-1], Exiting!

Does anyone has an idea to resolv this issue?

Regards

Benny

Re: SnapCreator Plugin "Cache" SoapFault

Looks like a SOAP communication issue, under certain conditions or at times it appears the CACHE plugin returns an invalid result type back to SC server. You can try with SC 3.6P1 as this was more lenient toward SOAP message formulation, however ultimately this appears to be a plugin issue.

I will look into plugin and see if I can find anything

Regards,

Keith

Re: SnapCreator Plugin "Cache" SoapFault

Thank for reply!

We use some more Plugins and did the Update from 3.6 to 4.0 a few weeks ago. At the moment its difficult to do the downgrade.

Did you find something in the plugin?

Regards,

Benny

Re: SnapCreator Plugin "Cache" SoapFault

Hello Benny,

Please email a scdump output to sivar at netapp.com

I shall review the logs and get back to you asap.

Thanks,

Siva Ramanathan

Re: SnapCreator Plugin "Cache" SoapFault

Hi Siva Ramanathan,

I have a similar error with the MAXDB plugin at another customer (first occurrence after customer upgraded to SC 4.0P1):

[2013-08-28 10:35:34,790] ERROR: SCF-00037: Application quiesce for plugin [maxdb] failed with error [org.apache.cxf.binding.soap.SoapFault: Can't call method "references" on an undefined value at /<C:\Program Files\NetApp\Snap_Creator_Framework\scAgent4.0p1\snapcreator.exe>SOAP/Lite.pm line 2799.

For me this looks like it is not a plugin issue but a general SOAP problem. I can mail you two SCDUMPs if you find that helpful. Just let me know if you'd like them.

Regards,

Tobias

Re: SnapCreator Plugin "Cache" SoapFault

Hi,

do you have any update on this matter?

Best regards

Tobias

Re: SnapCreator Plugin "Cache" SoapFault

Tobias,

I don't have an update yet.

If you want me to review this with you over a webex session, I can schedule one for you.

Please email me your availability next week to sivar at netapp.com

Thanks,
Siva Ramanathan

Re: SnapCreator Plugin "Cache" SoapFault

Hi,

we have got now three issues at three customers with the same error:

[2013-08-28 10:35:34,790] ERROR: SCF-00037: Application quiesce for plugin [maxdb] failed with error [org.apache.cxf.binding.soap.SoapFault: Can't call method "references" on an undefined value at /<C:\Program Files\NetApp\Snap_Creator_Framework\scAgent4.0p1\snapcreator.exe>SOAP/Lite.pm line 2799.

] and exit code [-1], Exiting!

The error occurs at different plugins (Cache, maxDB) and always the agent chrashes.

We need assistence...

Could you find some further informations?

Regards Benjamin

Re: SnapCreator Plugin "Cache" SoapFault

BURT 761317 has been opened and this has been escalated so it is being looked at. We arent able yet to reproduce problem but hopefully soon we will and then we can provide a fix or make recommendation for workaround.

If you could provide all the environment details and steps to reproduce this error that would be helpful? Especially interesting would be if perl is installed on these systems and if so what version? Does this happen on only windows systems or unix? Is there some pattern here that can be recognized?

As for workaround: I heard from the BURT case that SC 3.6 P1 does not have this issue so if you are in a pinch and need to get something working asap I would go that route until this issue is resolved.

Regards,

Keith

Re: SnapCreator Plugin "Cache" SoapFault

Oh and another thing to try I forgot to mention is set this in config:

PLUGIN_RESULT_FILTERING_ENABLE=Y

SC 4.0 server is using cxf which is very strict with SOAP message handling and the SC Agent is using Perl which isnt a strict. This option basically will ensure the Agent filters anything out of response that plugin might be adding which shouldnt be there.

I dont know that this will fix issue but please test this, it would help us tremendously to know.

?

Thanks!

Keith