Community

Subscribe
Highlighted
Accepted Solution

Snapcreator 4 upgrade from 3.6 errno=13008

HI,

Just tried to upgrade to Snapcreator 4 upgrade from 3.6 as per Install guide, got it going however when running a schedule now getting this error. It seems it's expecting a snapvault primary license on the snapvault destination filer? Any ideas? Same config file worked/works fine with 3.6

(attached full out log as some snapvault status commands seem to have worked?)

########## Running Snapvault Update on destination backup-filer1:/vol/sv_cloud_BT_syd_001/vnfs_bt2 using snapshot DailySnapvault-daily_20130604170334 ##########

[2013-06-04 17:03:50,461] INFO: STORAGE-02120: Updating SnapVault relationship [/vol/vnfs_bt2] based on Snapshot copy [DailySnapvault-daily_20130604170334].

[2013-06-04 17:03:50,461] INFO: STORAGE-02121: Updating SnapVault relationship [/vol/vnfs_bt2] based on Snapshot copy [DailySnapvault-daily_20130604170334] finished successfully.

[2013-06-04 17:03:50,602] INFO: STORAGE-02110: Retrieving SnapVault status.

[2013-06-04 17:03:50,602] ERROR: com.netapp.snapcreator.storage.executor.ZapiExecutorException: netapp.manage.NaAPIFailedException: Api snapvault-primary-relationship-status-list-iter-start requires license for sv_ontap_pri (errno=13008)

          at com.netapp.snapcreator.storage.executor.ZapiExecutorImpl.run(ZapiExecutorImpl.java:62)

          at com.netapp.snapcreator.storage.api.ontap.Ontap7ModeApi.snapVaultStatus(Ontap7ModeApi.java:1263)

          at com.netapp.snapcreator.storage.StorageCoreImpl.snapVaultGetStatus(StorageCoreImpl.java:926)

          at com.netapp.snapcreator.workflow.task.ZAPITask.snapVaultWait(ZAPITask.java:337)

          at com.netapp.snapcreator.workflow.task.ZAPITask.snapVaultUpdate(ZAPITask.java:728)

          at com.netapp.snapcreator.workflow.task.SnapVaultTask.execute(SnapVaultTask.java:58)

          at com.netapp.snapcreator.workflow.impl.SCTaskCallable.call(SCTaskCallable.java:48)

          at com.netapp.snapcreator.workflow.impl.SCTaskCallable.call(SCTaskCallable.java:20)

          at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)

          at java.util.concurrent.FutureTask.run(Unknown Source)

          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

          at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

          at java.lang.Thread.run(Unknown Source)

Caused by: netapp.manage.NaAPIFailedException: Api snapvault-primary-relationship-status-list-iter-start requires license for sv_ontap_pri (errno=13008)

          at netapp.manage.NaServer.invokeElem(NaServer.java:671)

          at com.netapp.snapcreator.storage.executor.ZapiExecutorImpl.run(ZapiExecutorImpl.java:53)

          ... 12 more

[2013-06-04 17:03:50,602] ERROR: STORAGE-02112: Retrieving SnapVault status failed with error [netapp.manage.NaAPIFailedException: Api snapvault-primary-relationship-status-list-iter-start requires license for sv_ontap_pri (errno=13008)].

[2013-06-04 17:03:50,617] ERROR: SCF-00018: Snapvault Status list for [backup-filer1] failed! Exiting

########## Snap Creator Framework 4.0.0 failed ##########

Message was edited by: Gergely Gardonyi

Re: Snapcreator 4 upgrade from 3.6 errno=13008

Can you send the debug log?

We changed the snapvault workflows slightly in 4.0 to account for dealing with Clustered OnTap and newer ONTAP versions. The issue is we are doing a snapvault primary status on secondary it appears which requires the sv_ontap_pri license. I think the simple solution is to just add this license, is that possible?

Regards,

Keith

Re: Snapcreator 4 upgrade from 3.6 errno=13008

we've bought only secondary license for the 'backup' filers and primary for the production ones, primary is 6240 with 8.1.2, backup is 3140 with 8.1.1, both 7-mode

debug log attached

actually the 6420 now has both pri and sec license (it was an upgrade of a 3170) but the 3140 has only sec license Message was edited by: Gergely Gardonyi

Re: Snapcreator 4 upgrade from 3.6 errno=13008

bump

Re: Snapcreator 4 upgrade from 3.6 errno=13008

We are still trying to understand and reproduce this problem. The issue seems to be that we changed snapvault to do a list from secondary instead of only primary but we are using the API for snapvault primary which requires a primary license.

You can

1) open NGS case and escalate if this is urgent

2) speak to account team and try and get license

3) revert to SC 3.6 and wait till this issue is addressed in 4.0

I apologize for this issue, we will get it addressed

Keith

Re: Snapcreator 4 upgrade from 3.6 errno=13008

Hi ,

Can you please show me the license show output of both the primary and secondary filers ?

in 8.1.1 if i add sec license it also adds for primary as well...Hence in your case it should not fail then.

-Hari

Re: Snapcreator 4 upgrade from 3.6 errno=13008

It was upgraded from 7.x...

backup-filer1> version

NetApp Release 8.1.1 7-Mode: Mon Jul 30 12:49:46 PDT 2012

backup-filer1> license

                 a_sis ENABLED

                    cf not licensed

             cf_remote not licensed

                  cifs not licensed

           compression ENABLED

     disk_sanitization ENABLED

                   fcp not licensed

           flash_cache ENABLED

            flex_clone not licensed

            flex_scale ENABLED

         flexcache_nfs ENABLED

                  http ENABLED

       insight_balance not licensed

                 iscsi ENABLED

            multistore not licensed

      nearstore_option ENABLED

                   nfs EIXXDCG

    operations_manager not licensed

    persistent_archive ENABLED

    protection_manager not licensed

  provisioning_manager not licensed

              smdomino not licensed

                 smsql not licensed

     snapdrive_windows not licensed

              snaplock not licensed

   snaplock_enterprise not licensed

    snapmanager_hyperv not licensed

    snapmanager_oracle not licensed

       snapmanager_sap not licensed

snapmanager_sharepoint not licensed

        snapmanager_vi not licensed

   snapmanagerexchange not licensed

            snapmirror GVYKSHL

       snapmirror_sync ENABLED

             snapmover ENABLED

           snaprestore AEKPNOJ

         snapvalidator not licensed

      storage_services ENABLED

    sv_application_pri not licensed

          sv_linux_pri not licensed

          sv_ontap_pri not licensed

          sv_ontap_sec AWHPNOJ

           sv_unix_pri not licensed

             sv_vi_pri not licensed

    sv_windows_ofm_pri not licensed

        sv_windows_pri not licensed

      syncmirror_local not licensed

              v-series not licensed

                   vld ENABLED


BACKUP- FILER1

FAS3140-R5

8.1.1 7-MODE

7-Mode

ProtocolLicense KeyONTAP Ver.Key TypeLicense TypeType ValueSales OrderExp. DateDate CreatedAction
A-SIS

GYQGUPC

N/A

128437



Print

DSANIT

KJNEYRI

N/A

128437



Print

FLEXCACHE_NFS

WOXGUPC

N/A

128437



Print

ISCSI

GVEWHEM

N/A

128437



Print

NEARSTORE

SQHLSHL

N/A

128437



Print

NFS

EIXXDCG

N/A

128437



Print

SNAPMIRROR

GVYKSHL

N/A

128437



Print

SNAPMOVER

KFFADLK

N/A

128437



Print

SNAPRESTORE

AEKPNOJ

N/A

128437



Print

SV_ONTAP_SEC

AWHPNOJ

N/A

120003031



Print

Re: Snapcreator 4 upgrade from 3.6 errno=13008

Hi Gergely,

I am happy to report we reproduced this issue and opened a BURT. This will be fixed in a patch release 4.0P1. I cant say when this will be available but it will be soon, probably within a month, it is coming.

BURT 717180

Regards,

Keith

Re: Snapcreator 4 upgrade from 3.6 errno=13008

Thanks, I've just received an 90 days eval snapvault pri license as well from our account team (and a perm license is forthcoming I think).

Re: Snapcreator 4 upgrade from 3.6 errno=13008

Good news and we will definitely have a fix for this available before your temp license expires.

Keith