Community

Subscribe
Highlighted

Snapcreator Framework for Xenserver configuration issue

Hi,

I am trying to install snapcreator framework 4.0 for Xenserver, however I am stuck on certain points

1) what does this option do "Take Xen VM Snapshots"

2)I have two host on the XEN pool, do I add them both

3) Where do I install the agent?

Re: Snapcreator Framework for Xenserver configuration issue

Hi,

Let me try to answer your questions

1) what does this option do "Take Xen VM Snapshots"

This is an option you want to set to take consistent snapshots of Xenserver VMs. If you dont set this option the NetApp snapshot taken is crash consistent which is normally fine, assuming you dont have application data inside VM which isnt being backed up by some other mechanism. What enable this option does is before we take NetApp snapshot we force Xenserver to create a meta data file for VM, writes then go to the meta data file and not the VM therefore the VM is now consistent. I am not a Xenserver expert but I believe this is the way it works. Someone correct me if I am wrong.

2)I have two host on the XEN pool, do I add them both

Not sure what a XEN pool is are these hosts VMs? Or are these hosts XEN servers?

If they are VMs then if you want to back them both up together yes, add them to config.

If they are XEN servers I think a backup config can only handle one Xenserver not multiple. You would need I believe one agent for each Xensserver and I dont think you can backup / restore a set of VMs on multiple Xenservers.

3) Where do I install the agent?

Agent should be installed on the host or a host which has the Xenserver management CLI. We use the CLI to create the metadata files and do things with the VMs.

Regards,

Keith

Re: Snapcreator Framework for Xenserver configuration issue

Hi Keith

2)I have two host on the XEN pool, do I add them both

Not sure what a XEN pool is are these hosts VMs? Or are these hosts XEN servers?

Xen pool is nothing but a pool of Xen hosts, when i was configuring it when i add one host i see all the VM's on it even though some of the VM's are not running on the other Xen server.

So should i be adding them both and if i have to add only one , what happens when the host that i added failed?

Re: Snapcreator Framework for Xenserver configuration issue

Hello Rakesh,

You can find the pool name by running the below command on the xenserver

xe pool-list | grep name-label | awk '{ print $4 }'

More information on the xen pool as borrowed from the link below.

http://knowledgelayer.softlayer.com/faqs/145

What is XenServer Pooling?  

XenServer pooling can be thought of as up to 16 servers working as a cluster. This not only allows for shared resources but allows for live migration of VirtualMachines using XenMotion. One server will act as the "master node" while the rest of them will be slaves. Opening any of the servers in the pool via XenCenter will open the management information for the entire pool. When a node joins the pool its management password is changed to match the management password of the master node. When removing a node from the pool this password is not changed.  All systems in the node must be from the same processor family, as in Intel or AMD. You cannot have both Intel-based systems and AMD-based systems in the same pool as XenServer will not allow you to add them.  Ideally, hardware should be identical for pooling to be most successful. This is not entirely true with Heterogeneous CPU Pooling.  You will have to perform compatibility tests for yourself to see if your hardware is compatible.  Further inquiry should be directed to Citrix documentation:

http://support.citrix.com/article/CTX127059


Re: Snapcreator Framework for Xenserver configuration issue

Hi keith/Shiva,

I finished the configration, however the job does not run, i get this error.

########## Detecting Data ONTAP mode for 10.99.2.201 ##########
########## Detecting Data ONTAP mode for 10.99.2.200 ##########
[2014-01-14 11:25:05,147] INFO: STORAGE-03031: System version details of [10.99.2.201].
[2014-01-14 11:25:05,147] DEBUG: <system-get-version/>

[2014-01-14 11:25:05,147] DEBUG: <system-get-ontapi-version/>

[2014-01-14 11:25:05,147] INFO: STORAGE-03032: System version details of [10.99.2.201] finished successfully.
[2014-01-14 11:25:05,568] INFO: STORAGE-03031: System version details of [10.99.2.200].
[2014-01-14 11:25:05,568] DEBUG: <system-get-version/>

[2014-01-14 11:25:05,569] DEBUG: <system-get-ontapi-version/>

[2014-01-14 11:25:05,569] INFO: STORAGE-03032: System version details of [10.99.2.200] finished successfully.
########## Agent validation ##########
[2014-01-14 11:25:05,936] INFO: Agent validation completed successfuly for agent Xenserver:9090
########## Plugin validation ##########
[2014-01-14 11:25:05,964] INFO: Plugin validation completed successfuly for plugin xen
########## PRE APPLICATION QUIESCE COMMANDS ##########
[2014-01-14 11:25:05,989] INFO: Pre application quiesce commands are not defined
########## PRE APPLICATION QUIESCE COMMANDS FINISHED SUCCESSFULLY  ##########
[2014-01-14 11:25:05,991] INFO: Application auto discovery is not enabled skipping .
[2014-01-14 11:25:05,991] INFO: Validate volume is not enabled skipping validate volume task.
########## Application Quiesce ##########
[2014-01-14 11:25:10,501] ERROR: SCF-00037: Application quiesce for plugin [xen] failed with error [javax.xml.bind.UnmarshalException
- with linked exception:
[javax.xml.bind.UnmarshalException: unexpected element (uri:"http://www.netapp.com/SnapCreator/Daemon/Agent", local:"value"). Expected elements are <{http://www.netapp.com/SnapCreator/Daemon/Agent}error_code>,<{http://www.netapp.com/SnapCreator/Daemon/Agent}preserved>,<{http://www.netapp.com/SnapCreator/Daemon/Agent}stderr>,<{http://www.netapp.com/SnapCreator/Daemon/Agent}env>,<{http://www.netapp.com/SnapCreator/Daemon/Agent}exit_code>,<{http://www.netapp.com/SnapCreator/Daemon/Agent}message>,<{http://www.netapp.com/SnapCreator/Daemon/Agent}stdout>]] and exit code [-1], Exiting!
########## Application Unquiesce ##########
[2014-01-14 11:25:10,724] ERROR: SCF-00032: Application unquiesce failed due to application error. Check logs and application settings. To ignore application errors and proceed with backup you can set APP_IGNORE_ERROR=Y.

Re: Snapcreator Framework for Xenserver configuration issue

This sounds like a known issue.

Please try installing/(upgrading) to Snap Creator Framework version 4.0p1 found here http://support.netapp.com/NOW/download/software/snapcreator_framework/4.0P1/

After installing 4.0p1 you may also add this variable in your config file

PLUGIN_RESULT_FILTERING_ENABLE=Y

Please let us know once you tried.

Re: Snapcreator Framework for Xenserver configuration issue

Hi ,

I upgraded to 4.0P1, however it still does not work.

One more question.

I have contoller in 2040 HA pair and ontap is NetApp Release 7.3.6:

Does Snapcreator framework support it?

Also the command you suggested(PLUGIN_RESULT_FILTERING_ENABLE=Y), i added it under "application quiesce command" is that right?

########## Detecting Data ONTAP mode for 10.99.2.200 ##########

########## Detecting Data ONTAP mode for 10.99.2.201 ##########

[2014-01-15 16:38:28,898] INFO: STORAGE-03031: System version details of [10.99.2.201].

[2014-01-15 16:38:28,899] INFO: STORAGE-03032: System version details of [10.99.2.201] finished successfully.

[2014-01-15 16:38:29,343] INFO: STORAGE-03031: System version details of [10.99.2.200].

[2014-01-15 16:38:29,344] INFO: STORAGE-03032: System version details of [10.99.2.200] finished successfully.

########## Agent validation ##########

[2014-01-15 16:38:29,362] INFO: Agent validation completed successfuly for agent XENHOST:9090

########## Plugin validation ##########

[2014-01-15 16:38:29,389] INFO: Plugin validation completed successfuly for plugin xen

########## PRE APPLICATION QUIESCE COMMANDS ##########

[2014-01-15 16:38:29,391] INFO: Pre application quiesce commands are not defined

########## PRE APPLICATION QUIESCE COMMANDS FINISHED SUCCESSFULLY  ##########

[2014-01-15 16:38:29,392] INFO: Application auto discovery is not enabled skipping .

[2014-01-15 16:38:29,393] INFO: Validate volume is not enabled skipping validate volume task.

########## Application Quiesce ##########

[2014-01-15 16:38:29,608] ERROR: SCF-00037: Application quiesce for plugin [xen] failed with error [javax.xml.bind.UnmarshalException

- with linked exception:

[javax.xml.bind.UnmarshalException: unexpected element (uri:"http://www.netapp.com/SnapCreator/Daemon/Agent", local:"value"). Expected elements are <{http://www.netapp.com/SnapCreator/Daemon/Agent}error_code>,<{http://www.netapp.com/SnapCreator/Daemon/Agent}preserved>,<{http://www.netapp.com/SnapCreator/Daemon/Agent}stderr>,<{http://www.netapp.com/SnapCreator/Daemon/Agent}env>,<{http://www.netapp.com/SnapCreator/Daemon/Agent}exit_code>,<{http://www.netapp.com/SnapCreator/Daemon/Agent}message>,<{http://www.netapp.com/SnapCreator/Daemon/Agent}stdout>]] and exit code [-1], Exiting!

########## Application Unquiesce ##########

[2014-01-15 16:38:29,825] ERROR: SCF-00032: Application unquiesce failed due to application error. Check logs and application settings. To ignore application errors and proceed with backup you can set APP_IGNORE_ERROR=Y.

Re: Snapcreator Framework for Xenserver configuration issue

Hello Rakesh,

Yes. ONTAP 7.3.6 is qualified against the 4.0.x version of Snap Creator Framework.

Please check the IMT support details below.

     Citrix XenServer 5.6 and 5.6FP1

     Citrix XenServer 6.0 and 6.0.1

     Only NFS is supported.

What OS is your Snap Creator Server running on?

If it is Windows, then try using a Linux server to run Snap Creator server.

What is the Snap Creator agent version?

(I see that you are using the linux agent directly on the xenserver. It is supported.)

Meanwhile, you may also try this?

Keep a separate Snap Creator server (preferably Linux)

Download and install XenCenter on a windows server http://support.citrix.com/article/CTX118531

Install Snap Creator Agent on the above mentioned windows server.

All the plugin does is to run xe commands. (In the above case "C:\Program Files (x86)\Citrix\XenCenter\xe.exe")

The xe command line interface is installed by default on XenServer Hosts. A stand-alone remote CLI (of xe) is also available for Linux and Windows.

Following parameters need to be in your config file.

################################

### XEN Config Settings ###

################################

#########################################################################################################

# XEN_VMS - (required) semicolon separated <hostname:vm1,vm2> pair.                                     #

#           ie xenserver1:vm1,vm2;xenserver2:vm1,vm2                                                    #

# XEN_HOST_USERS - (required) semicolon seperated <hostname:username/password>                          #

#                  ie xenserver1:user1/password1;xenserver2:user2/password2                             #

# XEN_BIN_PATH - (required) Path of xe binary.                                                          #

#                ie C:\Program Files (x86)\Citrix\XenCenter\xe.exe                                      #

# XEN_METADATA_PATH - (required) Path on the server where we can store the vm metadata information      #

#                     ie C:\dir_name                                                                    #

# XEN_RESTORE_VMS  - (required only during restore) List of VMs to be restored.                         #

#                    ie xenserver1:vm1,vm2;xenserver2:vm1,vm2                                           #

#########################################################################################################

XEN_VMS=

XEN_HOST_USERS=

XEN_BIN_PATH=

XEN_METADATA_PATH=

XEN_RESTORE_VMS=

I am happy to jump on a webex. I am in Eastern time zone.

Re: Snapcreator Framework for Xenserver configuration issue

Hi Siva,

To anwser your question

1) What OS is your Snap Creator Server running on?

If it is Windows, then try using a Linux server to run Snap Creator server.

I am runing the server and agenr on the server where i have installed the xencenter( it is windows 2008 R2).

What is the Snap Creator agent version?

(I see that you are using the linux agent directly on the xenserver. It is supported.)

Thats not the case here.

I am using the agent installed on the XEN center server.

This part is a concern for me :Only NFS is supported. as my all SR are iSCSI disks.

is there any netapp product like SMVI for XEN which supports SAN technology?

Re: Snapcreator Framework for Xenserver configuration issue

Hello Rakesh,

I have good news for you.
Snap Creator Framework 4.1 (expected to be released next week) will have support for iSCSI and FCP.

Please wait and read the Installation and Administration Guide (when released) as it has several pointers towards XEN backups and restore.

Thanks,
Siva Ramanathan