Community

Subscribe
Highlighted
Accepted Solution

Upgrade from 3.60 to 4.0p1-SendMail issue

Config file  attached

TEST.conf #

Previous debug attached

TEST.debug.20130910180015.log #

Current debug attached

TEST.debug.20130911152358.log

The Exception is "Cannot allocate socket."

Help greatly appreciated.

Re: Upgrade from 3.60 to 4.0p1-SendMail issue

Have you tried running the cmd below by hand?

c:\SendMail\Sendmail -smtp smtp.pacificlife.net -noauth 1 -noconfirm -sender unixadmin@pacificlife.com -to VAServerSupportGroup@pacificlife.com -sub "INFO: Snapshot of TEST Database on ANTXAVE1 finished successfully ( Action: backup )" -body "Snapshot of DB2 TEST Database completed successfully on ANTXAVE1."

and see the result?

Re: Upgrade from 3.60 to 4.0p1-SendMail issue

Yes it is successful.

Re: Upgrade from 3.60 to 4.0p1-SendMail issue

We changed how we execute commands on windows in 4.0. If you have multiple quotes or sets of things that need to be quoted you need to use cmd /c to run command. Can you please try the following:

SUCCESS_TRAP=cmd /c "c:\SendMail\Sendmail -smtp smtp.pacificlife.net -noauth 1 -noconfirm -sender unixadmin@pacificlife.com -to VAServerSupportGroup@pacificlife.com -sub "INFO: Snapshot of TEST Database on ANTXAVE1 finished successfully ( Action: %ACTION )" -body "Snapshot of DB2 TEST Database completed successfully on ANTXAVE1.""

This should work

Regards,

Keith

Re: Upgrade from 3.60 to 4.0p1-SendMail issue

Keith,

I tried the following and am still getting the same error.

Re: Upgrade from 3.60 to 4.0p1-SendMail issue

you may also try the powershell commandlet if you are interested.

This is discussed in this communities webpage.

https://communities.netapp.com/thread/25907

Re: Upgrade from 3.60 to 4.0p1-SendMail issue

I tried the powershell and no luck with that either. Keep getting gui error log says invalid XML character.

Re: Upgrade from 3.60 to 4.0p1-SendMail issue

Have you tried putting the sendmail command into a script and calling the script in the SUCCESS_TRAP command?

Re: Upgrade from 3.60 to 4.0p1-SendMail issue

Not yet.

Re: Upgrade from 3.60 to 4.0p1-SendMail issue

Additionally you can try

SUCCESS_TRAP=cmd /c c:\SendMail\Sendmail -smtp smtp.pacificlife.net -noauth 1 -noconfirm -sender unixadmin@pacificlife.com -to VAServerSupportGroup@pacificlife.com -sub "INFO: Snapshot of TEST Database on ANTXAVE1 finished successfully ( Action: %ACTION )" -body "Snapshot of DB2 TEST Database completed successfully on ANTXAVE1."

However I dont think that is the problem, Snap Creator is calling the main client so it seems like there is some other issue going on outside of SC. It cant connect as we get a socket error...maybe there is a firewall issue?

Exception:

   Cannot allocate socket.

   >

   > Message saved to the Failed Folder as:

    "INFO_ Snapshot of TEST Database on ANTXAVE1 finished successfully ( Action_ backup ) (11-09-2013, 15.25.06).eml"

Sending Message FAILED!

Regards,

Keith