Subscribe

Add Volume Storage Efficiency

One of our developers has created a tool using the netapp-manageability-sdk-5.3.1 for creating and managing volumes on our NetApp (cDOT 8.2.3 P2). He is trying to extend the tool to also set storage efficiency policies, but receives the following error:

=====
<netapp vfiler="va_nonprod" xmlns="http://www.netapp.com/filer/admin" version="1.21">
<sis-get-iter>
</sis-get-iter>
</netapp>

<!-- Output of sis-get-iter [Execution Time: 466 ms] -->
<results reason='Insufficient privileges: user "webinf-nonprod" does not have read access to this resource' errno='13003' status='failed'/>

=====

But he is using the user “webinf-nonprod” and “webinf-prod” which appears to have all of the correct privileges:

=====
::> security login show -username webinf-*

Vserver: va_nonprod

Authentication Acct

UserName Application Method Role Name Locked

---------------- ----------- -------------- ---------------- ------

webinf-nonprod ontapi password vsadmin no

Vserver: va_prod

Authentication Acct

UserName Application Method Role Name Locked

---------------- ----------- -------------- ---------------- ------

webinf-prod ontapi password vsadmin no

2 entries were displayed.


::> security login role show-ontapi

….
sis-disable volume efficiency off
sis-disable-async volume efficiency off
sis-enable volume efficiency on
sis-enable-async volume efficiency on
sis-get volume efficiency show
sis-get-iter volume efficiency show
sis-policy-create volume efficiency policy create
sis-policy-delete volume efficiency policy delete
sis-policy-get volume efficiency policy show
sis-policy-get-iter volume efficiency policy show
sis-policy-modify volume efficiency policy modify
sis-set-config volume efficiency modify
sis-set-config-async volume efficiency modify
sis-start volume efficiency start
sis-start-async volume efficiency start
sis-status volume efficiency show
sis-stop volume efficiency stop
sis-stop-async volume efficiency stop

====

 

Please help me understand what we are missing.

 

Thank you,

-Bryan