Subscribe

Calling ZAPI volume-set-option for option "maxdirsize" freezes the Filer

Environment:

NetApp 8.2.2 7-mode running on FAS8040

 

We have a small utility that creates a volume on the Filer and set a few volume option.  We use the .NET SDK to invoke the <volume-create> and <volume-set-option> APIs.  When the program runs the <volume-set-option> API with the option "maxdirsize", it will freeze up the API access of the Filer.  Any new API connection will stuck in authentication and no more API access to the Filer, including OnCommand.  OnCommand will show up as waiting for authentication and after a few minutes it will eventually time out.  Eventually we have to reboot the Filer.

 

Then, we open up a SSH connection to the Filer and run the utility again.  This time, a message pops up when the program runs the <volume-set-option> API with the option "maxdirsize":

 

Warning: The default maximum directory size is model-dependent, and is,
         by default, already optimized for the size of system memory.
         You can increase it for a specific volume by using this option,
         but doing so could impact system performance. This parameter is
         not supported on Infinite Volumes. Do not proceed unless directed
         to do so by technical support.
         Do you want to continue?

 

If we don't type anything in the SSH console, the API layer will continue to be stuck.  Once we type "yes" in the SSH console, the API layer will work again.

 

So it looks like there is a really bad bug in the volume-set-option command that it expects an interactive answer even though we are coming in from API.

 

Is this a known bug and do we have any information about whether this bug will be addressed?

 

 

 

 

 

 

 

Re: Calling ZAPI volume-set-option for option "maxdirsize" freezes the Filer

I'm currently runnng into the same problem. Did you get a solution for it?