Subscribe
Accepted Solution

Failure to see a CIFS share from Windows 7

Hi all, as many others before me - I'm spending a lot of time to see a CIFS share under Windows 7.

All I see is the infamous "The account is not authorized to log in from this station".

CIFS setup ok, authentication by /etc/passwd, signing.enable on, no wins. I can ping the filer, I can run apitest, however the share does not appear within my Windows shares, and net use fails always. No life sign from cifs.trace_login.

Share is HOME, /vol/vol0/home, everyone, Full Control.

Networking occurs through a VPN (OpenVPN), and share mapping attempt was:

net use * \\192.168.3.86\HOME password1 /USER:192.168.3.86\root

I tried to create another user through useradmin, no success.

Any suggestion is welcome.

Re: Failure to see a CIFS share from Windows 7

As by default  home is not a qtree

What is security style do you have on /vol/vol0?

Do you tried to use administrator as username?

What is the value of:

>options wafl.nt_admin_priv_map_to_root

>fsecurity show /vol/vol0

>fsecurity show /vol/vol0/home

francois

Re: Failure to see a CIFS share from Windows 7

Hi Francois, I finally managed to have it working, by selecting authentication #3 (workgroup) in setup. Then I was requested to create an administrator user, so I did. Now it works fine with both local users, administrator and renzo, using the filer name:

net use * \\192.168.3.86\HOME password1 /USER:SCNETAPP\renzo

What is pretty confusing is the usage of "filer" in docs, where it means filer name and not filer host or ip.

Also authentication is somewhat confusing in setup: when choosing #4 (/etc/passwd), I'm prompted for a workgroup anyway, which should be related to #3.

And while choosing #3 I still have in /etc/cifsconfig_setup.cfg: "cifs setup -security unix  -cp 0", although we are going to use local users, not unix users.

In any case, I succeeded only after selecting #3 (workgroup) and creating local users. I still don't understand how a workgroup enters this game, but it works.

Regards,

Renzo