Subscribe

ONTAPI auth failures starting with ONTAP 9.1 P3

Hello,

 

starting with ONTAP 9.1 P3 we get different errors when using ONTAPI requests.

 

On one installation we get "HTTP POST - Authorization failed" after the ONTAPI connection is about 4 hours old. Reastablishing the connection solves the problem.

 

Another installation reports "not authorized for that command" for arbitrary commands.

 

Note that in both cases, the credentials are correct.

 

Are there any known changes in post 9.1 which may cause such behaviour? What may be the soluttion?

 

Thank you,

Detlef.

 

Re: ONTAPI auth failures starting with ONTAP 9.1 P3

Hi,

 

 

Thank you for contacting NetApp communities, May i know if you have enable HTTP ? 

 

Can check  "system services web modify -http-enabled true" 

 

 

 

Thanks, 

Nayab

Re: ONTAPI auth failures starting with ONTAP 9.1 P3

http-enabled is set to false and we are also forcing an https connection via ONTAPI. Unfortunately, I cannot just try what happens if we enable http on these systems. Do you have an iday why this could help?

 

Thank you,

Detlef.

 

Re: ONTAPI auth failures starting with ONTAP 9.1 P3

Hi, 

 

May i know if you are trying to use POWERSHELL CMDLTS?

 

 

Thanks,

Nayab

Re: ONTAPI auth failures starting with ONTAP 9.1 P3

Hello,

 

we are using the NetApp Manageability SDK (C++) with SSL and password authentication. The SDK has been upgraded to 5.7 to no avail.

 

Thank you,

Detlef.

 

Re: ONTAPI auth failures starting with ONTAP 9.1 P3

For the record:

 

The error "not authorized for that command" turned out to be an issue with the role which was assigned to the user. The role has been deleted and created again with the same(!) credentials. Now it is working. Note that the original role was working with 8.3.2 before.

 

The other error "HTTP POST - Authorization failed" still not solved. Note that this happens regularily after 4 hours. This happens on multiple systems, but it is disjunct to the previously mentioned error.

 

Thanks,

Detlef.