Subscribe
Accepted Solution

Perl and Manageability SDK v9.3 apitest.pl issue

Greetings - Just started playing with the Neatpp ManageabilitySDK and Perl.

 

I tried a simple use case of the apitest.pl smple program and am running into the following issue:

 

[root@svlv6231# pwd
/opt/netapp-manageability-sdk-9.3/src/sample/Data_ONTAP/Perl

 

root@centosvm# perl apitest.pl cluster01 foo bar system-get-version
Can't locate object method "new" via package "HTTP::Request" (perhaps you forgot to load "HTTP::Request"?) at ../../../../lib/perl/NetApp/NaServer.pm line 722.

 

Anyone have any idea what this error message means. It appears I have all the required Perl Modules loaded at run time.

 

Thx in advance!

Re: Perl and Manageability SDK v9.3 apitest.pl issue

Hello @pete_veenbaas,

 

Which dependencies did you install?  When I use the Perl module(s) I install these:

 

  • LWP::UserAgent
  • XML::Parser
  • Net::SSLeay
  • Socket
  • Switch

LWP::UserAgent installs, among other things, the HTTP::Request module.

 

Also, you can see how to create a container based version of the NMSDK here if you're interested.

 

Hope that helps.

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Perl and Manageability SDK v9.3 apitest.pl issue

Thx Andrew - I was missing the LWP::Useragent module