Community

Subscribe
Highlighted

in Zapi::invoke, cannot connect to socket

We get the error message

in Zapi::invoke, cannot connect to socket

when we try use "snapshot-create" with NaServer API.

The filer is a clustered filer running 8.1. There is httpd.enable parameter in clustered mode and

it is available only in 7-mode.

How do we resolve this issue?

rle Former NetApp Employee

Re: in Zapi::invoke, cannot connect to socket

From your description, I can't tell exactly what is going on.

Does clustered filer mean 7-mode ONTAP or clustered ONTAP?

Are you trying to ask a question about httpd.enable?

Does the system-get-version API work correctly?

Regards,

   - Rick -

Re: in Zapi::invoke, cannot connect to socket

Rick,


Thanks for the response.

I meant clustered ONTAP. It appears clustered ONTAP does not have httpd.enable feature. Is this correct? We are

getting the error "in Zapi::invoke, cannot connect to socket" when trying to create a snapshot on clustered ONTAP. We used

to enable httpd when we get this error and in 7-mode, this solution worked. It is not working on clustered ONTAP.

I have to check if system-get-version API works or not.

thanks

rle Former NetApp Employee

Re: in Zapi::invoke, cannot connect to socket

Please check my blog on system-get-version, because if system-get-version doesn't work, then you're not connecting to the correct LIF, which should be an admin LIF.

The snapshot-create API is only a Vserver API, so sending it to the cluster admin LIF should get the error: "Unable to find API: snapshot-create" errno="13005".  Snapshot-create needs to be sent to the Vserser admin LIF or to the cluster admin LIF with Vserver tunneling.

Regards,

   - Rick -