Subscribe
Accepted Solution

maxRecords query parameter over 500

Group -

 

OCAPI 1.2

 

I'm trying to retrieve greater than 500 records from the GET volumes REST call.  If I set the maxRecords query parameter to a number greater than 500, I always get 500 records.  However, the query will be adjusted downwards if I place a number less than 500.

 

REST syntax:

https://apiserver:8443/api/1.0/ontap/volumes?maxRecords=10000

 

Is this a bug or am I missing something?

Re: maxRecords query parameter over 500

 

CSiegle -

 

Yes, you're missing something.

 

There was a race condition bug with the old 7-mode API calls to get various objects, including volumes.

Hence the max records for the new APIs.

 

BCP is to get 20 records at a time (default) and populate the 'next' tag with the results from the previous call.

 


I hope this response has been helpful to you.

At your service,

Eugene E. Kashpureff, Sr.
Independent NetApp Consultant http://www.linkedin.com/in/eugenekashpureff
Senior NetApp Instructor, Fast Lane US http://www.fastlaneus.com/
(P.S. I appreciate 'kudos' on any helpful posts.)

Re: maxRecords query parameter over 500

[ Edited ]

This is as per design. at the most, you can fetch 500 records.  this is done considaring many factors. one of them is performance. still, if you wanted to have maxrecords more than 500, please get touch with product management.

 

Re: maxRecords query parameter over 500

If your requirement is get records beyond 500, then please use nextTag. This, you will find end of each response body

 

Example:

https://apiserver:8443/api/1.0/ontap/volumes?NextTag=<nextTagValue>

 

Re: maxRecords query parameter over 500

Great!  nextTag worked well.  Thanks.