GetServiceProvider error while adding servers to the SnapManager for Exchange

Recently I had the opportunity to work on an SME installation and found an interesting issue. In this case, while selecting "Add server to be managed", it was throwing an error message as below:

                                                                                                          

The "Add server to be managed" works fine for the local server. A quick netstat -ano would show that no application has a lock on the default port number 808/810 for exclusive usage. This pointed that it is a clear communication problem and led us to check the firewall settings which indeed turned out to be the culprit. The recommendation is to always disable the firewall to enable SnapDrive communications before installing SnapDrive for Windows on the Server.

 

For instance: netsh advfirewall firewall add rule name="NetApp SnapDrive" dir=in action=allow program="c:\program files\netapp\snapdrive\swsvc.exe" enable=yes profile=any

 

Now let's consider a scenario where the Windows Firewall is enabled on the host, then it needs to configured to allow SnapDrive for Windows communications.

Note: The Windows Firewall is enabled by default in Windows Server 2008.

 

Steps to allow SnapDrive for Windows communications:

 

· Navigate to Control Panel > Windows Firewall > Allow a program through Windows Firewall > Exceptions.

· If you will be using HTTP or HTTPS, select the World Wide Web Services (HTTP) or Secure World Wide Web Services (HTTPS) checkboxes.

· Click Add program.

· Click Browse and browse to C:\Program Files\NetApp\SnapDrive\, or to wherever you installed SnapDrive if you did not use the default location.

· Select SWSvc.exe and click Open, then click OK in the Add a Program window and in the Windows Firewall Settings window.

· Repeat the above to step to add sdcli and also SnapMgrService from C:\Program Files\NetApp\SnapManager for Exchange\.

· To verify that SWsvc.exe and sdcli.exe are in the list of inbound rules, in MMC, navigate to Windows Firewall > Inbound Rules.

 

                                                                                                   

More Suggestions:

 

· Ensure that the Windows Management Instrumentation (WMI) traffic is enabled in the firewall. It is enabled by default. Some security policy templates can block WMI at the firewall level. The WMI namespace security should allow access for local administrators in all the nodes in the cluster configuration. Some security policy templates can disable this access also.

· Ensure that there are no firewall restrictions between the remote and local servers.

 

 

Happy Reading and tune in to our Community forums to read the blog series talking about the heterogeneous Environment, SME and DAG configurations and SME BCM for Exchange 2003 and Exchange 2007 and more.

 

 

 

Niyaz Mohamed

Comments

 I tried all these options for the exact same error, but it didnt work for me..

 

Any other options.