Subscribe

Adding VMware NFS datastores to dataset in OnCommand

OnCommand 5.1 and Host Package 1.2

From the OnCommand Web UI when trying to add a VMWare NFS datastore to an existing dataset, I get the following error:

Could not find any storage mapping for virtual object nas22_vm_nfs3 (1184) of type Virtualization.VMware.Datastore in the database.

The complete error details are here, but none of the corrective actions seem to resolve the problem:

==ERROR==

Error or exception is not specified.

==TIME==

2012-09-27 14:34:18,570

==MESSAGE==

Could not find any storage mapping for virtual object nas22_vm_nfs3 (1184) of type Virtualization.VMware.Datastore in the database.

==DETAILS==

The storage map for an application object has not been discovered. (Error: 23831)

==CORRECTIVE ACTION==

1. Add the storage system for the object to the DataFabric Manager server. Use the "Storage Controllers" page in "Storage" tab to add the storage systems.

2. Ensure that the credentials for the storage system have been set on the DataFabric Manager server and pushed to host services. Then force the DataFabric Manager server to discover virtual and storage objects. You can complete these tasks from the "Host Services" tab in the console.

3. Remove the object from the dataset, then continue creating or editing the dataset.

==LOCATION==

Location is not specified.

==BROWSER INFO==

App Name: Netscape

App Version: 5.0 (Windows)

App Codename: Mozilla

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0.1

Platform: Win32

Cookie Enabled: true

From another forum discussion, I noted that when running the "dfm report view nfs-exports" command from the DFM console that the NFS export is not found in the results, and yet there is an object in the DFM database that relates to the NFS export in question.

Appreciate any help!

Re: Adding VMware NFS datastores to dataset in OnCommand

You had any luck with this issue? Experiencing the same issue with OC 5.0.2 and HS 1.1. This just started after the upgrade to 5.0.2 from 5.0.0 and now no matter what I do, I cannot get NFS datastores added to existing datasets.