Subscribe

How can I suppress the volume full error message on certain volumes?

Hi

I need to create a bunch of LUNs to provide storage for VMWare ESX hosts.  The current plan is to create each LUN inside its own volume.  I've created one volume and LUN and mapped it whereupon an ESX box can see the LUN and format it. No problems as such BUT I get an error (seen via the dmf/operations manager view) saying "Volume Full". The volume is indeed full -- by design!

Is there a way of saying "yes  I know this volume is full and it's not an error", please?

Thanks!

Richard.

How can I suppress the volume full error message on certain volumes?

In Operations Manager, you can change thresholds for individual volumes:

  1. Click on group name
  2. Click on the “Member Details” tab.
  3. Click on “File Systems”
  4. Find the volume in the list and click on the hyperlink.
  5. Click on "Edit Quota Settings" under "Volume Tools" in the lower left of the screen.
  6. This will bring up a list of all the thresholds.  You can set the ones you want to 100% and it should stop the alerts.
  7. You can also use the "Apply Settings To" drop down box in the bottom right to apply these settings to all the members of a group.

Alternatively, you can use the DFM command line:

  • To get a list of all dfm commands:
    dfm help
  • To get syntax of a specific command (in this example, volume):
    dfm volume help
  • To get a list of all the volumes being monitored (this will also list the volume ID, a number that represents the volume that can be used as a shortcut instead of typing out the vol name).  The –a will also show any snapshot volumes:
    dfm volume list -a
  • To see the alarm settings for a particular volume (the # is the vol ID from the list command):
    dfm volume get 594
  • To see the real names of the alarm options, use the –q option.  You will need this to set them:
    dfm volume –q get 594
  • To set a particular alarm option for a particular volume.  This example sets the alarm for volume #594 so that the snapshots will not alert until they reach 1000% of their allocated capacity.:
    dfm volume set 594 volSnapshotFullThreshold=1000

How can I suppress the volume full error message on certain volumes?

Hi,

An alternative is also just thin provisioning your LUNs.  If you don't space reserve your LUN's and have no guarantees on your volumes, then you don't really use any extra space just making the volumes 10-20% larger than your luns.  In the end, it can really make life easier because you really only have to watch the aggregate filling levels.  The added value is, of course, that you can use the blocks that have been ordered and "reserved" with full provisioning for other things.

Just a thought.  It made my life a lot easier.