Community

Subscribe
Highlighted

RBAC with VSC 4.1, vCenter 5.1

Hi All,

Sorry, I seem to be posting endless questions about vCenter 5.1...

We're testing VSC 4.1 right now and have a problem with RBAC configuration.  We have configured RBAC for vcenter as per https://kb.netapp.com/support/index?page=content&id=1013941.  However, having installed VSC 4.1 and registering it with vcenter, we are getting a permissions issue when trying access the VSC in the vsphere client:

If we change the roles to full admin in vcenter it works correctly, so there must be some privilege we're missing.  Is there any updated RBAC doc covering VSC 4.1 on vCenter 5.1, or does anyone have any experience of this?

Many thanks,

Craig

Re: RBAC with VSC 4.1, vCenter 5.1

Hi Craig,

Have you tried to use ONTAP RBAC Username Creator for VSC by dbkelly. It is a GUI application and might be very helpful. Link below to the installer and guide.

https://communities.netapp.com/docs/DOC-19074

Re: RBAC with VSC 4.1, vCenter 5.1

Hi Craig,

I also used https://kb.netapp.com/support/index?page=content&id=1013941, with the same http error 403, but I got it working with an extra privilege:

In vCenter under Administration -> Roles, I have combined all privileges needed for Backup & Recovery, Privisioning & Cloning, Optimization & Migration in 1 Role + privilege Sessions -> Validate session.

We have vSphere 5.0, not 5.1.

Peter

Re: RBAC with VSC 4.1, vCenter 5.1

The previous post, adding priv Sessions -> Validate session, fixed us as well running 5.1.  Thanks

Re: RBAC with VSC 4.1, vCenter 5.1

When registering Virtual Storage Console with the vCenter Server at https://VSC_HOST:8143/Register.html, are you using vSphere administrator credentials?

Re: RBAC with VSC 4.1, vCenter 5.1

Yes.

Van: maness

Verzonden: zaterdag 13 april 2013 4:01 PM

Aan: Peter van Voorene

Onderwerp: - Re: RBAC with VSC 4.1, vCenter 5.1

<https://communities.netapp.com/index.jspa>

Re: RBAC with VSC 4.1, vCenter 5.1

created by maness<https://communities.netapp.com/people/maness> in Virtualization - View the full discussion<https://communities.netapp.com/message/105462#105462>

When registering Virtual Storage Console with the vCenter Server at https://VSC_HOST:8143/Register.html, are you using vSphere administrator credentials?

Reply to this message by replying to this email -or- go to the message on NetApp Community<https://communities.netapp.com/message/105462#105462>

Start a new discussion in Virtualization by email<mailto:discussions-community-products_and_solutions-virtualization@communities.netapp.com> or at NetApp Community<https://communities.netapp.com/choose-container.jspa?contentType=1&containerType=14&container=2160>