Subscribe

SMVI not listing all datastores when creating a backup

I have come accross this today, it seems SMVI is not seeing all the datastores when im trying to creating a new backup schedual for a VM

Both the below datastores are missing when I hit the dropdown to select datastore (Note: this is not a new datastore iv read the bug notes Smiley Happy)

path>/vol/ESX02/ESXLUN2</path>

path>/vol/ESX04/ESXLUN4</path>

Below is a section of the log file, intresingly the "Received ZAPI response for "lun-initiator-list-map-info" from "f1":" can see all datastores

However when it Received ZAPI response for "lun-initiator-list-map-info" from "f2": cannot see ESX02 and ES04

Any help would be appreciated

Thanks,

Tony

2008-12-08 09:49:26,317 [::] DEBUG - Authenticated user ************ with handler com.netapp.smvi.security.authentication.handler.WindowsAuthenticationHandler

2008-12-08 09:49:26,786 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] DEBUG - ZEPHYR-10002: Received ZAPI response for "lun-initiator-list-map-info" from "f1":

<results status='passed'>

<lun-maps>

<lun-map-info>

<path>/vol/ESXTemplate/ESXTemplate/ESXTemplateLUN</path>

<initiator-group>VMWare</initiator-group>

<lun-id>1</lun-id>

</lun-map-info>

<lun-map-info>

<path>/vol/ESX01/ESX01/ESXLUN1</path>

<initiator-group>VMWare</initiator-group>

<lun-id>0</lun-id>

</lun-map-info>

<lun-map-info>

" So I Can see SMVI can see all the LUNS via list command"

<path>/vol/ESX02/ESXLUN2</path>

<initiator-group>VMWare</initiator-group>

<lun-id>2</lun-id>

</lun-map-info>

<lun-map-info>

<path>/vol/ESX03/ESXLUN3</path>

<initiator-group>VMWare</initiator-group>

<lun-id>3</lun-id>

</lun-map-info>

<lun-map-info>

<path>/vol/ESX04/ESXLUN4</path>

<initiator-group>VMWare</initiator-group>

<lun-id>5</lun-id>

</lun-map-info>

<lun-map-info>

<path>/vol/ESX05/ESXLUN5</path>

<initiator-group>VMWare</initiator-group>

<lun-id>8</lun-id>

</lun-map-info>

<lun-map-info>

<path>/vol/esxtpfvol01/esxtpflun01</path>

<initiator-group>VMWare</initiator-group>

<lun-id>10</lun-id>

</lun-map-info>

</lun-maps>

</results>

2008-12-08 09:49:26,802 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] DEBUG - ZEPHYR-10001: Executing ZAPI request "lun-initiator-list-map-info" to "f2":

<lun-initiator-list-map-info>

<initiator>10:00:00:00:c9:70:df:4f</initiator>

</lun-initiator-list-map-info>

2008-12-08 09:49:26,896 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] DEBUG - ZEPHYR-10002: Received ZAPI response for "lun-initiator-list-map-info" from "f2":

It’s at this point the datastore ESX02 and ESX04 are missing

<results status='passed'>

<lun-maps>

<lun-map-info>

<path>/vol/ESXSATADATA/ESXSATA01</path>

<initiator-group>VmwareBkup</initiator-group>

<lun-id>6</lun-id>

</lun-map-info>

<lun-map-info>

<path>/vol/ESXSATADATA/ESXSATAEXCH01</path>

<initiator-group>VmwareBkup</initiator-group>

<lun-id>7</lun-id>

</lun-map-info>

<lun-map-info>

<path>/vol/ESXSATA02/ESXSATALUN2</path>

<initiator-group>VmwareBkup</initiator-group>

<lun-id>9</lun-id>

</lun-map-info>

<lun-map-info>

<path>/vol/VMwareBkup/VMwareBkup.lun</path>

<initiator-group>VmwareBkup</initiator-group>

<lun-id>4</lun-id>

</lun-map-info>

</lun-maps>

</results>

2008-12-08 09:49:26,896 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] DEBUG - Datastore: esxtlunpf01 (493542ed-fdcb6538-79a7-001e4f347907)

2008-12-08 09:49:26,896 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] DEBUG - LUN: f1:/vol/esxtpfvol01/esxtpflun01 (1)

2008-12-08 09:49:26,896 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] DEBUG - *** Added all datastores to datastorelist, now will call the getDatastoreMappedToDataStores method

2008-12-08 09:49:26,896 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] DEBUG - Datacenter: ********

2008-12-08 09:49:26,896 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] DEBUG - DataStore: esxsan03 (f1:/vol/ESX03) (485fc2db-aca1c4f8-8645-001e4f347907)

2008-12-08 09:49:26,896 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] DEBUG - DataStore: esxsata01 (f1:/vol/ESXSATADATA) (48776d80-ced00688-6373-001e4f347907)

2008-12-08 09:49:26,896 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] DEBUG - DataStore: esxsan05 (f1:/vol/ESX05) (48f8703c-4e10f298-9b05-001e4f347907)

2008-12-08 09:49:26,896 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] DEBUG - DataStore: esxsata02 (f2:/vol/ESXSATA02) (48f87061-2bacc928-40ab-001e4f347907)

2008-12-08 09:49:26,896 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] DEBUG - DataStore: esxbackup01 (f2:/vol/VMwareBkup) (4912cd8b-80aaec38-8a4b-001e4f347907)

2008-12-08 09:49:26,896 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] DEBUG - DataStore: esxtlunpf01 (f1:/vol/esxtpfvol01) (493542ed-fdcb6538-79a7-001e4f347907)

2008-12-08 09:49:26,896 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] INFO - FLOW-11007: Operation completed

2008-12-08 09:49:26,927 [datastore-list:0dc76478dadd34eb334020c19566bf93:8298d8c3-23c1-489c-8aab-f49e51f67f65] INFO - FLOW-10107: Persisting Checkpoint null (COMPLETE)

2008-12-08 09:49:27,334 [::] DEBUG - Attempting to authenticate user ************with handler com.netapp.smvi.security.authentication.handler.WindowsAuthenticationHandler

2008-12-08 09:49:27,349 [::] DEBUG - WindowsAuthenticationHandler: authenticate: authenticate(********************)

2008-12-08 09:49:27,349 [::] DEBUG - WindowsAuthenticationHandler: authenticate: OS is Windows

2008-12-08 09:49:27,349 [::] DEBUG - WindowsAuthenticationHandler: authenticate: Calling JNI authenticateUser(**************)

2008-12-08 09:49:27,349 [::] DEBUG - WindowsAuthenticationHandler: authenticate: User '**************' granted access

Re: SMVI not listing all datastores when creating a backup

Hi Tony,

Just to make sure I understand correctly - are you trying to back up a VM with VMDKs on multiple datastores and is all storage identified to SMVI?

Thanks,

John