Subscribe

VMware Storage Replication Adapter pairing

I have installed Site Recovery Manager and the Storage Replication Adapter (v 4.0P1) at both my production and recovery sites.  After pairing my production and DR sites I am trying to setup storage replication.  When I select the production or DR site and select the SRA tab the status shows a warning of "Unable to find SRA at the paired site", because of this error I cannot pair the SRA's.  I haven't found much information on this error, but I did come across this article:

https://kb.vmware.com/s/article/2083060

The article talks about setting the environment variable for PERL but doesn't give any examples of what that variable should be.  Could the PERL variable be the cause of my problem? and if so how do I correctly set the variable path?  Any other suggestions on what might be causing this issue would be appreciated.  Thanks.

Re: VMware Storage Replication Adapter pairing

A few things to look at to help troubleshoot.

 

- What do the logs on the SRA server indicate?

- Have you also installed the applicance and registered with the SRA?

- Does it show as SRA being available atleast for one site?

 

Thanks.

Re: VMware Storage Replication Adapter pairing

Hi Sorry for the late reply.  I have tried a complete reinstall of SRM, the SRA Server Appliance and the NetApp Adapter.  

 

In the vSphere client I am now getting a slightly different error:

 

"Unable to find any Storage Replication Adapter (SRA) files.  You must install SRAs before adding or modifying an array manager."

 

I suspect this still relates to the Environment variable path setting,as the error is even closer to the one listed in the article I linked previously.  

 

Here are the Path environment variables on my SRM servers:

 

"Path=%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\"

 

Are there any entries missing?  For reference, I am running SRM 6.1.2.1, SRA Server Appliance and SRA v.4.0P1

 

To answer satishv's questions:

 

1.  I've exported the SRA log bundle from the SRA server virutal appliance but there are lots of logs/files there could you let me know which log files I should be looking at? 

 

2.  Yes to both quesitons. 

 

3.  No, same error for both sites.  

 

 

Re: VMware Storage Replication Adapter pairing

 

My problem was that I missed the 'rescan SRAs' step.  The SRA's are now detected at both sites, however, when I try and create an array manager I now get the following error:

Create Array Manager

SRA command 'discoverArrays' failed.

Cause:
Authentication failed.
Invalid management IP address and/or invalid credentials. Ensure that you provide the correct management IP address with a valid username and password.

I've checked the cluster management IP, username and password and they are all correct.  Also, I've read some articles where certain options not being set could cause this authentication problem, but I'm using clustered ontap 9.1, not 7-mode, so I'm not sure if there are equivalents of the 'httpd.admin.access' or 'httpd.admin.enable' options in C-DOT anymore.