Accepted Solution

VSC 5.0: No linked mode support?

Upon my first run of a VSC 5.0 install (upgraded from 4.2.1) in the web client, my screen stays grey with this message at the top:

"This web client is connected to more than one vCenter server.  Virtual Storage Console does not support this configuration"

I have two vCenter servers running in linked mode.  Am I dead in the water here?

Re: VSC 5.0: No linked mode support?

Officially, VSC does not support Linked Mode vCenter.  Never has.

Dead in the water?  No.  You can run unique installs of VSC on a per-vCenter basis.  Let me look into "how" exactly for you, with regards to the web client.

Backstory: Support for Linked Mode has been floating around as a request for some time.  There has been a lot of back and forth with VMware about the future of federated vCenter management, and whether Linked Mode was the way forward.  That decision hasn't been made, so we've opted to wait until that time and prioritize other features above it.

Re: VSC 5.0: No linked mode support?

I realize that VSC doesn't support linked mode itself; I've always run two copies of it (one for each vcenter server).  When your method of interacting with VSC was through the classic client plugin, I just selected which instance to connect to (and that was fine).

What I am seeing now, though, is the web client detects a linked mode install and doesn't let me work at all.

Honestly linked mode is just a convenience and I can live without it if necessary; but it feels like it's for a silly reason   It would be great if I could just have VSC (via the web client) just look at one server at a time, like with VSC 4.2.1.

Re: VSC 5.0: No linked mode support?


Same Problem herer. New Installation VSC 5.0 and Virtual Center 5.5 Linked Mode. After Registration the VC in VSC nothing happens in the Web Client.

"This web client in connected to more than on Vcenter server, Virtual Storage Console does not support this configuration"

Loading storage system details ... and nothin happens in Web Client ?

Any Workarounds ?


Re: VSC 5.0: No linked mode support?

I've turned off linked mode on my setup this morning (I'm sure some of the admins are going to yell ).  Upgraded my second system and I can see VSC now.

However on the first system, I am still seeing the above error even though linked mode has been disabled.  Restarted services to no avail, thinking I might have to do a reinstall of VSC.

UPDATE:  After a reinstall and a restart of the vSphere Web Client service, it is working (with linked mode disabled).

Re: VSC 5.0: No linked mode support?

Any update on getting this working in the Web Client?  Other requirements mean I can't just disable vCenter Linked Mode.  I only need VSC on this primary vCenter; the other sites aren't NetApp storage anyway.

I've got the same greyed-out screen in Web Client with the red unsupported warning and just spinning "Loading Storage System Details"

Re: VSC 5.0: No linked mode support?

Same problem. it worked in the classic client (seperately)

we need linked mode (SRM, shared licences, single management view)

we also need VSC and use it in our vsphere 5.0 setup (VSC 4.2) fine!


is there any work around such as removing linked mode. carrying out 2 installs and get them working them re-enable linked mode or will it just come back? is there a config file we can stop the check for linked mode happening?

Re: VSC 5.0: No linked mode support?

Can we run VSC 4.2.1 on vsphere 5.5 U1?

that is our current thought process until this is fixed. anyone doing this?

Re: VSC 5.0: No linked mode support?

Any updates on running VSC against a vcenter in linked mode?

Re: VSC 5.0: No linked mode support?

Little bit off topic, but to all People who working with VSC 4.x or 5.x how u mange your Snap Vault Relations VM Backups to a Secondary Filer ?We still using On Command Host packages 1.3 with Data protection Manager from Netapp and it Works with VMWAERE 5.5 ( Local Backup, the Snap Vault VMWARE . Are they any Changes in the VSC 5 Version, that a Local Backup can be Snapvaultet to a Secondary Filer without Scripts, or still only Snapmirror function?