Subscribe
Highlighted

VSC 6.2.1 P1: Incomplete Netapp Storage System detection

[ Edited ]

Hi,

we are currently investigating why our VSC 6.2.1P1 doesnt backup VMs anymore as soon as they were migrated once. Migration processes are complete but during backup cycle there are log-entries like: WARN - Virtual machine {vmname} is currently migrating and will not be backed up

 

(Filer FAS8020 with clustered Ontap 8.3.2P9 with NFS-exports for vsphere 6.5 hosts, vcenter 6.5 vcs-aplliance, no snapcenter, just smvi-backup)

 

Now our problem might be the result of an uncomlete detection / integration of our netapp-filer. We added the filer to VSC by using the FAS-cluster management IP interface using an administrative account.

- VSC Storage system summary shows all privileges are allowed.

- "Related objects" of that storage system lists no hosts, no SVMs and no NAS datastores.

- "Related objects" of that storage system lists all interfaces, except cluster management and interconection interfaces. The nfs-export interfaces with our vmware-volumes-SVMs are listet as "Data-LIF".

 

Adding the storage system or manually selecting "Update Host and Storage data"triggers task "Netapp Storage discovery" which completes in about 2-3 seconds. This task should recognize three of ten NetappSVMs and ten NFS/NAS-datastores and six VM hosts which are using these SVMs and datastores, but it doesnt.

 

Any ideas were to look or what could be the reason?

 

 

Re: VSC 6.2.1 P1: Incomplete Netapp Storage System detection

Same issue with ONTAP 9.1P1 on FAS8040 cluster, with vSphere 6.5.

 

List of issues:

  1. On Summary screen of VSC, Storage System Discovery Status displays “No Data Available”.
  2. Under Storage Systems section, only the cluster displays, SVMs do not display.
  3. In Related Object screen, only the Interfaces tab displays content. However, cluster mgmt. lif is missing.

This is a customer lab test of VSC pre-production.

 

Re: VSC 6.2.1 P1: Incomplete Netapp Storage System detection

[ Edited ]

Hi Wade,

I have a already case open. Until now we have found out the following: our ESXi Server uses lsi_mr3-driver to access its RAID controller. As long as this driver is active, VSC can not get needed information from ESXi-hosts. At VSC-Server in logfile "vsc.log" lines appear like "ERROR (Viapi) - RemoteException: Unable to get information for youresxserverhostname
java.rmi.RemoteException: Exception in WSClient.invoke:;" when you are doing a discovery.

 

If you are using Cisco UCS Server you can switch to another driver as workaround:

https://communities.vmware.com/thread/548631?start=15&tstart=0

 

 

Re: VSC 6.2.1 P1: Incomplete Netapp Storage System detection

Hi, do you have any news about this issue? I'm having the same problem but I don't have the LSI driver as the hosts are HP and don't use LSI drivers.

 

Regards,

JL

Re: VSC 6.2.1 P1: Incomplete Netapp Storage System detection

I was notified today that engineering has released VSC patch release (6.2.1P1D1) for burt 1069251 "Multiple failure: Provision datastore, Host discovery, Backup datastore". Click here to download VSC patch release (6.2.1P1D1)

Re: VSC 6.2.1 P1: Incomplete Netapp Storage System detection

Thank you very much!

 

Have a great weekend!