Subscribe

esxi 5.0 not able to detect FCoE LUN from 3210

Hi Team,I have a question regarding the FCoE/CNA with netapp3210,anybody can advise please ? I have a pair of filer 3210, installed FcoE license. NFS and iscsi tested ok. Now moving to FCOE.2 UTA connected to nexus 5548U, and I can see the connections.I have also brocade CNA card installed on ibm 3650 m4 servers with esxi 5.0 . But   I cannot detect the storage from esxi host when I did a rescan. The LUN on filer has the initiator information of the CNA cards added and igroup as well. Nexus switch’s show flogi database and  zoneset all looks ok. I feel something might be missing on the filer configuration,  any advice please? Thanks

sh vsan 2001 membership

vsan 2001 interfaces:

    fc1/31            fc1/32            vfc3              vfc4

    vfc5              vfc6

sh fcoe

Global FCF details

        FCF-MAC is 00:2a:6a:0f:fa:40

        FC-MAP is 0e:fc:00

        FCF Priority is 128

        FKA Advertisement period for FCF is 8 seconds

VFC MAC details

        vfc3 FCF-MAC is 00:2a:6a:0f:fa:6a

        vfc4 FCF-MAC is 00:2a:6a:0f:fa:69

        vfc5 FCF-MAC is 00:2a:6a:0f:fa:6b

        vfc6 FCF-MAC is 00:2a:6a:0f:fa:6c

sh flogi data

--------------------------------------------------------------------------------

INTERFACE        VSAN    FCID           PORT NAME               NODE NAME

--------------------------------------------------------------------------------

vfc4             2001  0xd90060  50:0a:09:82:88:c9:92:0f 50:0a:09:80:88:c9:92:0f

vfc5             2001  0xd90000  10:00:8c:7c:ff:20:c0:99 20:00:8c:7c:ff:20:c0:99

vfc6             2001  0xd90020  10:00:8c:7c:ff:30:04:0d 20:00:8c:7c:ff:30:04:0d

Total number of flogi = 3.

Nexus5548-B# fcping pwwn  10:00:8c:7c:ff:20:c0:99 vsan 2001

28 bytes from 10:00:8c:7c:ff:20:c0:99 time = 236 usec

28 bytes from 10:00:8c:7c:ff:20:c0:99 time = 210 usec

28 bytes from 10:00:8c:7c:ff:20:c0:99 time = 209 usec

28 bytes from 10:00:8c:7c:ff:20:c0:99 time = 197 usec


Re: esxi 5.0 not able to detect FCoE LUN from 3210

-3210a> igroup show iGroup_FCoE_01

    iGroup_FCoE_01 (FCP) (ostype: vmware):

        10:00:8c:7c:ff:20:10:fd (not logged in)

        10:00:8c:7c:ff:20:84:3d (not logged in)

        10:00:8c:7c:ff:30:04:0d (logged in on: vtic)

        10:00:8c:7c:ff:20:c0:99 (not logged in)

        10:00:8c:7c:ff:20:10:fc (not logged in)

        10:00:8c:7c:ff:20:c0:98 (not logged in)

Re: esxi 5.0 not able to detect FCoE LUN from 3210

do a "shut" and "no shut" on these below WWN ports

        10:00:8c:7c:ff:20:10:fd (not logged in)

        10:00:8c:7c:ff:20:84:3d (not logged in)

        10:00:8c:7c:ff:20:c0:99 (not logged in)

        10:00:8c:7c:ff:20:10:fc (not logged in)

        10:00:8c:7c:ff:20:c0:98 (not logged in)

once you disable and enable these ports, Filer should detect them under "igroup show" command.

even after disable and enable, Filer is not detecting the WWNs, then try to move those cables to a different port and try the above activity.

this should resolve your issue.

Re: esxi 5.0 not able to detect FCoE LUN from 3210

Thanks for reply, I have 2 connections from each server and 2 from netapp filers, for the 2 nexus, so the below shows not all logged in . but even for th3 wwn which are already logged in, the esxi still not able to detect the LUN. I have triedot shut and no shut for vfc 3 - 6 ports with any changes....

any advice please? thanks

igroup show

    iGroup_FCoE_01 (FCP) (ostype: vmware):

        10:00:8c:7c:ff:20:c0:98 (not logged in)

        10:00:8c:7c:ff:20:84:3c (not logged in)

        10:00:8c:7c:ff:30:04:0c (not logged in)

        10:00:8c:7c:ff:20:10:fc (not logged in)

        10:00:8c:7c:ff:20:84:3d (logged in on: vtic, 1a)

        10:00:8c:7c:ff:20:10:fd (logged in on: vtic, 1a)

        10:00:8c:7c:ff:30:04:0d (logged in on: vtic, 1b)

        10:00:8c:7c:ff:20:c0:99 (not logged in)

    iGroup_iSCSI_SQL (iSCSI) (ostype: windows):

        iqn.1991-05.com.microsoft:sql01 (not logged in)

    iGroup_vmware_iscsi (iSCSI) (ostype: vmware):

        iqn.1998-01.com.vmware  (not logged in)

5548-B# fcping pwwn 50:0a:09:82:98:c9:92:0f vsan 2001

28 bytes from 50:0a:09:82:98:c9:92:0f time = 148 usec

28 bytes from 50:0a:09:82:98:c9:92:0f time = 185 usec

-Nexus5548-B# fcping pwwn  50:0a:09:82:88:c9:92:0f vsan 2001

28 bytes from 50:0a:09:82:88:c9:92:0f time = 148 usec

28 bytes from 50:0a:09:82:88:c9:92:0f time = 141 usec

28 bytes from 50:0a:09:82:88:c9:92:0f time = 228 usec

Nexus5548-B#

-3210b>  ifconfig e1a

e1a: flags=0x8f48867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 02:a0:98:3d:9b:fc (auto-10g_twinax-fd-up) flowcontrol full

        trunked VIF-b

s-3210b>  ifconfig e1b

e1b: flags=0x8f48867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 02:a0:98:3d:9b:fc (auto-10g_twinax-fd-up) flowcontrol full

        trunked VIF-b

3210b> ifconfig VIF-b

VIF-b: flags=0x24f48863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM,NOWINS> mtu 1500

        inet 192.168.10.132 netmask 0xffffff00 broadcast 192.168.10.255

        partner vif-a (not in use)

        ether 02:a0:98:3d:9b:fc (Enabled interface groups)

-3210b>

Re: esxi 5.0 not able to detect FCoE LUN from 3210

can you paste the o/p of  "storage show adapter "  from Filer.