-
How to decide which NetApp API to use?
I'm often asked by customers or partners which API they should use to get information for their NetApp systems. The most common use-case is that they are putting together a dashboard, which is often multi-platform or multiple layers of the tech stack. I put together a relatively simple flowchart to help determine whether…
-
Inode (files) value on aggregate level?
How do I get these two values trough the new REST API? files-total: Total user-visible file (inode) count, i.e., maximum number of user-visible files (inodes) that this referenced file system can currently hold. If the referenced file system is restricted or offline, a value of 0 is returned files-used: Number of…
-
AIQ API - platformType String
I am trying to collect some data from the "/v1/health-check/recommended_software/firmware_details" API in Active IQ, and the documentation mentions that a parameter named "platformType" is required in the GET request, but I cannot find any supporting documentation that explains what the available values are for that…
-
CloudInsights very occasionally returning Vmdks with IDs that don't map to anything
Hi all, I've written a .NET Console app that imports in data from CloudInsights into our SQL database. It's making about 80,000 HTTP requests to the API that are throttled to no more than 50 consecutive requests. Once in a blue moon on a Friday the thirteenth, I get the following error response to all of my requests…
-
Missing OnTAP REST API calls
Several API calls are missing from the OnTAP REST interface. Many or all of these are present in the NMSDK interface. The missing commands correspond to these OnTAP commands and sub-commands: volume modify commands such as: space-nearly-full-threshold-percent space-full-threshold -percent vserver security file-directory…
-
How to know ONTAP and NMSDK API calls are GET / POST requests?
How to know ONTAP and NMSDK API calls are GET / POST requests? I am using methods like AggrListInfoRequest to get the data from the NetApp Cluster.
-
NetApp API quota-set-entry
Hello, We have a quote a few NAS SVMs running accross 2 cDot Clusters that run Ontap 9.4P3, when attempting to use quota-set-entry through the API we receieve following error but only on a handful of SVMs. "Missing Input: policy" The strange thing is that it always fails on 4 out 20 SVMs when the policy is not set in the…