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Introduction to Simulate ONTAP 

Simulate ONTAP is a simulator for running ONTAP software. It enables you to test the 
features of ONTAP without having to buy new hardware or disturb your production 
environment.  

Simulate ONTAP is a VMware virtual machine that runs on a hypervisor. You can run 
Simulate ONTAP on a Windows or a Mac system, or directly on a VMware ESXi server. 

Supported VMware applications 
You can install Simulate ONTAP only on certain VMware applications. 

You need to install one of the following VMware applications on the host system to use 
Simulate ONTAP: 

• VMware Workstation 

• VMware Player 

• VMware vSphere 

• VMware Fusion 

Limitations and unsupported features 
Simulate ONTAP supports most ONTAP functionality and most of its features. However, 
Simulate ONTAP has some functional limitations and does not support some ONTAP 
features because of the virtualization architecture. 

Simulate ONTAP has the following limitations: 

• Non-Volatile RAM (NVRAM) is simulated and is not persistent. 

Data loss might occur after power cycles. You must shut down the simulator properly to 
avoid data loss. 

• You can have a maximum of four simulated disk shelves with 14 disk drives per shelf, 
for a total of 56 drives per simulator. 

• Each simulated drive is limited to 9 GB. 
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Note: The simulator image comes pre-configured with 28 1 GB disks; 14 each on 
simulated disk shelves 0 and 1. Simulated disk shelves 2 and 3 are not populated. You 
can configure up to a maximum of 220 GB total space for each Simulate ONTAP node. 

• You can create 64-bit aggregates, but they are limited to a maximum of 9 GB per 
simulated disk drive. 

• Simulate ONTAP is not suitable for applications that require high performance or heavy 
I/O. 

• No more than two instances of the simulator can be booted simultaneously. 

Simulate ONTAP does not support the following features: 

• High Availability (CFO/SFO) 

• Fibre channel and SAN connectivity 

• RLM (Remote LAN Module) 

• CFE, BIOS, shelf FW, and so on 

• Multipathing 

Downloading Simulate ONTAP software 
The Simulate ONTAP software is a set of VMware files that have been packaged in an .ova 
file. You need to download the appropriate software and license files from the NetApp 
Support Site. 

About this task 

Different .ova files are available depending on whether you plan to run the simulator on a 
VMware ESXi server, or on one of the supported VMware desktop applications. 

Steps 

1. Log in to the NetApp Support Site at mysupport.netapp.com 

2. Type your user name and password, and then click Login. 

3. In the Downloads section, select Tools and Add-Ons for Purchased Products. 

The ToolChest page displays. 

http://mysupport.netapp.com/
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4. Scroll down the list of tools and click Simulate ONTAP for ONTAP 8.x and 9.x. 

The Simulate ONTAP Description page displays. 

5. Click Continue to go to the Download page. 

6. In the row that corresponds to the version of Simulate ONTAP you want to use (for 
example, 9.3), download the ONTAP simulator software by selecting the vsim-esx-
DOT9.3-cm.ova link for VMware ESXi or for running on a hypervisor. 

The File Download popup window displays. 

7. Click the Save button to save the .ova file to the applicable location: 

If you are downloading to... Then... 

A Windows system Save the file to the C:\Virtual Machines folder. 

A Mac system Save the file to the download folder. 

An ESXi server Save the file to a location that is accessible to your 
VMware vSphere Client. 

8. After the download is complete, click the VSIM Licenses link to display the list of 
ONTAP licenses that you need to unlock certain ONTAP features, and then save this 
information to your computer. 
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Installing Simulate ONTAP on a Windows 
system 

You can install Simulate ONTAP on a Windows system and test the features of ONTAP 
software. 

In a Windows system, you need to have one of the following VMware applications installed 
before you can run Simulate ONTAP: 

• VMware Workstation 

• VMware Player 

Windows system requirements 
You must ensure that the hardware and software prerequisites are met before installing 
Simulate ONTAP on a Windows system.  Also ensure that you have administrative privileges.   

Hardware requirements 
• Dual core 64-bit Intel or AMD system 

• 5.1 GB of RAM for one instance of the simulator 

• 10.2 GB of RAM for two instances of the simulator 

• 40 GB of free disk space for each instance of the simulator 

• VT support for Intel system 

Software requirements 
• Microsoft Windows 7 or Microsoft Windows 10 

• VMware Workstation (11.1.0) or VMware Player (7.1.0) 

Enabling the VT feature 
To install Simulate ONTAP on a Windows system, you must enable the VT feature. The VT 
can be referred to as Vanderpool Technology, Virtualization Technology, or Virtual Machine 
Extensions. The VT setting can be found under a Security or CPU screen in the BIOS. 
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About this task 

By default, VT is disabled on an Intel-based system. 

Steps 

1. Access the system BIOS while booting your laptop or desktop. 

2. In the BIOS, enable VT if it is not already enabled. 

3. Save the changes to the BIOS settings and then turn off the system. 

4. Turn on the system again. 

Note: If you reboot the system without turning it off, VT is not enabled. 

Installing Simulate ONTAP on VMware Workstation 
You can download and install VMware Workstation on a Windows laptop or desktop, 
configure the VMware Workstation for Simulate ONTAP, start Simulate ONTAP Guest OS 
on the VMware Workstation, and configure the network adapters on the VMware 
Workstation. 

Note: You cannot install multiple versions of VMware Workstation on the same host. 

For information about installing VMware Workstation software, and for VMware 
Workstation documentation, see the VMware Web site. 

Related information 

VMware Workstation software 

Workstation User’s Manual 

Configuring VMware Workstation for Simulate ONTAP 
Using the Preferences menu, you can change the default location for virtual machines. You 
can also set the preferences for the virtual machines and software updates. 

Steps 

1. Click Start > All Programs > VMware > VMware Workstation. 

2. In the VMware Workstation window, click Edit > Preferences. 

http://downloads.vmware.com/d/
http://www.vmware.com/support/pubs/ws_pubs.html
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By default, the Workspace tab is selected in the Preferences window. 

3. Click Browse to select the default location for Simulate ONTAP virtual machines. 

4. Select the Preferences for the following: 

a. Default location for virtual machines 

b. Virtual machines 

c. Privacy 

 

5. Click OK.  

Configuring network adapters on VMware Workstation 
You must configure network adapters on VMware Workstation to support Simulate ONTAP 
on your laptop or desktop. 

About this task 

There are two virtual network configurations that you can use on your laptop or desktop: 
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• Host-Only and Custom 

All virtual interfaces used by Simulate ONTAP are set to host-only and custom. 

• Bridged and Custom 

Virtual network interface vmnet0 is set to bridged and all other interfaces used by 
Simulate ONTAP are set to either host-only or custom. 

If the virtual network interface vmnet0 is set as bridged, then you can use the physical 
Ethernet port of your laptop to access all volumes created and mounted by using ONTAP. 
This works only if the IP addresses and subnet are static. 

Steps 

1. Click Start > All Programs > VMware > Virtual Network Editor. 

2. In the Virtual Network Editor window, select the virtual network interface as per your 
requirements. 

3. Click OK. 

Starting Simulate ONTAP on VMware Workstation 
You must start Simulate ONTAP on VMware Workstation to access the Simulate ONTAP 
console. 

Steps 

1. Click Start > All Programs > VMware > VMware Workstation. 

2. In the VMware Workstation window, click File > Open. 

3. In the Open window, select the .ova file described in Downloading Simulate ONTAP 
software on page 6, and then click Open. 

4. In the Import Virtual Machine window, provide a name and local storage path for the new 
virtual machine, and then click Import. 
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5. In the virtual machine tab, click the Power on this virtual machine icon. 

 

After you finish 

To configure ONTAP, see ONTAP setup on page 29 and the ONTAP Software Setup Guide 
on the NetApp Support Site at mysupport.netapp.com 

 

http://mysupport.netapp.com/


Installation and Setup Guide  | 13 

Installing Simulate ONTAP on VMware Player 
You can download and install the VMware Player on a Windows laptop or desktop, start 
Simulate ONTAP, set preferences for the Simulate ONTAP virtual machine, and configure 
network adapters on the VMware Player. 

For information about installing VMware Player software and VMware Player 
documentation, see the VMware Web site. 

Related information 

VMware Player software 

VMware Player Getting Started Guide 

Starting Simulate ONTAP on VMware Player 
You must start the Simulate ONTAP virtual machine to configure ONTAP in the VMware 
Player console. 

Steps 

1. Click Start > All Programs > VMware > VMware Player. 

2. In the VMware Player window, click Open a Virtual Machine. 

 

http://downloads.vmware.com/d/
http://www.vmware.com/support/pubs/player_pubs.html
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3. In the Open Virtual Machine window, select the .ova file described in Downloading 
Simulate ONTAP software on page 6, and then click Open. 

4. In the Import Virtual Machine window, provide a name and local storage path for the new 
virtual machine and then click Import. 

 

Result 

Simulate ONTAP opens in the VMware Player console. 

Setting preferences for the Simulate ONTAP virtual machine 
In the Simulate ONTAP virtual machine, you can set preferences to select the mode of exit 
and to check the web for updates on startup. 

Steps 

1. In the VMware Player window, click Player > File > Preferences. 

2. In the Preferences window, select the mode of exit from one of the following options: 

• Suspend the virtual machine 

• Power off the virtual machine 
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You can also select “Confirm before exiting the application” to receive a confirmation prompt 
when exiting the virtual machine. 

3. Click OK. 

Configuring network adapters on VMware Player 
You must configure network adapters on VMware Player to support Simulate ONTAP on 
your laptop or desktop. 

Steps 

1. In the VMware Player Simulate ONTAP console, click Edit virtual machine settings. 
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2. Set the appropriate network type depending on the network adapters: 

If you are using... Then set the network type as... 

Network Adapter and 
Network Adapter 2 

Host-only 

Network Adapter 3 Bridged 

After you finish 

To configure clustered ONTAP, see ONTAP setup on page 29 and the ONTAP Software Setup 
Guide on the NetApp Support Site at mysupport.netapp.com  

http://mysupport.netapp.com/
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Installing Simulate ONTAP on a Mac system 

You can install Simulate ONTAP on a Mac operating system to test the features of ONTAP. 

Mac system requirements 
You must ensure that the hardware and software prerequisites are met before installing 
Simulate ONTAP on a Mac (Apple) operating system.  Also ensure that you have 
administrative privileges. 

Hardware requirements 
• Intel Core 2 Duo processor 

• 5.1 GB of RAM for one instance of the simulator 

• 10.2 GB of RAM for two instances of the simulator 

• 40 GB of free disk space for each instance of the simulator 

• Physical Address Extension (PAE) support 

Software requirements 
• Mac OS X 10.6.8 

• VMware Fusion 7.1.1 

Installing Simulate ONTAP on VMware Fusion 
You can download and install VMware Fusion on a Mac (Apple) system, configure VMware 
Fusion to run Simulate ONTAP, add Simulate ONTAP on VMware Fusion, start Simulate 
ONTAP, and configure the network adapters on VMware Fusion. 

For information about installing VMware Fusion software and VMware Fusion 
documentation, see the VMware Web site. 

Related information 

VMware Fusion software 

VMware Fusion documentation 

http://downloads.vmware.com/d/
http://www.vmware.com/support/pubs/fusion_pubs.html
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Configuring VMware Fusion to run Simulate ONTAP 
To run Simulate ONTAP on a Mac operating system, you must configure VMware Fusion 
software by setting the preferences on a Mac laptop or desktop. 

Steps 

1. On your Mac laptop or desktop, click Applications. 

2. In the Applications window, click VMware Fusion. 

3. Select VMware Fusion > Preferences. 

4. In the General window, you can set one of the following preferences for the action to take 
when closing the virtual machine. 

• Suspend the virtual machine 

• Power off the virtual machine 

You can also select “Confirm before closing” to receive a confirmation message when closing 
the virtual machine. 

Adding Simulate ONTAP on VMware Fusion 
To install Simulate ONTAP on VMware Fusion, you must add Simulate ONTAP to the 
virtual machine library by using the VMware Fusion software. 

Steps 

1. On the desktop, click Applications. 

2. In the Applications window, click VMware Fusion. 

3. Click File > Import. 

4. In the Choose an Existing Virtual Machine window, choose the .ova file described in 
Downloading Simulate ONTAP software on page 6, and click Continue. 
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5. Provide a name for the new virtual machine in the Save As text box and then click Save. 

6. In the Finished window, click Finish to run the virtual machine or click Customize Settings 
to change the default virtual machine settings.  

Result 

The added Simulate ONTAP virtual appear in the Virtual Machine Library. 
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Configuring network adapters on VMware Fusion 
You must configure network adapters on VMware Fusion to support Simulate ONTAP on 
your computer. 

You can configure the network adapters on VMware Fusion to the following types of network 
configuration: 

• Host-Only network adapters 

• Bridged network adapters 

Configuring host-only network adapters on VMware Fusion 

You can configure network adapters on VMware Fusion to change to the host-only network 
configuration. 

Steps 

1. Select a Simulate ONTAP virtual machine from the Virtual Machine Library. 

2. Click Virtual Machine > Network Adapter 3 > Host-only. 

By default, the Network Adapter 3 is set to NAT. 

Click Virtual Machine > Settings. 

Select Network. 

Host-Only Network configurations can use any IP subnet class. In the configuration tested, 
172.16.0.0 subnet 255.255.0.0 is used for cluster traffic, and 10.97.105.0 subnet 
255.255.255.0 is used for management and data traffic. 

Result 

The virtual network dialog box appears with the summary of active network adapters. 
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Configuring bridged network adapters on VMware Fusion 

You can configure the network adapters on VMware Fusion to the bridged network 
configuration. When configured using bridged mode, you can export volumes and manage 
simulator guests by using static IP addresses. 

Steps 

1. Select a Simulate ONTAP virtual machine from the Virtual Machine Library. 

2. Click Virtual Machine > Network Adapter 3 > Bridged. 

By default, the Network Adapter 3 is set to NAT. 

Click Virtual Machine > Settings. 

3. Select Network. 

Changes are automatically saved when you close the virtual network editor dialog box. 

Result 

The virtual network dialog box appears with the summary of active network adapters. 

After you finish 

Consult with your local IT support group for static IP address allocation for ONTAP 
simulators. 
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Starting Simulate ONTAP on VMware Fusion 
You must start the Simulate ONTAP virtual machine to configure ONTAP in the VMware 
Fusion console. 

Steps 

1. On the desktop, click Applications. 

2. In the Applications window, click VMware Fusion. 

3. Select Window > Virtual Machine Library. 

4. Select a Simulate ONTAP virtual machine from the Virtual Machine Library. 

5. Click Start up. 

After you finish 

To configure clustered ONTAP, see ONTAP setup on page 29 and the ONTAP Software Setup 
Guide on the NetApp Support Site at mysupport.netapp.com 

  

http://mysupport.netapp.com/
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Installing Simulate ONTAP on VMware 
vSphere 

You can install Simulate ONTAP on a VMware vSphere system and test the features of 
ONTAP software. 

VMware vSphere system requirements 
You must ensure that the hardware and software prerequisites are met before installing 
Simulate ONTAP on a VMware ESXi system. 

Minimum ESXi server hardware requirements 
• 8 GB of RAM for one instance of the simulator 

• 16 GB of RAM for two instances of the simulator 

• 230 GB of free disk space for each instance of the simulator 

• VT support for Intel systems 

Software requirements 
• VMware vSphere 5.5, including VMware ESXi and VMware vSphere Client, and 

optionally vCenter Server 

Additional requirements 

There are additional networking requirements when installing Simulate ONTAP on an ESXi 
host. There are also requirements for the computer on which the vSphere Client software is 
installed. The instructions provided in this manual reference the vSphere Client software 
instead of the vSphere Web Client.  

For more information, see the “System Requirements” chapter of the VMware ESXi and 
vCenter Server Installation Guide for complete hardware and software requirements. 

Installing Simulate ONTAP on VMware ESXi 
You can download and install VMware ESXi on a server, and then install and start Simulate 
ONTAP on that server. 
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VMware ESXi is different from the other VMware virtualization software described in this 
manual because it cannot be installed on a laptop—it must be installed on a server. 
Additionally, you must install the VMware vSphere Client on a separate computer to install 
and manage the Simulate ONTAP virtual machine on the ESXi host. For this reason, it is 
recommended that you install Simulate ONTAP on ESXi only if you are familiar with 
VMware ESXi, or if someone at your site has this knowledge. 

For information about installing VMware ESXi and VMware vSphere Client software, and for 
VMware ESXi documentation, see the VMware web site. 

Installing Simulate ONTAP on VMware ESXi involves the following tasks: 

• Create a cluster network 

• Create a NAS network (required only when deploying Simulate ONTAP to a NAS 
datastore) 

• Register the Simulate ONTAP virtual machine 

• Start the Simulate ONTAP virtual machine 

Related information 

VMware ESXi 5.5 software 

VMware vSphere 5.5 Documentation Center 

vSphere Installation and Setup 

Creating a cluster network 
When running ONTAP, you must create a network for the cluster traffic that is separate from 
the network for data traffic. This effectively creates a virtual machine port group. 

About this task 

Both Simulate ONTAP instances in the cluster must be running on the same ESXi server. 

Steps 

1. Log in to the vSphere Client and select the ESXi host from the inventory panel. 

2. Select the Configuration tab, and then click Networking (under the Hardware list). 

https://my.vmware.com/web/vmware/details?productId=352&downloadGroup=ESXI550
https://pubs.vmware.com/vsphere-55/index.jsp
https://pubs.vmware.com/vsphere-55/topic/com.vmware.vsphere.install.doc/GUID-7C9A1E23-7FCD-4295-9CB1-C932F2423C63.html
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3. In the vSphere Standard Switch view, click Add Networking. 

The Add Network Wizard is launched. 

4. In the Connection Type page, select Virtual Machine, and then click Next. 

5. In the Virtual Machines – Network Access page: 

a. Select the vSwitch to use, or select Create a vSphere standard switch to create a new 
vSwitch. 

b. Click Next. 

6. In the Virtual Machines – Connection Settings page: 

a. In the Network Label field, enter a name that identifies the network you are creating, for 
example, “Cluster Network”. 

b. Click Next. 

7. In the Ready to Complete page, verify the details about the Virtual Machine port group you 
are adding, and then click Finish. 

You can click Back if you need to make any corrections. 

Creating a network to access the NAS datastore 
If you are planning to deploy the Simulate ONTAP files to a NAS datastore, then you need to 
create a network on the ESXi server that will enable communication with the remote 
datastore. This step creates a VMkernel port group (network) where the NAS can be mounted 
on the ESXi server. 

About this task 

See the VMware ESXi Configuration Guide if you need more details about creating a new 
network. 

If you are accessing Simulate ONTAP files on a local datastore, skip this section. 

Steps 

1. Log in to the vSphere Client and select the ESXi host from the inventory panel. 

2. Select the Configuration tab and click Networking (under the Hardware list). 
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3. In the vSphere Standard Switch view, click Add Networking. 

The Add Network Wizard is launched. 

4. In the Connection Type page, select VMkernel and click Next. 

5. In the VMkernel - Network Access page, perform the following steps: 

a) Select the vSwitch to use and the check box(es) for the virtual network adapter(s) 
your vSwitch will use, if available, to provide access to the datastore. 

or  

Select Create a vSphere standard switch to create a new vSwitch. 

b) Click Next. 

6. In the VMkernel - Connection Settings page, perform the following steps: 

a) In the Network Label field, enter a name that identifies the network you are 
creating, for example, "Datastore Network". 

b) Click Next. 

7. In the VMkernel - IP Connection Settings page, perform the following steps: 

a) Enter the IP connection details manually, or select Obtain IP settings automatically 
to use DHCP to obtain the IP settings. 

b) Click Next. 

8. In the Ready to Complete page, verify the details about the VMkernel port group you are 
adding and click Finish. Note that you can click Back if you need to make any corrections. 

If you receive a message about the gateway not being specified, enter the Default gateway 
details and click Finish. 

9. Mount the datastore as a NAS datastore on the ESXi server. 

Result 

The VMkernel network that will be used to access the NAS datastore is created successfully 
and the datastore is mounted. 
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Registering Simulate ONTAP on an ESXi server 
To register Simulate ONTAP on an ESXi server, you must deploy the Simulate ONTAP.ova 
file using the vSphere Client. 

Steps 

1. Log in to the vSphere Client and select the ESXi host from the inventory panel. 

2. Click File > Deploy OVF Template. 

The Deploy OVF Template Wizard is launched. 

3. In the Source page, browse to the .ova file described in Downloading Simulate ONTAP 
software on page 6 and click Next. 

4. In the OVF Template Details page, verify the details about the ova selected and then click 
Finish. 

5. In the Name and Location page, specify a name and location for the deployed template and 
then click Next. 

6. In the Storage page, select where you want to store the virtual machine files and then click 
Next. 

7. In the Disk Format page, click Next. 

8. In the Network Mapping page, map the network used in the ova files to the networks in your 
inventory and then click Next. 

9. In the Ready to Complete page, verify the details about the Virtual Machine you are creating, 
and then click Finish. 

You can click Back if you need to make any corrections. 

 

Starting Simulate ONTAP on a VMware ESXi server 
You must start the Simulate ONTAP virtual machine to access ONTAP through the VMware 
ESXi console. 
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Steps 

1. In the left pane of the vSphere Client, select the Simulate ONTAP virtual machine that you 
created. 

2. Click the Summary tab to view the details about this virtual machine. 

3. Click the Power On button to start the virtual machine. 

4. After the virtual machine is running, open the console to the ONTAP interface: 

• Open the console in a separate window by right-clicking the virtual machine, and then 
selecting Open Console. 

• Open the console within the vSphere Client window by clicking the Console tab. 

You must press Ctrl-Alt to free the cursor from the console window to perform other tasks. 

After you finish 

To configure ONTAP, see ONTAP setup on page 29 and the ONTAP Software Setup Guide 
on the NetApp Support Site at mysupport.netapp.com 

  

http://mysupport.netapp.com/
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ONTAP setup 

You can set up ONTAP software on Simulate ONTAP virtual machines to test ONTAP 
features. 

You will need to collect information about the network, such as IP addresses, network mask, 
default gateway, and so on, before setting up the Simulate ONTAP virtual machine. 

For complete information about configuring ONTAP, see the ONTAP Software Setup Guide 
and the ONTAP 9.0 Documentation page on the NetApp Support Site at 
mysupport.netapp.com 

Configuring your ONTAP simulators 
Configuring a cluster of ONTAP simulators involves setting up ONTAP software on one or 
more simulators. You create the cluster while setting up the first node, and then you join the 
second node to the cluster while setting up the second node. 

You must initialize the simulator to run it for the first time. 

Note: The simulator might hang and reboot repeatedly if the initialization steps are not 
performed correctly. 

Booting the first node 
You should use the Cluster Setup wizard to create the cluster on the first node. The wizard 
helps you to configure the cluster network that connects the nodes, create the cluster admin 
Storage Virtual Machine (SVM, formerly known as Vserver), add feature license keys, and 
create the node management interface for the first node. You must boot the first node to create 
the cluster. 

Steps 

1. Click inside the vSphere Client Console window for the simulator virtual machine, and when 
the Press Ctrl-C for Boot Menu message is displayed, press Ctrl-C. 

NetApp Data ONTAP 8.x.x Cluster-Mode 
Copyright (C) 1992-2015 NetApp. 
All rights reserved. 
running fsck_msdosfs on /cfcard 

http://mysupport.netapp.com/
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md1.uzip: 39168 x 16384 blocks 
md2.uzip: 5760 x 16384 blocks 
******************************* 
*                             * 
* Press Ctrl-C for Boot Menu. * 
*                             * 
******************************* 
^C  
Boot Menu will be available. 

Note: You might see disk status messages before the menu appears; ignore such 
messages. 

When the Boot Menu is displayed, enter 4 and press Enter. 

Please choose one of the following: 
(1) Normal Boot. 
(2) Boot without /etc/rc. 
(3) Change password. 
(4) Clean configuration and initialize all disks. 
(5) Maintenance mode boot. 
(6) Update flash from backup config. 
(7) Install new software first. 
(8) Reboot node. 
Selection (1-8)? 4 

At the Zero disk, reset config and install a new file system? prompt, enter 
y and press Enter. 

Zero disks, reset config and install a new file system?: y 

At the confirmation prompt, enter y and press Enter. 

The VM restarts automatically and begins the reset process. 

This will erase all the data on the disks, are you sure?: y 
Rebooting to finish wipeconfig request. 
Skipped backing up /var file system to CF. 

Note: You must wait until the reset process is completely finished. If you stop the 
process, you might corrupt the simulator files (simulator disks) and might be required to 
extract them again. After the VM resets, the node setup wizard will start. 
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Creating the cluster 
Creating a cluster enables you to pool the resources and distribute work across the members 
(nodes) of the cluster, while presenting administrators with a single entity to manage. 

Before you begin 

You should have obtained a base cluster license and ONTAP feature licenses from the 
Simulate ONTAP download page.  

Steps 

1. After the node boots, the Node Setup wizard starts on the console, informing you that 
AutoSupport will be enabled automatically. 

Welcome to node setup. 
 
You can enter the following commands at any time: 
  "help" or "?" - if you want to have a question clarified, 
  "back" - if you want to change previously answered questions, and 
  "exit" or "quit" - if you want to quit the setup wizard. 
     Any changes you made before quitting will be saved. 
 
To accept a default or omit a question, do not enter a value. 
 
This system will send event messages and weekly reports to NetApp Technical 
Support. To disable this feature, enter "autosupport modify -support disable"  
within 24 hours. Enabling AutoSupport can significantly speed problem  
determination and resolution should a problem occur on your system.  
For further information on AutoSupport, see: 
http://support.netapp.com/autosupport/ 
 
Type yes to confirm and continue {yes}: 

2. Exit the Node Setup wizard: 

exit 

The Node Setup wizard enables you to configure the node's node management interface for 
use with System Setup. You do not need to use the Node Setup wizard if you are setting up 
the cluster in the CLI. 
 
The Node Setup wizard exits and a login prompt appears, warning that you have not 
completed the setup tasks: 



32 | Simulate ONTAP 9.3 Installation and Setup Guide 

Exiting the node setup wizard. Any changes you made have been saved. 
 
Warning: You have exited the node setup wizard before completing all 
of the tasks. The node is not configured. You can complete node setup by 
typing "node setup" in the command line interface. 
 
login:  

3. Log in to the admin account by using the admin user name. 

4. Start the Cluster Setup wizard: 

cluster setup 

::> cluster setup 
 
Welcome to the cluster setup wizard. 
 
You can enter the following commands at any time: 
  "help" or "?" - if you want to have a question clarified, 
  "back" - if you want to change previously answered questions, and 
  "exit" or "quit" - if you want to quit the cluster setup wizard. 
     Any changes you made before quitting will be saved. 
 
You can return to cluster setup at any time by typing "cluster setup". 
To accept a default or omit a question, do not enter a value. 
 
Do you want to create a new cluster or join an existing cluster? {create, 
join}: 

5. When prompted whether you want to create a new cluster or join an existing cluster, enter 
create and press Enter. 

Example 

Welcome to the cluster setup wizard. 
 
You can enter the following commands at any time: 
"help" or "?" - if you want to have a question clarified, 
"back" - if you want to change previously answered questions, and 
"exit" or "quit" - if you want to quit the cluster setup wizard. 
Any changes you made before quitting will be saved. 
 
You can return to cluster setup at any time by typing "cluster setup". 
To accept a default or omit a question, do not enter a value. 
 
Do you want to create a new cluster or join an existing cluster? 
{create}: 
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create 

6. When prompted whether you want to use the system default values, press Enter to accept the 
default answer yes. 

The default answer, when available, is shown in brackets. 

Example 

System Defaults: 
Private cluster network ports [e0a]. 
Cluster port MTU values will be set to 1500. 
Cluster interface IP addresses will be automatically generated. 
 
Do you want to use these defaults? {yes, no} [yes]: <Enter> 

When prompted for an “admin” password, enter a strong password with numbers and letters 
and confirm. 

Write your password in the space provided and do not lose it. 

Password: _________________________  

After the cluster interfaces are created, enter a name for your cluster. 

Example 

It can take several minutes to create cluster interfaces... 
Step 1 of 5: Create a Cluster 
You can type "back", "exit", or "help" at any question. 
 
Enter the cluster name: cluster1 

When prompted for the cluster base license key, enter the base license you downloaded  
(do not enter the characters in the example). 

Example 

Enter the cluster base license key: A2A4A6A8AB2AAAAAAAAAAAAA 
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When prompted to enter feature licenses, press Enter to continue. 

You can add ONTAP feature licenses later. You must temporarily exit the configuration steps 
to locate the VMware IP addresses that were created during the virtual machine 
installation. 

a) Press Ctrl+Alt to exit the Console window and return to the Windows operating 
system. 

b) Open a Windows command prompt and enter ipconfig. 

c) Find and record the VMnet1 (Host-only) IPv4 address and subnet mask. 

You must assign IP addresses to the simulator ports in the VMnet1 subnet (for 
example 192.168.65.20). 

VMnet1 IPv4 Address: __________________________________________ 

VMnet1 Subnet Mask: __________________________________________ 

Example 

The following example is specific to the VMware Player environment. You should 
configure IP addresses for the e0c and e0d ports based on your network settings. 

Ethernet adapter VMware Network Adapter VMnet1: 
Connection-specific DNS Suffix.: 
Link-local IPv6 Address........: fe80::e95e:d77a:1b5b:a70dz22 
IPv4 Address...................: 192.168.x.20 
Subnet Mask....................: 255.255.255.0 
Default Gateway................: 

Return to the vSphere Console window for the simulator, and then enter the following values 
to define the cluster management port using the information you gathered in the previous 
step: 

• Enter the cluster management interface port [e0d]: e0c 

• Enter the cluster management interface IP address: 192.168.x.20 (x =your subnet) 

• Enter the cluster management interface netmask: 255.255.255.0 

• Enter the cluster management interface default gateway: (leave blank) 

Enter the cluster management interface port [e0d]: e0c 
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Enter the cluster management interface IP address: 192.168.x.20 
Enter the cluster management interface netmask: 255.255.255.0 
Enter the cluster management interface default gateway: <Enter> 
 
A cluster management interface on port e0c with IP address 192.168.x. 
20 has been created. 
You can use this address to connect to and manager the cluster. 
 
Enter the DNS domain names: <Enter> 

You connect to and manage the cluster using the cluster management interface IP 
address. Enter that IP address in the space provided below: 

Cluster Management Interface: __________________________________________ 

Note: The preceding example is specific to the VMware Player environment. You should 
configure IP addresses for the e0c and e0d ports based on your network settings. 

Press Enter when prompted for the DNS domain names to continue to the next step. 

When prompted for a location of the controller, enter the type of location; for example, the 
name of the building or the lab, and press Enter to continue. 

Example 

Where is the controller located []: lab2 

Enter the following values to define the node management port using the information you 
gathered in the previous steps: 

• Enter the node management interface port [e0c]: e0c 

• Enter the node management interface IP address: 192.168.x.21 (x is your subnet) 

• Enter the node management interface netmask: 255.255.255.0 

• Enter the node management interface default gateway: <Enter> 

Example 

The following example is specific to the VMware Player environment. You should 
configure IP addresses for the e0c and e0d ports based on your network settings. 
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Enter the node management interface port [e0c]: <Enter> 
Enter the node management interface IP address: 192.168.x.21 
Enter the node management interface netmask: 255.255.255.0 
Enter the node management interface default gateway: <Enter> 
A node management interface on port e0c with IP address 192.168.x.21 
has been created. 

The setup wizard continues to create the node management interface. Press Enter to continue. 

Cluster setup is now complete. 

To test the cluster, enter the cluster show command. 

login: admin 
Password: <password you defined> 
 
cluster1::> cluster show 
Node     Health  Eligibility 
--------------------- ------- ------------ 
cluster1-01    true    true 
1 entry is displayed. 

Add the unassigned disks to the node: 

storage disk assign –all true –node cluster1-01 

The simulator should not be shut down at this time. The console window can be minimized 
while you set up the second node in the cluster (if required). 

Configuring serial number and system ID for the second node 
You must perform an additional step on the second node because the storage system ID is 
hardcoded in the provided Simulate ONTAP image. Each Simulate ONTAP node in a cluster 
must have a unique System ID. 

Steps 

1. Register the second virtual machine from the .ova file described in Downloading Simulate 
ONTAP software on page 6. 

Change the System ID and serial number of the second node before joining the cluster. 

Press the space bar when the Hit [Enter] to boot immediately, or any other 
key for command prompt. Booting in 10 seconds... message is displayed. 
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You should see a VLOADER> prompt. 

Change the Serial Number and System ID for this node: 

VLOADER> setenv SYS_SERIAL_NUM 4034389-06-2 

VLOADER> setenv bootarg.nvram.sysid 4034389062 

Verify that the information was saved correctly: 

VLOADER> printenv SYS_SERIAL_NUM 

VLOADER> printenv bootarg.nvram.sysid 

Enter the boot command to boot the node:  

VLOADER> boot 

The simulator begins the boot process with the new system ID and serial number. 

Booting the second node 
You must reboot the node to configure it and to connect it to the cluster. 

Steps 

1. When the Press Ctrl-C for Boot Menu message is displayed, press Ctrl-C to display 
the Boot Menu. 

NetApp Data ONTAP 8.x.x Cluster-Mode 
Copyright (C) 1992-2015 NetApp. 
All rights reserved. 
******************************* 
*                             * 
* Press Ctrl-C for Boot Menu. * 
*                             * 
******************************* 
^C 
Boot Menu will be available. 

When the Boot Menu is displayed, enter 4 (to initialize all disks) and press Enter. 

Please choose one of the following: 
 
(1) Normal Boot. 
(2) Boot without /etc/rc. 
(3) Change password. 
(4) Clean configuration and initialize all disks. 
(5) Maintenance mode boot. 
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(6) Update flash from backup config. 
(7) Install new software first. 
(8) Reboot node. 
Selection (1-8)? 4 

Enter y and press Enter at the prompt Zero disk, reset config and install a new 
file system? 

Zero disks, reset config and install a new file system?: y 

At the confirmation prompt, enter y and press Enter. 

This will erase all the data on the disks, are you sure?: y 
Rebooting to finish wipeconfig request. 

Result 

The virtual machine restarts automatically and begins the reset process. You must wait until 
the reset process is complete. If you interrupt the process, you might corrupt the simulator 
files (simulator disks) and you might have to register them again. 

Joining the node to the cluster 
After creating a cluster, for each remaining node, you use the Cluster Setup wizard to join the 
node to the cluster and create the node's management interface. 

Steps 

1. Join the cluster you created earlier by entering the join command and pressing Enter. 

The cluster setup wizard is displayed. 

Welcome to the cluster setup wizard. 
 
You can enter the following commands at any time: 
"help" or "?" - if you want to have a question clarified, 
"back" - if you want to change previously answered questions, and 
"exit" or "quit" - if you want to quit the cluster setup wizard. 
Any changes you made before quitting will be saved. 
 
You can return to cluster setup at any time by typing "cluster setup". 
To accept a default or omit a question, do not enter a value. 
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Do you want to create a new cluster or join an existing cluster? 
{join}: 
join 

When asked to use the system default values, press Enter to accept the default answer, which 
is yes. 

System Defaults: 
Private cluster network ports [e0a]. 
Cluster port MTU values will be set to 1500. 
Cluster interface IP addresses will be automatically generated. 
 
Do you want to use these defaults? {yes, no} [yes]: <Enter> 

After the cluster interfaces are created, enter the name of the cluster you want to join. Press 
Enter to join "cluster1". 

It can take several minutes to create cluster interfaces... 
Step 1 of 3: Join an Existing Cluster 
You can type "back", "exit", or "help" at any question. 
 
Enter the name of the cluster you would like to join [cluster1]: 
<Enter> 

Wait while node 2 joins the cluster. 

Enter the following values to define the node interface using the information you gathered 
when setting up the first node: 

You must ensure that you enter a unique IP for node management interface (22, as shown 
below). 

• Enter the node management interface port [e0c]: e0c 

• Enter the node management interface IP address: 192.168.x.22 (x=your subnet) 

• Enter the node management interface netmask: 255.255.255.0 

• Enter the node management default gateway: (leave blank) 

Step 3 of 3: Set Up the Node 
You can type "back", "exit", or "help" at any question. 
 
Enter the node management interface port [e0c]: <Enter> 
Enter the node management interface IP address: 192.168.x.22 
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Enter the node management interface netmask [255.255.255.0]: <Enter> 
Enter the node management interface default gateway: <Enter> 

Note: You should configure IP addresses for the e0c and e0d ports based on your 
network settings. 

The setup wizard will continue to create the node management interface. Press Enter to 
continue. 

The cluster setup is now complete. 

To test the cluster, enter the cluster show command. 

There will now be two nodes in the cluster. 

cluster1::> cluster show 
Node           Health Eligibility 
-------------- ------ ------------ 
cluster1-01    true   true 
cluster1-02    true   true 
2 entries were displayed. 

To assign ownership of unowned disks to a specific node, enter the following command: 

> storage disk assign –all true –node cluster1-02 

You have completed a two-node cluster setup. The console window can be minimized, but the 
simulator should not be shut down at this time.  

Disabling root snapshots 
Root snapshots consume a large amount of space on the root volume with snapshots of log 
files.  If you are concerned about running out of space on your root volume, you should 
disable root snapshots before creating aggregates and volumes.   

Steps 
1. From the command line, enter run local. 

This takes you into the nodeshell. 

2. Delete all existing snapshots on the root volume and suppress confirmation request. 

snap delete –a –f vol0 
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3. Disable the automatic snapshot schedule. 

snap sched vol0 0 0 0  

4. Enable snapshot autodelete. 

snap autodelete vol0 on 

5. Set the snapshot autodelete threshold to 35% for the volume free space. 
This guarantees the volume has a minimum of free space equal to 35% of its overall size. 

snap autodelete vol0 target_free_space 35 

6. Confirm the autodelete has been configured correctly. 

snap autodelete vol0 

Expanding the root volume size 
If your root volume is too small, you can expand it.  Your root aggregate must have enough 
free space to accommodate an increase in the size of your root volume. 

Steps 

1. If necessary, add more disks to your root aggregate to increase its size and accommodate the 
additional space needed in your root volume. 

storage aggregate add-disks -aggregate aggr0 -diskcount <n>  

2. Set the root volume to a new size. 

volume size -vserver <vserver_name> -volume vol0 -new-size <new_size> 

3. View the root volume size details to verify the new size. 

volume show -volume vol0 
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How to send comments about documentation 
and receive update notifications  

You can help us to improve the quality of our documentation by sending us your feedback. 
You can receive automatic notification when production-level (GA/FCS) documentation is 
initially released or important changes are made to existing production-level documents. 

If you have suggestions for improving this document, send us your comments by email to 
doccomments@netapp.com. To help us direct your comments to the correct division, include 
in the subject line the product name, version, and operating system. 

If you want to be notified automatically when production-level documentation is released or 
important changes are made to existing production-level documents, follow Twitter account 
@NetAppDoc. 

You can also contact us in the following ways: 

• NetApp, Inc., 495 East Java Drive, Sunnyvale, CA 94089 U.S 

• Telephone: +1 (408) 822-6000 

• Fax: +1 (408) 822-4501 

• Support telephone: +1 (888) 463-8277 
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