AFF, NVMe, EF-Series, and SolidFire Discussions

Highlighted

AFF200 cifs Quota don't initialize

Hi there;

 

I am facing a problem with the quotas of my cifs svm, i have 4 volumes there with qtree quotas enabled, 3 volumes are fine but 1 makes problems:

 

quota.jpg

when i try to enable the quota i receive this Error: Job failed: The specified qtree does not exist

 

cluster1::> volume quota on -vserver svm_cifs -volume vol2_home -foreground
[Job 6282] Running: Sending quota rules. 100 Quota rules sent.

Error: command failed: [Job 6282] Job failed: The specified qtree does not exist.

cluster1::>

Does anyone know how to solve it?

Thanks a lot, Thomas

 

5 REPLIES

Re: AFF200 cifs Quota don't initialize

Hi

 

it's documented under this BUG # https://mysupport.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=1126163

i suggest running

 

quota policy rule show -volume <vol name> -fields Qtree

 

 

and

 

qtree show -volume <vol name> -fields Qtree

 

 

putting them one by one in excel and see what the extra record is.

 

There maybe other ways. or a more detailed message in EMS. but i think that's an easy approach.

 

Gidi

 

Re: AFF200 cifs Quota don't initialize

Hi marcus;

 

Thanks, perfect answer, its running again.

Greetings, Thomas

Re: AFF200 cifs Quota don't initialize

Hi

 

I'm having the exact same problem. Running the two commands, I get the same result apart from 1 extra entry when running the second command. The extra qtree listed is the root, shown as "".

 

I use the standard default rule on all qtree. 

 

Probably not revelant, but i am running FAS8200 9.3P4

 

Where do i go from here?

 

 

Thanks

M

Re: AFF200 cifs Quota don't initialize

Check the output again and make sure it is extactly same.  In my case, i have renamed qtree which i created intially because of the typo but the quota policy rule  was showing the old qtree name. I have deleted the old rule and i am able to activate.

 

Second command will display the extra qtree listed as root. I think it is normal

 

Re: AFF200 cifs Quota don't initialize

Sorry, I forgot to update this after fixing the problem a while ago. 

 

For the benefit of others experiencing the same issue, I had two quota policy rules that were referencing the qtree's by the path rather that the qtree name itself. I removed the quota policy RULE and recreated them by referencing the qtree name. I was able to activate the quota on the volume after this.

 

Hope this helps.

 

 

Forums