AFF, NVMe, EF-Series, and SolidFire Discussions

Check vCenter compatibility with Element Plug-in for vCenter Server

Just a heads-up to those who tend to install latest & greatest: the Element Plugin-in for vVCenter server which is commonly used by SolidFire and NetApp HCI customers, currently has its compatibility notes in Release Notes (v4.2.3).

Latest VCSA supported by this version:

VMware vSphere 6.7
◦ VMware vCenter Server 6.7 Update 1

 

Later this info will move to the NetApp IMT.

 

Newer versions may work, but also not. For example plugin v4.2.3 doesn't seem to work on the very latest VCSA (6.7.0.30000 Build number 13010631). It did work for me with two post-6.7U1 updates, but it doesn't work on this very latest one, so check this carefully before updating VCSA or the plugin...

 

4 REPLIES 4

Re: Check vCenter compatibility with Element Plug-in for vCenter Server

Thanks for the information!

Re: Check vCenter compatibility with Element Plug-in for vCenter Server

The Element plugin will deploy and works with 6.7u2 flash based web client. However, vmware made a change to the html5 web client that stops the plugin from being deployed. 

Re: Check vCenter compatibility with Element Plug-in for vCenter Server

Despite NetApp HCI v1.7 being released *after* vSphere 6.7 U3, there's nothing on this in v1.7 release notes. Element Plugin for Element Plug-in for vCenter Server was released before vCenter 6.7 U3, so the reasonable thing to do would have been to provide this information in NetApp HCI v1.7 release notes, IMO. As is, the docs still have no information about this.

 

Using my lab as a testbed, I upgraded my vSphere 6.7 to version 6.7.0.41000 and only then was I able to get the plugin 4.3* to work in HTML5. With the most recent VCSA v6.7.0.3* (as of now) only Flash version worked.

Re: Check vCenter compatibility with Element Plug-in for vCenter Server

I'll talk to TechPubs about getting it in the release notes. Currently it's documented in the NetApp Element Plug-in for vCenter Server 4.3 User Guide under VMware vSphere prerequisites.

 

The plug-in is not compatible with version 6.7 U2 of the HTML5 vSphere Web Client. It is
compatible with the version 6.7 U2 vSphere Web Client for Flash/FLEX.

Forums