AFF, NVMe, EF-Series, and SolidFire Discussions

Highlighted

Solidfire vCenter Plugin

I upgrade vCenter to 6.7 and the plug for Solidfire stopped working. I went to the mangement node to registered it but I'm getting the error below: Error connecting to vCenter server at  -- Exception caught trying to invoke method RetrieveServiceContent; nested exception is: javax.net.ssl.SSLHandshakeException: Remote host closed connection during handshake.

 

I tired to unregister the extenstion from https:vcenter/mob. It sees it in the list but fails on unregistering because it was not found. How do I go about fixing the error to register the plugin again?

 

thanks

5 REPLIES 5

Re: Solidfire vCenter Plugin

While I'm not 100% here, this is worth a shot. vSphere 6.7 disabled TLS 1.0 and 1.1, I would try re-enabling 1.1 and seeing if that resolves the issue. Have a look at this VMware document.

Re: Solidfire vCenter Plugin

As the VCP docs state, you should uninstall the plugin first, and install it anew after an upgrade.

 

Now some surviving bits and pieces that try to use vCenter 6.5 are still in there, but VCSA 6.5 is gone. 

You need to use the troubleshooting procedure from the VCP docs to manually clear orphaned/stale VCP files (it's a find + delete combo for "*solidfire*" files and directories, IIRC - check the UG). Log out from VCSA Web UI, execute that step, then go back to mNode and re-install. Maybe a VCSA reboot would be required. 

 

Since the plugin is not functioning, you might as well use this opportunity to install the latest mNode before the last step (VCP re-install) and that would help you install a newer VCP (which contains minor improvements and bug fixes). 

 

If this sounds too complicated, it may be best to contact Support for a review of the exact steps.

Re: Solidfire vCenter Plugin

I have done everything in the document to remove the plug in and rebooted the appliance many times. It still will not work. I need to go to the next code level of SolidFire to make this work since it is VSCA 6.7.

Re: Solidfire vCenter Plugin

OK.

 

You didn't mention what the version of VCP was, maybe it was an older version that couldn't work with VCSA 6.7. I've been using VCP 4.2 with VCSA 6.7 for a while, but not earlier VCP releases.

Re: Solidfire vCenter Plugin

I came across a similar (or maybe the same) issue and noted (https://community.netapp.com/t5/AFF-NVMe-EF-Series-and-SolidFire-Discussions/Check-vCenter-compatibility-with-Element-Plug-in-for-vCenter-Server/m-p/1...) the VCSA and VCP versions involved.

 

As I didn't have a backup of the earlier VCSA, I couldn't restore to it - I had to install a fresh VCSA and then upgrade it to a release that did work for me.

Forums