Active IQ Unified Manager Articles and Resources

WFA 2.1+ CM Snapshot support with Unified Manager 6.0+


Hi All,



If you've come here, you may have noticed that WFA 2.1 appears to lack support of Snapshots in cDOT, and the Snapshot database view within OnCommand Unified Manager 6.0 and above is empty.

This pack intends to fill that gap by providing a separate collector that uses the same list of clusters as the Unified Manager database collector, but goes directly to the cluster to gather Snapshot information. In future it may gather other information not available within a Unified Manager view.


Updates included in v4:

Includes Cluster and Vserver Peer information collections, dictionary, commands and filters.

You can also connect directly to the cluster, no Unified Manager required!

To connect directly to a cluster, specify a comma separated list of clusters to connect to, using their 'primary_address' as registered in OnCommand Unified Manager to ensure filters match the cluster.primary_address field.


Here is an overview of the components in the attached.


Schema: cm_storage_augment


Snapshot          Represents a Volume Snapshot

Vserver_Peer    Represents a Vserver Peer relationship

Cluster_Peer     Represents a Cluster Peer relationship



Create Volume Snapshot             Creates a Volume Snapshot

Remove Volume Snapshot           Removes a Volume Snapshot

Create Storage Virtual Machine Peer with reservations

                                                 Creates a Vserver peer including cm_storage_augment reservations

Create cluster peer with reservations

                                                 Creates a Cluster peer including cm_storage_augment reservations

Note: These commands do not depend on the cm_storage_augment schema and may be used independently if needed.



CM Storage Augment_6.0           Collects Snapshot information from OnCommand Unified Manager 6.0 and above (via direct cluster connection)



Snapshots by Volume                 Returns a list of Snapshots for the specified volume

Snapshots by Volume Regex       Returns a list of Snapshots matching a regex for the volume (ie. ^hourly)

Clusters with Available Peer Relationships (includes self)

                                                  Returns a list of clusters that have an existing cluster peer, suitable for use in determining where Vserver Peering is possible.

Filter Aggregates available through Cluster Peers

                                                  Returns a list of aggregates available on clusters that are peered

Filter Aggregates available through Vserver Peers

                                                 Returns a list of aggregates available on clusters and vservers that are peered matching a regex. Useful in determining if a similar named Vserver exists on the destination.


Workflow-Example: Create Snapshot

               Creates a Snapshot of the selected Volume.


Workflow-Example: Remove Snapshot

               Removes a Snapshot of the selected Volume.


Installation Steps:

        Import the DAR file (attached)

        On the Credentials tab, ensure each cluster that is configured in OnCommand Unified Manager is listed and has correct credentials.

        Select the Data Sources tab. Create a new Data Source of type "CM Storage Augment - 6.0"

        Enter details of the OnCommand Unified Manager server and user account

          (User credentials must be normal users and NOT database users)

        Ensure you select "cm_storage_augment" and "Reset Schema" to create database tables.


Note: Reservations have now been included! Snapshot timestamp is set to 'now' so may adjust once a collection cycle has completed.

          Release v3 include Congruence Tests and Reservation Strings to complete the reservations information. It is also marked as PS Certified to indicate reservations are present.

           If using v2, ensure you update or reservations will not behave as expected.

           If upgrading to v4, ensure you select "Reset Schema" to allow the new Vserver and Cluster Peer tables to be created before the next collection.



Please report any feedback to, thanks!




- Michael Goddard.

Please Note:

All content posted on the NetApp Community is publicly searchable and viewable. Participation in the NetApp Community is voluntary.

In accordance with our Code of Conduct and Community Terms of Use, DO NOT post or attach the following:

  • Software files (compressed or uncompressed)
  • Files that require an End User License Agreement (EULA)
  • Confidential information
  • Personal data you do not want publicly available
  • Another’s personally identifiable information (PII)
  • Copyrighted materials without the permission of the copyright owner

Continued non-compliance may result in NetApp Community account restrictions or termination.


Too bad I saw this after posting:

What about 2.0 vs OCUM 5.2 - will the above work?


There's nothing WFA 2.1 specific about it (except the export was from 2.1), but UM 5.2 uses a different API/iterator type for searching clusters so it wouldn't work as is.

You'd need to swap cluster-iter for host-list-info-iter-start/next/end, the parameters are a little different too. A better starting point for DFM 5.2 would be the CM Performance collector, look for the section around those iterator names.


This is FANTASTIC.  Definitely helping bridge a gap we have with caching snapshots for clustered data ONTAP. Great work!!!

- Kevin.



I tried to import your dar file and receive the error:

     Incompatible DAR - no upgrade path were found.

     DAR version 'null', installed version

Any ideas?




Hi Christian,

     I tried the same on my WFA 2.1 setup and was able to import it successfully without any errors.

Can you post a setup by step of the same ?

BTW what is the version of your WFA ?


Hi Adaikkappan,

Our WFA version is Build 2178337


Is it a DAR or a ZIP? Communities will zip it again and IE Mime type detection sometimes gets it wrong. Rename the file you downloaded to .zip and open it and see if there is a .dar inside. This is what you want to import. The "null" version in the error usually means it's a zip not a dar.



Thanks Michael. That solved my issue.




I had no issue importing the dar file but am having one getting the cluster setup as the data source.  Credentials have been set and tested successfully, an OCUM data source was previously setup and tested successfully, but the cluster data source fails with the following error in the wfa.log:


failed: com.netapp.wfa.cache.execution.CacheException: Error running data acquisition script: At C:\Program Files\NetApp\WFA\jboss\standalone\tmp\wfa\cm_storage_augment4582972690885238274.ps1:172 char:43


WFA version 2.2 GA

Windows 2008 R2 EE (new vm)

PowerShell 3.0

.NET 4.5

OCUM 6.1

cDOT 8.2.1p1

IE8 and FF32


Has anyone seen this or have an idea on how to fix it?







Regarding the exception :Error running data acquisition script: At C:\Program Files\NetApp\WFA\jboss\standalone\tmp\wfa\cm_storage_augment4582972690885238274.ps1:172 char:43
PowerShell is not able to interpret the $cluster_addrs variable properly in the error message due to ':' after $cluster_addrs. 
This error message is interpreted properly in PowerShell v2, but not on v3.  As a workaround,  change the error message in the data acquisition script from
$error = "Error connecting to cluster $cluster_addrs: $($_.Exception)"  to 
$error = "Error connecting to cluster $($cluster_addrs) : $($_.Exception)"




I'm trying to add this datasource on a WFA build 2584685 on a windows 2008 R2 Standard witch SP1


Is it compatible?


Because i encoutered the following error during acquire:


Command '$Uri = @($input)[0] ; C:\Program` Files\NetApp\WFA\jboss\..\PoSH\profile.ps1;Invoke-WfaCommand -Script './cm_storage_augment8974378836624966228.ps1 '' timed out








I am trying to import this DAR into WFA3.1 and get the following error:


The version of .dar file used to import is The supported WFA version from which a .dar file can be imported is 2.2 (V2. or later.
To use the data from this .dar file, import the .dar file to WFA 2.2 (V2. and then export a .dar file in that WFA version. You can then use the new .dar file for import in this WFA version.


I have no WFA2.2 available. Can someone provide a DAR which can be improted in WFA3.1?




@masson, since you may have a complex environment (lots of snapshot for example), you may want to increase the timeout in the Data Source, i stumbled on this issue yesterday.






I've already modified the timeout value, but I still get the error message.

Any idea from your point of view?


thx & regards jens


I too am getting the time out error message when trying to connect the data source. This is WFA 3.1 & OCUM 6.3 with a 2 node test cluster and a high time out value. Any suggestions would be appreciate



Command '$_Netapp_Uri = @($input)[0] ; C:\Program` Files\NetApp\WFA\jboss\..\PoSH\profile.ps1;Invoke-WfaCommand -Script './cm_storage_augment3005120681171389997.ps1 '' timed out










I cannot import this dar file in WFA version 3.1 release.

Would it be possible for someone to share the dar for WFA 3.1






There is a datasource called "Clustered Data ONTAP - Snapshot" available.

All Community Forums