Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Active IQ Unified Manager Discussions

HTTP XML Authentication failed from x.x.x.x (Balance VA)

DOMINION801

Hello All,

In the OnCommand Balance GUI, I'm under Discovery > Storage.  I am needing to add our NetApp filers to be monitored.  So under the "Add new storage system" in the drop down, I select NetApp.  I input the IP Address of our filer, give it a name that I can easily know what I'm looking at later.  In the Login field, I want to use the root account on the filer and this is where I start encountering issues.  In the Login field, I simply put "root", in the Password field I put the root's password.  I check "Use SSL for communication" and click "Save".  In the Balance GUI I get this message:  "Could not complete login to this storage system because of an incorrect username or password".  I have an SSH session established with the filer I am wishing to add to Balance, and when I hit "Save" I see this output on the SSH session:  [filer:  HTTPPool01:warning]:  HTTP XML Authentication failed from x.x.x.x (IP of the Balance VA). 

Any ideas?

1 ACCEPTED SOLUTION

resqme914

BTW, I made a typo in the previous response, httpd.admin.ssl.enable, not http.admin.ssl.enable.  I tested this and it does prevent the Balance server from accessing the filer, but the error message is different.  Do you have weird characters in your password?  This does cause the same error (as tested).  Try using plain alphanumeric characters on the password.

The Balance Proxy server has nothing to do with accessing your NetApp storage arrays, so that's not where your problem is.  Other than the above, I'm out of ideas.  Good luck.

View solution in original post

9 REPLIES 9

resqme914

Make sure your options httpd.admin.enable is on and check options httpd.admin.access (should be either legacy or a list of hosts you wish to allow access).  Hope that solves your problem.

DOMINION801

Hi resqme914,

Here is how I currently have these options configured:

  • httpd.access - legacy
  • httpd.admin.access - legacy
  • httpd.admin.enable - on

I did however reconfigure both the httpd.access and httpd.admin.access to point directly at the Balance VA and received the same "Authentication Failed" message in the SSH session. 

Thank you again and any other ideas would be very much appreciated as I am at a loss!

resqme914

And option http.admin.ssl.enable is on, right?  By the way, what version of Ontap are you running?

DOMINION801

Correct, http.admin.ssl.enable is on as well. 

One of our filers is running 8.0.4 7-Mode and the others are running 8.1.2P1 7-Mode.

Also, all of our filers have the same options http set as we have been discussing so far.

I have also attempted to create a local user on the filer with administrative rights and tried to use this user in Balace and recieve the same results.  In the Balance installation guide, it informs us to ensure that ports 9443 and 443 are allowed for inbound and outbound traffic from the Balance Proxy server.  When I tested these ports with telnet, I get that the connect failed.  On the Balance proxy server, I have tried with Windows firewall disabled, and with creating rules to allow these ports for inbound and outbound traffic.  Needless to say, this didn't get me anywhere.  The guide also notes that UAC must be disabled on the Balance Proxy server, which it is in fact disabled.  Just thought I would add that in there as well.

Thank you for the quick responces by the way!

resqme914

BTW, I made a typo in the previous response, httpd.admin.ssl.enable, not http.admin.ssl.enable.  I tested this and it does prevent the Balance server from accessing the filer, but the error message is different.  Do you have weird characters in your password?  This does cause the same error (as tested).  Try using plain alphanumeric characters on the password.

The Balance Proxy server has nothing to do with accessing your NetApp storage arrays, so that's not where your problem is.  Other than the above, I'm out of ideas.  Good luck.

View solution in original post

DOMINION801

Holy cow pile!

The password suggestion you had was exactly the problem.  That password did have special characters in it.  So I created a new local user on the filer with administrative priveledges with the password only being alpha numberic.  Worked in the first 40 seconds it took to set it up.  Thank you so much!

donna_rice

Which password are you referring to?  The Balance password.  I am getting this error too but it is from OC Core.  Is it that password because my filer root password doesn't have special characters in it. 

DOMINION801

My issue was because the root password DID have special characters.  This was causing the error that my password was incorrect when, in fact, it was correct.  I created another local account on the filer with admin rights and gave it a password that was strictly alpha numeric.  This worked the first try.

But I'm not sure why yours isn't working even if the root password doesn't have any special characters. 

Wish I knew more, sorry...

donna_rice

Thanks for the reply Travis.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public