Active IQ Unified Manager Discussions

Problem with UserName in "Set CIFS Share ACL" command

TIMHOIBERG
2,962 Views

I'm trying to add an AD group to a CIFS share as part of the workflow using the Set CIFS Share ACL certified command and I get the following error:

[Error: illegal escape sequence: A]

[Near : {... AUTHORITY\Authenticated Users ....}]

                                         ^

The group I'm trying to add is called "NT AUTHORITY\Authenticated Users" (double quotation marks are included in the input) so I'm assuming that WFA has an issue with the \ in the input. Are there any characters I need to surround it in so WFA just reads it as part of the text?

1 ACCEPTED SOLUTION

tanzim
2,962 Views

Hi Tim,

Can you provide group input value with double backslashes as : "NT AUTHORITY\\Authenticated Users".

Tried the same and it seems to be working as expected in the preview stage.

Regards,

Tanzim

View solution in original post

4 REPLIES 4

tanzim
2,963 Views

Hi Tim,

Can you provide group input value with double backslashes as : "NT AUTHORITY\\Authenticated Users".

Tried the same and it seems to be working as expected in the preview stage.

Regards,

Tanzim

TIMHOIBERG
2,962 Views

Hi Tanzim,

Thanks for the help, that's fixed the issue. I'm assuming that any input in a workflow needs to have the extra \ to make sure that WFA inteprets it correctly?

tanzim
2,962 Views

Hi Tim,

I'm not quite sure about what you mean by "any input in a workflow".

Again, with reference to the issue discussed in this thread, a backslash needs to be preceded by another backslash to prevent it from being interpreted as an escape sequence.

Regards,

Tanzim

TIMHOIBERG
2,962 Views

Hi tanzim,

Yes that's what I meant. Thanks for your help

Public