The community will be undergoing maintenance soon, requiring Read-Only mode. Click to learn more.

Active IQ Unified Manager Discussions

WFA 4.2 Execution status doesn't refresh

skellner

After updating WFA to Version 4.2 the execution status in the Browser window with Chrome doesn't refresh. Nor a manual refresh or jumping between different views in WFA fixes this. When I start a workflow I can't follow the execution in the Status window. I can only see the execution in the foreground when I start a workflow with the gui. However, if I close the window I can't see the workflow in the status window. If I start it in the background via Rest for example the workflow doesn't show up in the execution status.

 

Anybody an idea what might be the issue? Thanks in advance

1 ACCEPTED SOLUTION

skellner

In the meantime the issue is solved. After opening up a support case the engineer found two things to modify.

 

First:

What I did in lab was to open the registry to
 
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0\NA_WFA_SRV\Parameters\Java
 
And changed the “option” key with new values for XMS and XMX like in :
 
-Xms1536m
-Xmx3072m
 
Once this was done I restarted the application and the execution status window was updated in a instant.

 

This didn't help at once.

 

Second:

We changed a my.ini file of MySQL at c:\programdata\Mysql\data\my.ini
In that file we have
 
Innodb_buffer_pool_size = 8M
 
We changed the buffer poolsize to 2048M and restarted the services, right after WFA was started we could see that the windows are updated faster than they were before.

 

That did the trick

 

View solution in original post

5 REPLIES 5

wronald

Hi @skellner,

 

I suppose you already restarted the service on the server?

Could you share the logs for review? Do you have a case open?

 

Cheers,

Ron.

skellner

Hi Ron,

yes, I restarted several times, used different browsers from different clients and the issue persists. Currently trying to download autosupport data and it doesn't work. I get the clock symbol the whole time. Once I got it I will post it here. I will also open up a case. Unfortunately we need wfa in production. So I will have to downgrade. Hopefully I can collect the logs in advance.

skellner

The production system has been rolled back. I did a fresh install of 4.2 on a new system. Same problem. I will open up a support case. Attaching the logs doesn't work. Don't know why

wronald

Hi @skellner,

 

Ok, sorry I couldn't help any further. I hope your problem will get solved at some point.

 

Cheers,

Ron.

skellner

In the meantime the issue is solved. After opening up a support case the engineer found two things to modify.

 

First:

What I did in lab was to open the registry to
 
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0\NA_WFA_SRV\Parameters\Java
 
And changed the “option” key with new values for XMS and XMX like in :
 
-Xms1536m
-Xmx3072m
 
Once this was done I restarted the application and the execution status window was updated in a instant.

 

This didn't help at once.

 

Second:

We changed a my.ini file of MySQL at c:\programdata\Mysql\data\my.ini
In that file we have
 
Innodb_buffer_pool_size = 8M
 
We changed the buffer poolsize to 2048M and restarted the services, right after WFA was started we could see that the windows are updated faster than they were before.

 

That did the trick

 

View solution in original post

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public