Ask The Experts

Highlighted

Move ONTAP Select appliance to a different ESXi host

We have a Select appliance running on a single host in a 8 node ESXi cluster.  I need to remove two of the hosts from this cluster, permanently.  One of which is the one that the select appliance runs on.  I need to move it to another host in the cluster, no changes to any IP's whatsoever.

 

On the deploy appliance, under the 'Hypervisor Hosts' section I've been able to add the esxi host I want to move to but it just shows a yellow triangle with an exclamation.  Is this is a licensing issue?  I see I have 1 license and it's applied to the existing host.  How do I move it?

11 REPLIES 11
Highlighted

Re: Move ONTAP Select appliance to a different ESXi host

You would move the ONTAP Select VMs from one host to another using vMotion from vSphere.

https://www.netapp.com/us/media/tr-4517.pdf Starting at the bottom of page 22

Highlighted

Re: Move ONTAP Select appliance to a different ESXi host


@RyanUrice wrote:

You would move the ONTAP Select VMs from one host to another using vMotion from vSphere.

https://www.netapp.com/us/media/tr-4517.pdf Starting at the bottom of page 22


Thanks.  I've moved them (the Select Deploy and Selct VM) to the new host but  the deploy appliance will never acknowledge the new ESX host it lives on and the Select won't come back online.  I hit refresh under Clusters (as the guide explains) and the host still shows only the old one.  Under Hypervisor Hosts hitting refresh doesn't discover the new one and while I can manually add it I just end up with the triangle with exclamation mentioned in the original post.

Highlighted

Re: Move ONTAP Select appliance to a different ESXi host

What version of Deploy and ONTAP Select are you running? Also keep in mind, moving Deploy to another host is a different procedure. You cannot just vMotion the Deploy utility, you have to take a configuration backup of the existing Deploy, spin up a new Deploy on the new host and then use the configuration backup to restore the config. See the steps outlined here: https://kb.netapp.com/app/answers/answer_view/a_id/1086612/~/how-to-migrate-ontap-select-deploy-tool-to-a-new-vm-machine-
Highlighted

Re: Move ONTAP Select appliance to a different ESXi host


@RyanUrice wrote:
What version of Deploy and ONTAP Select are you running? Also keep in mind, moving Deploy to another host is a different procedure. You cannot just vMotion the Deploy utility, you have to take a configuration backup of the existing Deploy, spin up a new Deploy on the new host and then use the configuration backup to restore the config. See the steps outlined here: https://kb.netapp.com/app/answers/answer_view/a_id/1086612/~/how-to-migrate-ontap-select-deploy-tool-to-a-new-vm-machine-

The guide you link to seems to indicate it's only needed when the management IP is changing, which it isn't.  It's just being moved to a different host within the cluster.  The Select is 9.1P2 and the deploy appliance is 2.5

Highlighted

Re: Move ONTAP Select appliance to a different ESXi host

Can you send a screenshot of what you are seeing under the Hypervisor Hosts section in the Deploy GUI?

 

Also, Deploy 2.5 and OTS 9.1P2 are pretty out of date, is there a reason for not upgrading them?

Highlighted

Re: Move ONTAP Select appliance to a different ESXi host


@RyanUrice wrote:

Can you send a screenshot of what you are seeing under the Hypervisor Hosts section in the Deploy GUI?

 

Also, Deploy 2.5 and OTS 9.1P2 are pretty out of date, is there a reason for not upgrading them?


Screenshot sent.  The Select appliance matches the physical version it's getting it's replication from.  The physical is on the radar for upgrade soon.  We use the Select appliance to merely replicate some volumes to our DR site.

Highlighted

Re: Move ONTAP Select appliance to a different ESXi host

Hi,

 

Have you registered the ONTAP Select Deploy instance with the target Hypervisior host?

In the UI when you select "Hypervisor host\ESX Hosts" Can you view the target ESX host in the list of hosts? If not click "add". I'd recommend using the "add using a vcenter" option and providing the vcenter FQDN or IP to ensure it registers all ESX hosts in the vSphere cluster. Given the host is registered there isn't any other requirement to vMotion the vApp to another host

 

/Matt

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Highlighted

Re: Move ONTAP Select appliance to a different ESXi host


@mbeattie wrote:

Hi,

 

Have you registered the ONTAP Select Deploy instance with the target Hypervisior host?

In the UI when you select "Hypervisor host\ESX Hosts" Can you view the target ESX host in the list of hosts? If not click "add". I'd recommend using the "add using a vcenter" option and providing the vcenter FQDN or IP to ensure it registers all ESX hosts in the vSphere cluster. Given the host is registered there isn't any other requirement to vMotion the vApp to another host

 

/Matt

 


I have added the host, both through vCenter and standalone and it doesn't make a difference.  That's the screenshot I sent you.  The host is there but I'm not sure how to make it the "assigned" host and it just remains with the yellow triangle instead of a green checkbox.  I can't hot vmotion it as it says I'm missing the 2 serial ports.  If I take it offline with the deploy appliance (shuts it down) I can manually move it but trying to bring it back online fails and if I power it up manually it the deploy appliance still says it can't bring it online.

Highlighted

Re: Move ONTAP Select appliance to a different ESXi host

@aregisteruser  if you are still looking for help then please update the thread, we will have our experts look into it.

 

@mbeattie  @RyanUrice  can you look into the latest query and see if you can help?

 

Thanks

Rajesh

Highlighted

Re: Move ONTAP Select appliance to a different ESXi host


@RajeshPanda wrote:

@aregisteruser  if you are still looking for help then please update the thread, we will have our experts look into it.

 

Thanks

Rajesh


Yes it's still a problem.  I posted last so was just treading water.

Highlighted

Re: Move ONTAP Select appliance to a different ESXi host

Hi,

 

Based on the problem statement "I can't hot vmotion it as it says I'm missing the 2 serial ports. If I take it offline with the deploy appliance (shuts it down) I can manually move it but trying to bring it back online fails and if I power it up manually the deploy appliance still says it can't bring it online" that sounds like there is an issue with VM configuration. I wasn't able to replicate the issue in my lab so i can't be sure what would be causing the issue. I'd suggest the best path forward would be log a support case.

 

/Matt

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Check out the KB!
Knowledge Base
All Community Forums