BlueXP Services

Azure China

Scott_E
732 Views

Hello,

 

I am trying to use BlueXP to provision a connector and CVO in Azure China (China North 3).  I can't get BlueXP to connect to our Azure China subscription.  It just keeps wanting to connect me to Azure Commercial.  I have read through the BlueXP docs, and apart from small mentions here and there about BlueXP supporting or not supporting this and that in China, I can't find any instructions specific to Azure China.

 

I also provisioned a connector from the Azure China marketplace, but when I point a browser at it, it brings up a page with a spinning circle that never results in anything.  It's like it's trying to contact something before continuing but can't.  I have verified that the connector VM can reach cloudmanger.bluexp.netapp.com (which I saw mentioned in the documentation), so I'm not sure why it's not working.

 

I'm beginning to think the only way to provision/manage CVOs in Azure China is via the connector, but it just doesn't seem to want to work.  I have a case open with support, but it was transferred to APAC cloud support, which works precisely opposite my waking hours.

 

Does anyone have any input?

3 REPLIES 3

AlexDawson
505 Views

CVO is not listed as supported in cn-north-3, only cn-north-1. https://bluexp.netapp.com/cloud-volumes-global-regions

Anna_A
399 Views

Hi Scott, likewise I got the same issue when provisioning CVO in Azure ChinaNorth3. I also couldn't get BlueXP to connect Azure China Marketplace subscription. It looks like Marketplace subscription is not supported in Azure China. And totally agree with you that there is no specific instructions on how to get CVO (& connector) deployed in Azure China!

 

Hi Alex, just checked the link provided, ChinaNorth3 (Heibei) is in the list for Azure China. So I supposed CVO should be supported there! 

Anna_A_1-1712722476819.png

 

 

Scott_E
309 Views

Hello Anna_A,

 

I gave up on the support case I had open as they could not find any documentation or assistance with deploying a connector/BlueXP/CVO in China Azure.  So, here's what I did:

1. Picked the Connector from the Marketplace

2. Changed the VM to a plain ubuntu VM instead of the connector/bluexp gen1 default.

3. Deployed the VM.  It won't have any connector software installed, it will just be ubuntu.

4. Downloaded the "Dark Site" BlueXP installer from the netapp support site.

5. Uploaded and installed the "Dark Site" installer on the newly provisioned connector VM.

6. This worked.  Gave me a BlueXP interface from the local VM and it recognized China Azure subscriptions/accounts/resources.

 

Now, if they would just support PAYGO instead of BYOL only.

Public