Cloud Discussions

Optimization Service is not running

chuckoutcalt

I'm trying out the SteelStore 730 AMI from the AWS marketplace.  Following the setup rules, but when I get to connecting the storage, its failing because the optimization service cannot be started...needs encryption key.

 

How do I resolve?

 

Thanks!

 

 

Using username "admin".
NetApp SteelStore
Authenticating with public key "imported-openssh-key"
Last login: Wed Feb 4 20:48:56 2015 from 98.210.4.211
amnesiac > sysconfig -a
% Unrecognized command "sysconfig".
Type "?" for help.
amnesiac > enable
amnesiac # configure terminal
amnesiac (config) # no service enable
% The optimization service is not running.
amnesiac (config) # aws setup data partition
Data partition setup complete.
amnesiac (config) # service restart
% The optimization service is not running.
% The optimization service cannot be started because no encryption key is present. Please generate a key and try again.
amnesiac (config) #

1 ACCEPTED SOLUTION

chriswong

Hi,

The problem does appear unusual, can you please try to issue the following commands to address it for now (from the SSH connection to the SteelStore):

enable

configure terminal

datastore encryption generate-key

 

This should generate the encryption key, and address the problem you're experiencing.


Regards,

Christopher

View solution in original post

1 REPLY 1

chriswong

Hi,

The problem does appear unusual, can you please try to issue the following commands to address it for now (from the SSH connection to the SteelStore):

enable

configure terminal

datastore encryption generate-key

 

This should generate the encryption key, and address the problem you're experiencing.


Regards,

Christopher

Public