Converged Infrastructure Discussions

Redeploy HCI with NDE

Hi community,

 

at the moment we are running a HCI, consisting of

2x Compute H410C-27020

4x H610S-1 Storage Nodes

2 Mellanox Switche SN-2010

for testing purposes.
It has been already configured.

Now we would like to completely freshly redeploy the HCI with the NDE.
But I cannot get to the NDE console because when I enter the IP of a S-Node in my browser it always redirects me to the cluster URL.

So my question:
How can I start the NDE for  a HCI that has been already deployed?

 

Thanks in advance

regards

 

5 REPLIES 5

Re: Redeploy HCI with NDE

You can't deploy a deployed cluster. You can scale (add new nodes, storage or compute) a deployed cluster - that URL is in NetApp HCI user docs, but you don't want that either.

 

You want to re-deploy, which means you need to reset first. Assuming you don't want to keep any data, and you don't want to rearrange your network cabling or settings, you could write down your IPs, netmasks, VLANs, gateways, DNS, NTP currently used, and then reset all of the nodes, which would return  you to the initial "factory" state.

 

I wouldn't recommend to try unless you've done it before or at least watched somebody do it beore, because you're likely to get stuck, but if you want to go ahead I would suggest to reset compute nodes by rebooting and immediately (it's shown for 1 second only) pick a Bootstrap OS menu to avoid booting to ESXi, and in it find the reset function. That would reset compute nodes. Then for Element OS (storage nodes), it's best to download Storage Node ISO and re-install over IPMI or via 4 slim USB keys (faster) plugged into storage nodes.

 

Once everything is reset you will see the NDE Web UI on the storage node(s). 

NDE docs (for current version; for other versions, navigate to your own):

http://docs.netapp.com/hci/topic/com.netapp.doc.hci-ude-17P1/GUID-8CED8C44-68D4-4AFD-9DB8-F611914AA637.html?cp=2_0_2_0

Re: Redeploy HCI with NDE

Hi,

ty very much for the answer!
At the moment it is not a "real" HCI so the storage nodes have never been installed - they are empty.
You mentioned 4 USB sticks - that is just for speed and not because there is a need of installing all 4 nodes ath the same time, cottect?

 

Thank you.

regards

 

Re: Redeploy HCI with NDE

You're welcome.

 

If there are no storage nodes, then there's no h/w to run NetApp Deployment Engine (NDE) (to deploy HCI), which means you'd use a standard ESXi procedure. One way is:

 

1) Get one of supported ESXi, e.g., 6.7U3 ISO from VMware and install it

 

2) Get required drivers (Mellanox and Intel NICs, for example) 

https://mysupport.netapp.com/products/hci/1.7P1/downloads.html

You may not have networking working when you install these in which case you'd have to copy them to ESXi OS from USB key or otherwise.

You may need to read a KB or ask NetApp SE or Support for help, if you get stuck.

http://docs.netapp.com/hci/topic/com.netapp.doc.hci-ude-17P1/GUID-5BDC16C7-7BA6-49CC-B744-FD3B25308741.html?resultof=%22%64%72%69%76%65%72%73%22%20%22...

 

Re: Redeploy HCI with NDE

Hi,

 

sorry - my bad.
I wanted to say: The C-Nodes have never been installed - so no ESX installed

The S-Nodes are up and running at the moment and building a solidfire cluster...

Re: Redeploy HCI with NDE

Normally we would access NDE at http://managementIP of any storage node *before* anything has been configured (either storage or compute or Management Node) and deploy HCI that way:

http://docs.netapp.com/hci/topic/com.netapp.doc.hci-ude-17P1/GUID-8CED8C44-68D4-4AFD-9DB8-F611914AA637.html?cp=2_0_2_0

But wIth NDE you could not install only storage nodes, for example, because a minimum NetApp HCI cluster currently consists of 4 storage + 2 compute nodes. If you have the h/w but decide to install a storage cluster first, that'd be a "SolidFire" storage cluster. It is easier to install a "full HCI" cluster than separately.

 

If storage-ony cluster has been built, you'd use HCI Compute Node ISO that corresponds to ISO used to buid HCI Storage Cluster. For example if you used storage ISO from HCI 1.7.0, you'd get compute ISO from HCI 1.7.0 as well. This comes with Element (SolidFire) v11.5.

Newest HCI version is 1.7.1 which contains Element (SolidFire) v11.7:

https://mysupport.netapp.com/products/p/hci.html

 

When you get Compute Node ISO for HCI that corresponds to storage OS you got, assuming you backed up compute nodes' data you want to keep, you'd install Compute Node ISO which would do 2 things: refresh compute nodes' BIOS and firmware (if necessary), and install Bootstrap OS on the first internal SATADOM.

After a reboot, these nodes would be ready to deploy with NDE, which runs on storage nodes and deploys ESXi on the second internal SATADOM on compute node.

 

As I mentioned in top paragraphs, storage-only clusters are easy to install but if you already have all the h/w it's best to install from scratch using NDE.

1) HCI v1.7.1 would require management node VM to be installed and configured. Then you could go to:

https://[management node IP]/mnode

NDE installs Management VM for you, but if your existing storage cluster doesn't have it, you may install and configure it on your own, which may be harder than to just use NDE to install HCI from scratch.

2) HCI v1.6 and earlier (maybe even 1.7.1, I haven't tried), try HTTP management IP of any storage node

http://[any-storage-node-management-ip]

This "easy scale" function will let you add compute nodes only if they're properly cabled, VLANs and MTUs correct, etc. so while it requires just a few clicks (https://youtu.be/krWod7ZaBqE) to complete, network preparation requires the understanding of HCI networking options and other details (http://docs.netapp.com/hci/topic/com.netapp.doc.hci-ude-17P1/GUID-67E1EEF6-900D-4C7A-B1CD-3598A000E7FD.html?cp=2_0_2_5).

 

Personally if I had a system with no data to keep, I'd wipe everything clean and install using Compute and Storage ISOs from HCI v1.7.1.

 

Using 4 USB sticks: yes, I meant it saves you time to have 4 sticks for 4 storage nodes (4.5GB per image = you can use USB keys 8GB or larger). Compute nodes ISOs are getting close to 20GB and for those a fast USB 3.0 key moved from one node to another one may be better than several slow USB keys in parallel.

USB cables or kesy need to be slim enough to not get pushed by VGA cable which can cause read errors.

Forums