Data Backup and Recovery Discussions

Can't split clone for SQL backup on SnapCenter 4.3

Maybe I don’t understand something, but ... Does SnapCenter 4.3 support clone splitting for SQL databases resides on LUN?

When I try to split the clone I got the following error: "Failed to get the SMB server for storage system".
Which SMB server was looking for?

 

2020-01-17_15-01-33.jpg

11 REPLIES 11

Re: Can't split clone for SQL backup on SnapCenter 4.3

Hi,

 

Could you check the logs - If there is more information that we can work with ?

 

It says "SMB" so can't be LUN, wher does it resides ?

 

Logs:
Log location comes from Sanpcenter documentation, I don't have snapcenter installed hence can't verify.
The log files are located at /var/opt/snapcenter/spl/logs. You can also download the log files from the SnapCenter user interface by clicking Monitor > Logs > Download.

 

According to this TR: (For SMB shares only)
SnapCenter currently does not support backup, restore, or cloning for databases on SMB shares.
Best Practices Guide for Microsoft SQL Server with ONTAP
https://www.netapp.com/us/media/tr-4590.pdf

 

SnapCenter Plug-in for Microsoft SQL Server features:https://docs.netapp.com/ocsc-43/index.jsp
Supports provisioning SMB shares only. Support is not provided for backing up SQL Server databases on SMB shares.

 

If it's on LUN : Check if you can resolve SMB server hostname (dh-san-02) from Snapcenter?

 

Thanks!

Re: Can't split clone for SQL backup on SnapCenter 4.3

Hello,

 

The "dh-san-02" SVM have one and only the iSCSI service. Therefore, I am very surprised why suddenly SMB:

 

anno1.png

No, "dh-san-02" does not resolving from SnapCenter. I don't maked any DNS records for it.

The log file for this job was attached.

 

Thank you for your reply!

Re: Can't split clone for SQL backup on SnapCenter 4.3

Hi,

 

I will take a look at the logs later (as soon I get some time).

 

I remember something from SnapManager days (snapDrive). I don't know if you have used SMSQL product before, but there was a requirement for 'snapdrive' to have access to CIFS/SMB from host (where snapdrive was installed) it was required in order to open a tcp port under RPC hood to talk to storage system (other option was http/https if you remeber).

 

When it comes to SnapCenter, I think the plug-ins have inbuilt snapdrive capability and it may be what it requires to talk back to storage system. It has nothing to do with LUN, but it may require it to talk to storage system.

 

Can you try this out, while I have your logs checked.

1) Can you setup CIFS on the SVM (Where iSCSI/LUNs provisioned -dh-san-02) - You can delete it later,  so no harm.
2) Ensure the Host (where Plug-ins installed) can resolve to storage hostname (dh-san-02), if not add it in DNS or manually create storage host to IP entry on each host.
3) Try split-clone again

 

In the mean-time, also talk to NetApp support (Incase you haven't already raised a ticket). We need to understand, how it all works in Snacenter , b'cos there are number of components such as : snapcenter server, sm service, hosts  plug-ins etc, unless we know how inter-communication works, we cannot troubleshoot.

 

Thanks!

Re: Can't split clone for SQL backup on SnapCenter 4.3

Well, I have done the following things:

 

  1. Enabled CIFS services in this SMV
  2. Created same name CIFS server (dh-san-02) on this SVM
  3. Created and applied appropriate export policy
  4. Created separate network interface
  5. Created appropriate DNS records

Now, the \\dh-san-02 is available from the SnapCenter server and SQL server which hosts the SCSQL plugin.

Also, I rediscovered entire cluster in the SnapCenter and restarted SnapCenter service.

 

No luck (( Same error message...

Went to create the support ticket...

Anyway - thanks for trying to help!

Re: Can't split clone for SQL backup on SnapCenter 4.3

Thanks for the update. Good you raised a ticket with NetApp, do that always in parallel if it's urgent.

 

Also, I was reading my notes about RPC: SnapDrive does not support the RPC protocol in a clustered Data ONTAP environment; you must use HTTP or HTTPS protocol. So that logic does not apply (CIFS) Smiley Sad

 

Can you verify the following:

::>event log show

::> event log show -node node (that hosts the SVM vols)

is there anything wrt the error ?

 

 

Do keep us updated.

Re: Can't split clone for SQL backup on SnapCenter 4.3

event log show doesn't show any error at all.

And I also noticed that the execution of the cmdlet Invoke-SmResourceSplit -Estimate gives exactly the same result:

2020-01-22_15-21-56.jpg

Re: Can't split clone for SQL backup on SnapCenter 4.3

ok..

 

I am just trying to find the whole logic of SMB in iSCSI environment.

 

Reading from the tr-4714
SnapCenter uses SM Service, which is a NetApp SnapManager® web service running on top of Windows Server (IIS) on the SnapCenter Server. SM Service takes all client requests such as backup, restore, clone, and so on. The SnapCenter Server communicates those requests to SMCore, which is a service that runs colocated within the SnapCenter Server

 

Basically: In order to 'start clone' , SM Service & SMCore are key elements , that means somewhere this communication is not happening.

 

Could you give me this info:
::> network interface show -vserver <vserver> i.e dh-san-02

 

How is the NetApp storage (SVM) added in Snapcenter ? What IP/LIF type it is? using SVM Management IP ?

 

 

How is your setup, hows LUNs used as, datastore ?

Re: Can't split clone for SQL backup on SnapCenter 4.3

Well, dh-san-02 has four interfaces:

2020-01-23_12-15-27.jpg

10.10.11.0 network - this is a 1G network. Cluster management LIF, SnapCenter server and SQL server resides in this network.

All SVM doesn't has a management LIF and doesn't managed separately in SnapCenter.

The SQL server has only one interface in the 10.10.11.0 network.

Re: Can't split clone for SQL backup on SnapCenter 4.3

Ok...we might be getting closer.

 

For SAN Protocols (iSCSI/FC) a dedicated SVM management LIF is required because data protocols and management protocols cannot share the same LIF.

 

1) Please create a SVM Management LIF

cluster::> network interface create -vserver dh-san-02 -lif SVM_mgmt_LIF_name -role data -data-protocol none -address x.x.x.x -netmask x.x.x.x -home-node node_a_or_b -home-port e0M -status-admin up

 

2) You mentioned SVM are not managed separately in snapcenter ? Please add the SVM directly instead of the Cluster, using the IP created in step 1.

 

3) I don't have SnapCenter console so I am kind of blind here, but figure out how you need to configure : If you need to re-discover it whatever.

 

Give this a try. Snapcenter must talk back to Storage via SVM Manamgnet LIF for Management related ZAPI calls.

Try the new BETA Support Site!
Beta Support Site
Forums