Data Backup and Recovery Discussions

Data Broker 1.0 - cannot register SnapCenter Plug-in for vm with SnapCenter 4.2

Hi guys,

 

I want to backup vm guest os using SnapCenter, and deployed Data Broker 1.0 and SnapCenter 4.2

for vCenter 6.7.

After installing and initial setup SnapCenter and Data Broker, I tried to register and add host in SnapCenter

as vSphere. (Data Broker 1.0 deployment, page 18)

After clicking Submit, I encountered the following error and couldn't regiter Data Broker with vSphere type.

 

---

Failed to register host <DATA BROKER IP>. Error: Failed to find host (<DATA BROKER IP>). Verify if the host is up and running and check the DNS and firewall settings. Unknown host.

--

I set a credential of user name and password selected Linux for authentication.

ping to Data Broker from SnapCenter server was ok, and SnapCenter wirewall was all disabled.

After rebooting a Data Broker server and SnapCenter server, the results were not changed.

 

Have you ever encoutered a similar issue? Could you show me the correct steps to register Data Broker?

 

kind regards,

mau

4 REPLIES 4

Re: Data Broker 1.0 - cannot register SnapCenter Plug-in for vm with SnapCenter 4.2

FYI, If you are wanting backups of just the VM's, not application aware backups, then you don't need snapcenter.

 

I have snapcenter 4.2 deployed along with the databroker for application aware backups.  I deployed the databroker, uninstalled the old VSC plug-in from SnapCenter and then added the databroker without issues.  When you added the databroker to snapcenter what host type did you select?  You need to make sure you select the type of vSphere and then put in the IP address and credentials you defined.  Are you able to see the snapcenter plug-in in vCenter?

Re: Data Broker 1.0 - cannot register SnapCenter Plug-in for vm with SnapCenter 4.2

Can you make sure the  Databroker ip and hostname resolution works fine from snapcenter server and re-try adding again.

Re: Data Broker 1.0 - cannot register SnapCenter Plug-in for vm with SnapCenter 4.2

Hi Trubida,

 

Yes, I selected  the type of vSphere and Data Broker credential.

I just aware that after installing  the latest VSC, SnapCenter 4.2 was installed, 

so just an idea that I'm going to  remove the VSC plugin and add the host in SnapCenter.

 

Thanks,

Re: Data Broker 1.0 - cannot register SnapCenter Plug-in for vm with SnapCenter 4.2

Hi pranjith,

 

The Data Broker  installation document descibes that it needs to input Data Broker IP address,

I'm not aware of hostname resolution. After adding A record of Data Broker record,

I'll try to add the host in Snapcenter.

Forums