Data Backup and Recovery Discussions

Data Broker picks wrong LIF for restore

Hi,

 

we are running the Data Broker 1.0.1D for our vCenter backups. All fine except of a restore from secondary.

 

During the restore, the snap shot gets cloned and a export policy conaining all IP adresses of the vCenter is created and attached to the volume clone.

 

Data Broker discovers all storage interfaces.

[DBG] SDGetNetworkInterfacesResponse : SDGetNetworkInterfacesResult : 
Network Interface : Name - SecondaryNetapp-576, Address - 15.16.16.28, StorageSystem - SecondaryNetapp, Protocols - null
Network Interface : Name - SecondaryNetapp-st408, Address - 192.168.5.209, StorageSystem - SecondaryNetapp, Protocols - Nfs
Network Interface : Name - SecondaryNetapp-st801, Address - 50.142.0.22, StorageSystem - SecondaryNetapp, Protocols - Nfs
[INF] End SDGetNetworkInterfaces

 

Now it takes the first useable lif and modifies the mount parameter:

[DBG] Get network NFS lif for owning VServer SecondaryNetapp
[DBG] NFS lif found 192.168.5.209
[DBG] NFS lif found 192.168.5.209
[DBG] Replacing vserver name of clone.FullPath: SecondaryNetapp:/vol/sv_n970340404272009464219816 with IP address 192.168.5.209
[INF] Begin ReplaceSVM
[INF] End ReplaceSVM
[DBG] Replacing vserver name of clone.ResourceName: SecondaryNetapp:/vol/sv_n970340404272009464219816 with IP address 192.168.5.209

 

But the export policy does not contain the IP that fits to the export of 192.*

export-policy rule show  -policyname ExportPolicye09bad2ea81540f193f6becd24990b5d
             Policy          Rule    Access   Client                RO
Vserver      Name            Index   Protocol Match                 Rule
------------ --------------- ------  -------- --------------------- ---------
sv57sko9746  ExportPolicye09bad2ea81540f193f6becd24990b5d 1
                                     any      50.142.0.210            any

 

I also this entry in the logs:

[INF] Begin Get_SVM_Lif_Mapping
[DBG] INFO: Preferred SVM LIF MAPPING not found.
[INF] End Get_SVM_Lif_Mapping
[DBG] NFS lif is not configured. Will process live check.

 

Is there a way to influence the lif selection?

 

Marcus

5 REPLIES 5

Re: Data Broker picks wrong LIF for restore

Hi,

 

I don't have this setup (restore from secondary), so trying to anylze the whole process and see what could be missing. First thing, do we have case raised with NetApp ?

 

Do you mind uploading: SnapCenter full logs.

 

Question:
So, we are restoring the snapshot from the 'secondary', which means we have a Primary SVM that is discovered/added in the SnapCenter. The Primary SVM has a snapshots which is then replicated to the secondary storage under a specific SVM. Is the secondary SVM where the replicated snaps exists, is that SVM discovered/added to SnapCenter server using SVM_mgmt_LIF? Also, can ESXi has a route to talk to secondary SVM or rather the plug-in host can talk to secondary SVM using Management LIF of the secondary SVM?

 

Thanks!

Re: Data Broker picks wrong LIF for restore

Hi,

 

the case it's on his way...

 

Primary and Secondary are defined in Data Broker. You dont need SnapCenter for that anymore.

Backup is running, snapshots are tagged with the right label. All fine here.

ESXi has a couple of possibilities to reach the seconary SVM. 

 

Marcus

 

Re: Data Broker picks wrong LIF for restore

Ok, good you raised ticket. Do let us know once you get resolved.

Re: Data Broker picks wrong LIF for restore

Hi Marcus,

In my case on NDB 1.0.1D1, the issue was similar to described in KB 1080144 (SC restore/clone fails if the SVM has multiple LIFs with the same data-protocol). So the solution worked for me was similar, too.

  1. Access diagnostic shell (maint login to console)
  2. Modify config file
    sudo vi /opt/netapp/protectionservice/publish/storage/appsettings-storage.json
  3. Add following into section "AppSettings":
    "PreferredNFSLIF": "<SVM1 Name>:<Preferred LIF IP>,<SVM2 Name>:<Preferred LIF IP>"
  4. Save config file
  5. Restart services or reboot VM

Hope this helps.

Regards,

Simon

View solution in original post

Re: Data Broker picks wrong LIF for restore

Hi Simon,

 

thanks, that solved my problem!

 

Marcus

Cloud Volumes ONTAP
Review Banner
All Community Forums
Public