Data Backup and Recovery Discussions

Errors trying to get this all working

Hi All,

I'm trying to use SnapCreator to make SnapDrive snapshots on just 1 VM at the moment. I have enabled SnapCreator in the config and set up my NTAP_SNAPSHOT_CREATE command in the config. I do get a snapshot when I run the config but it exits with error code 1 witht he following error:

stdout: [500 read timeout at /<C:\NASC\scServer3.3.0\snapcreator.exe>SnapCreator/Agent/ line 288
stderr: [500 read timeout at /<C:\NASC\scServer3.3.0\snapcreator.exe>SnapCreator/Agent/ line 288
[Wed Mar  2 15:52:07 2011] ERROR: Running snapshot create command ["C:\Program Files\NetApp\SnapDrive\sdcli" snap create -m wit212_Test -s wit212_Test.NSCF-daily-20110302155200 -D G:] failed with exit code [1] and message [500 read timeout at /<C:\NASC\scServer3.3.0\snapcreator.exe>SnapCreator/Agent/ line 288

I also have the config setup to report to OpsManager but I get an error there as well. That error is:

[Wed Mar  2 15:52:07 2011] INFO: Creating OM Event (script:critical-event) on xx.xx.xx.xx
[Wed Mar  2 15:52:07 2011] ERROR: Data Fabric Server service is not running (code = 13001)
[Wed Mar  2 15:52:07 2011] ERROR: in Zapi::invoke failed to connect SSL Inappropriate I/O control operation (code = 13001)
[Wed Mar  2 15:52:07 2011] DEBUG: Exiting with error code - 1

The obvious thing I see in that error is the Data Fabric server service is not running but it actually is running.

Environment Details:

VM target server is W2K3


SnapDrive 6.3

DataOnTap 7.3.2

SnapCreator server is currently on an XP desktop for testing

OpsManager 4.0

Any help anyone could offer with either of these 2 issues would be greatly appreciated.


Re: Errors trying to get this all working


I would recommend opening a support case with NGS since Snap Creator 3.3.0 is supported, they can help much better that folks on communities.

However I did take a quick look in config file.

1. Your agent timeout is set to 5 seconds, I have never in seen SnapDrive complete in 5 seconds. Try increasing SC_AGENT_TIMEOUT. This is the time the server waits to hear response from agent.


2. Operations Manager issue appears to be that you are using HTTPS TRANSPORT=HTTPS and are using HTTP port for OM 8088, try changing OM port to 8488


SC is all or nothing either you use HTTP or HTTPS for everything, same goes w/password protection



View solution in original post

Re: Errors trying to get this all working

Actually both your answers solved each of my problems. Thanks for taking time to look and respond!

Re: Errors trying to get this all working

Glad to hear

Happy SnapCreating!

Cloud Volumes ONTAP
Review Banner
All Community Forums